summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sratom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sratom')
-rw-r--r--media-libs/sratom/Manifest2
-rw-r--r--media-libs/sratom/metadata.xml5
-rw-r--r--media-libs/sratom/sratom-0.4.4.ebuild41
-rw-r--r--media-libs/sratom/sratom-0.4.6.ebuild44
4 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/sratom/Manifest b/media-libs/sratom/Manifest
new file mode 100644
index 000000000000..3aabc6069dc3
--- /dev/null
+++ b/media-libs/sratom/Manifest
@@ -0,0 +1,2 @@
+DIST sratom-0.4.4.tar.bz2 134625 SHA256 fa0c29f4fed822d5d2c41e4b4694d3a01bda1e25ae16af1054b85ad42a2180e0 SHA512 f485da575810348ed9f5016d326b1e82bd9e52d096fa91598c626bdad3f3ba15bbacdd5153b09134f1ad3112fc00132678d096e38f9f7ce2af3cef9f6fe1585a WHIRLPOOL 9dafa3ec0990b8f562d11efe6870e3b0a47e86b15f79665d1677e9cf30b9f75607d3f76a299c6c63b38b2c2a1a364e3e62131ca86aac084dd3ab008808ff272b
+DIST sratom-0.4.6.tar.bz2 138165 SHA256 a4b9beaeaedc4f651beb15cd1cfedff905b0726a9010548483475ad97d941220 SHA512 198ab8fd7b027bf62db5d215e1af020695304339df552af6a336be661b30228d9c1ab2befeca959fdde0920dad2c33666fbd6bbf833ba1e24e4fde23d850dc0e WHIRLPOOL 82e0f8ab618b911b949da3d4d42e9084f906476f626d743a9920b572b64b6bf472ad1041bf07c64135636e88ec9f5ef62769c75aff3468ad5d4cd93a12b1f281
diff --git a/media-libs/sratom/metadata.xml b/media-libs/sratom/metadata.xml
new file mode 100644
index 000000000000..0dc3775f83d7
--- /dev/null
+++ b/media-libs/sratom/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>
diff --git a/media-libs/sratom/sratom-0.4.4.ebuild b/media-libs/sratom/sratom-0.4.4.ebuild
new file mode 100644
index 000000000000..1d56ece69529
--- /dev/null
+++ b/media-libs/sratom/sratom-0.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lv2
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}
diff --git a/media-libs/sratom/sratom-0.4.6.ebuild b/media-libs/sratom/sratom-0.4.6.ebuild
new file mode 100644
index 000000000000..2943c45017ee
--- /dev/null
+++ b/media-libs/sratom/sratom-0.4.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=media-libs/lv2-1.8.1
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}