summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-11 12:50:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-11 12:58:38 +0200
commit9059893740d48af00972496e76310f12460c6e61 (patch)
tree33897d8a1a714dc0413b2df4da62d8eebd808daa /media-libs/zimg
parentmedia-libs/zimg: Remove old (diff)
downloadgentoo-9059893740d48af00972496e76310f12460c6e61.tar.gz
gentoo-9059893740d48af00972496e76310f12460c6e61.tar.bz2
gentoo-9059893740d48af00972496e76310f12460c6e61.zip
media-libs/zimg: bump to 3.0.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/zimg')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-3.0.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index eda1f0e39ab1..c65862038c88 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1,2 +1,3 @@
DIST zimg-2.9.2.tar.gz 266049 BLAKE2B 214a6afec061dc7cc7c751f2a57e56951e44b78fea6a0c0dc71235d3dd286fb811303b0a5198ab82165ee78d993caabaf39d7ec17db4c4e5ffca9a3475b49781 SHA512 b688f8e93a2e4549f2c844cd58c6e0714e6494d6fc8c800dc1b0cdf2278fb9925a646fc332350c1b5d77cef2134bf35e18a873c24ea1979c1adce57bfef68ebe
DIST zimg-3.0.1.tar.gz 326304 BLAKE2B 353e623520df49122badd2d58400936fd25bf74fe386ade6b7a5c1b86db696dd50ff72ff40e1edbd38ee9a8a10dd429f207061fdb2ea326018396dfb92707053 SHA512 ae117399772d2c35ffa61b8cf5d156edf4ed65e9ffeb2e9e0688c88244fdd1a89c098bd842e3795b33fb0951da97f844fb6ffe27045e3234720f70f842356936
+DIST zimg-3.0.2.tar.gz 326554 BLAKE2B 2ebea0060519a6912caf685ec551ed60f64f3e379629c607ad21d256daa549a2e85e2c8dbc0886846e9636508576680ed60353d569aef407879ba5fa7dd3001d SHA512 6aed45c19a07862d389dfc2903a7ed9c0c6b6faa23e1d5de5483f15f1c3fb44a31c954004b8b9f34def0d387a43590d9403d9e24a99a271bcadc373c6ce30d42
diff --git a/media-libs/zimg/zimg-3.0.2.ebuild b/media-libs/zimg/zimg-3.0.2.ebuild
new file mode 100644
index 000000000000..c7a443af6834
--- /dev/null
+++ b/media-libs/zimg/zimg-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="debug static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}