summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-02-19 13:32:56 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-02-19 13:33:23 +1100
commitb8b0d3d717a857aa1d86a027f245b09a83d542d7 (patch)
tree6b160c2d003386323fee428062056f05ad7b2c16 /media-libs
parentprofiles: mask >=media-gfx/libopenraw-0.1.0 due to revdep breakagea (diff)
downloadgentoo-b8b0d3d717a857aa1d86a027f245b09a83d542d7.tar.gz
gentoo-b8b0d3d717a857aa1d86a027f245b09a83d542d7.tar.bz2
gentoo-b8b0d3d717a857aa1d86a027f245b09a83d542d7.zip
media-libs/libopenraw: version bump 0.1.0
Gentoo-bug: 601240 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libopenraw/Manifest1
-rw-r--r--media-libs/libopenraw/files/libopenraw-0.1.0-jpeg-9a.patch24
-rw-r--r--media-libs/libopenraw/libopenraw-0.1.0.ebuild60
3 files changed, 85 insertions, 0 deletions
diff --git a/media-libs/libopenraw/Manifest b/media-libs/libopenraw/Manifest
index 3acd570a30fc..b267853e7e82 100644
--- a/media-libs/libopenraw/Manifest
+++ b/media-libs/libopenraw/Manifest
@@ -1 +1,2 @@
DIST libopenraw-0.0.9.tar.bz2 478687 SHA256 49fd1adf0a0228c7a17a79bf98d8d03664195feae1e50f4ddd1b20162626e18f SHA512 88d475d27719212686a0a5a08da04d6879fd456ec8f7531f401217df97f4f3d4c52dc8c4fb1c6ca88c12d6a67ecd516b151c5e9dceba9cbfcd13150fe81d6db5 WHIRLPOOL 52d407b1d443fe7c38c59274b3267feb4dffeca9114a39cad925c346ae21d1378cbceba4ce1973657073f8890bf50a18c476ba3451d806fe7f50824bb935c559
+DIST libopenraw-0.1.0.tar.bz2 525449 SHA256 4dede1db9b85c9c22a1ddaf37839f2713746a00b81a6d4623d66556000cb76cf SHA512 f3b867d831d03350e487a98f08cadf6a24d5e4296129a401c0066cfdf0e628663e821ed0b7e42613d1533513a9c36a1693d6c3cbbd918246dbdfbb111b5a470a WHIRLPOOL 4101f34e20d4f73560086ed849b5c648eb3f399610ee77285361a13f1343255d2f95bd6b045b80505695e4f0125d491cec37e0f8c525d953a7bf12009f031875
diff --git a/media-libs/libopenraw/files/libopenraw-0.1.0-jpeg-9a.patch b/media-libs/libopenraw/files/libopenraw-0.1.0-jpeg-9a.patch
new file mode 100644
index 000000000000..e5156a953211
--- /dev/null
+++ b/media-libs/libopenraw/files/libopenraw-0.1.0-jpeg-9a.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/520888
+https://sourceforge.net/p/fink/package-submissions/4336/
+
+
+--- a/lib/jfifcontainer.cpp
++++ b/lib/jfifcontainer.cpp
+@@ -157,7 +157,7 @@
+ m_file->seek(0, SEEK_SET);
+
+ if (::setjmp(m_jpegjmp) == 0) {
+- int ret = JPEG::jpeg_read_header(&m_cinfo, TRUE);
++ int ret = JPEG::jpeg_read_header(&m_cinfo, JPEG::TRUE);
+ //Trace(DEBUG1) << "jpeg_read_header " << ret << "\n";
+
+ JPEG::jpeg_calc_output_dimensions(&m_cinfo);
+@@ -194,7 +194,7 @@
+ src->pub.next_input_byte = nullptr;
+ src->pub.bytes_in_buffer = 0;
+ }
+- return TRUE;
++ return JPEG::TRUE;
+ }
+
+
diff --git a/media-libs/libopenraw/libopenraw-0.1.0.ebuild b/media-libs/libopenraw/libopenraw-0.1.0.ebuild
new file mode 100644
index 000000000000..29ddc8b3a642
--- /dev/null
+++ b/media-libs/libopenraw/libopenraw-0.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="A decoding library for RAW image formats"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/"
+SRC_URI="https://${PN}.freedesktop.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="gtk static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ virtual/jpeg:0
+ gtk? (
+ dev-libs/glib:2
+ >=x11-libs/gdk-pixbuf-2.24.0:2
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.35
+ virtual/pkgconfig
+ test? ( net-misc/curl )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ has_version '>=media-libs/jpeg-9a:0' && epatch "${FILESDIR}"/${P}-jpeg-9a.patch
+ default
+}
+
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ $(use_enable static-libs static) \
+ $(use_enable gtk gnome)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ use gtk && gnome2_gdk_pixbuf_savelist
+}
+
+pkg_postinst() {
+ use gtk && gnome2_gdk_pixbuf_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_gdk_pixbuf_update
+}