summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-12-21 20:01:12 +0100
committerSam James <sam@gentoo.org>2020-12-27 21:40:15 +0000
commite5bbb26bd5f3591dd6770219a33c201c0f404d38 (patch)
tree25588ddc6266ceb9104903ff3ead2941b874c246 /media-libs
parentdev-libs/cudnn: Remove old (diff)
downloadgentoo-e5bbb26bd5f3591dd6770219a33c201c0f404d38.tar.gz
gentoo-e5bbb26bd5f3591dd6770219a33c201c0f404d38.tar.bz2
gentoo-e5bbb26bd5f3591dd6770219a33c201c0f404d38.zip
media-libs/ilmbase: bump to 2.5.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ilmbase/Manifest1
-rw-r--r--media-libs/ilmbase/ilmbase-2.5.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/ilmbase/Manifest b/media-libs/ilmbase/Manifest
index 57134a0ad812..2418671100a6 100644
--- a/media-libs/ilmbase/Manifest
+++ b/media-libs/ilmbase/Manifest
@@ -1,2 +1,3 @@
DIST ilmbase-2.3.0.tar.gz 595490 BLAKE2B db956fe7dbabf94632eb98635f4ebda8e937f26e26ed69f33743069fa2bf6d5ed3711f00eb33377c98b4f8ea367bbfc51b11d4cb884ce02238b537857cc19a9c SHA512 db0804a7c37c2a97f9dbf81b20f40f7fdea73242baa2759d9dc3728e6849e7ecae0e178fa1c710add980d050499151650675e4b2cda6cbbaa61aca406a1f929a
DIST ilmbase-2.5.2.tar.gz 27525326 BLAKE2B c48a61513457f2c04f3a512963ae27eaf154933ffe7c6ff3e2d71f27f246ae624a34dbe6f8ab500c51a56898ad0f61e6784f5cd3f9c3df591ce347b46ba4ac88 SHA512 62f98695cf56600303db9c2d13d34cacc1851a103d8ffb7e7ce8c6d9d14e6bf02804836c718ae03e8d685ef3dda0cf7b2130e2d363f8095b22a15bf30d706fab
+DIST ilmbase-2.5.3.tar.gz 27534825 BLAKE2B 4647b4aac074b10c0d1fb35ddb6b5acefca81c0f2debde04987b5df4e290b14b6406fc922949449aaeea7cf4be371a25c93f8fcb9f67c63d65276340bd586a21 SHA512 6da03193d4fea1e97e35008f59304ab408c521ead8495ba411cde5c172cf953be97999971f57398b813d14f1af1d722539a6b74d5ee54b9e74769ea8258d36ba
diff --git a/media-libs/ilmbase/ilmbase-2.5.3.ebuild b/media-libs/ilmbase/ilmbase-2.5.3.ebuild
new file mode 100644
index 000000000000..36e14655d113
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+KEYWORDS="~amd64 -arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="large-stack static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/openexr-${PV}/IlmBase"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DILMBASE_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DILMBASE_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DILMBASE_INSTALL_PKG_CONFIG=ON
+ )
+
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ mycmakeargs+=(
+ -DILMBASE_HAVE_UCONTEXT_H=OFF
+ )
+ fi
+
+ # needed for running tests with x86_32
+ # see https://github.com/AcademySoftwareFoundation/openexr/issues/346
+ if use abi_x86_32 && use test; then
+ append-cppflags -ffloat-store
+ fi
+
+ cmake_src_configure
+}