summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-24 13:06:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-24 13:06:31 +0200
commitfd52499959f722329caecf12c8ca58e04400e2c4 (patch)
tree99bef686225e5f2e5180c1a0cf7b3d09bbe9beb1 /media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild
parentdev-libs/botan: version bump (diff)
downloadgentoo-fd52499959f722329caecf12c8ca58e04400e2c4.tar.gz
gentoo-fd52499959f722329caecf12c8ca58e04400e2c4.tar.bz2
gentoo-fd52499959f722329caecf12c8ca58e04400e2c4.zip
media-plugins/vdr-imonlcd: Bump to version 1.0.2
Also fix detection of freetype (via pkg-config) Closes: https://bugs.gentoo.org/661590 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild')
-rw-r--r--media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild b/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild
new file mode 100644
index 000000000000..d67f1e90c8a2
--- /dev/null
+++ b/media-plugins/vdr-imonlcd/vdr-imonlcd-1.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vdr-plugin-2 linux-info udev
+
+VERSION="2086" # every bump, new version
+
+DESCRIPTION="VDR Plugin: shows information about the current state of VDR on iMON LCD"
+HOMEPAGE="http://projects.vdr-developer.org/wiki/plg-imonlcd"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freetype"
+DEPEND="${RDEPEND}
+ media-video/vdr"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.2-freetype_pkgconfig.patch"
+)
+
+CONFIG_CHECK="~IR_IMON"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ vdr-plugin-2_pkg_setup
+}
+
+src_install() {
+ rm -f README.git
+ vdr-plugin-2_src_install
+
+ insinto $(get_udevdir)/rules.d
+ doins "${FILESDIR}"/99-imonlcd.rules || die
+}