summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-rotor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-rotor')
-rw-r--r--media-plugins/vdr-rotor/Manifest1
-rw-r--r--media-plugins/vdr-rotor/files/vdr-rotor-0.1.5_vdr-1.7.13.diff30
-rw-r--r--media-plugins/vdr-rotor/metadata.xml12
-rw-r--r--media-plugins/vdr-rotor/vdr-rotor-0.1.5.ebuild37
4 files changed, 80 insertions, 0 deletions
diff --git a/media-plugins/vdr-rotor/Manifest b/media-plugins/vdr-rotor/Manifest
new file mode 100644
index 000000000000..7ebe9f343dde
--- /dev/null
+++ b/media-plugins/vdr-rotor/Manifest
@@ -0,0 +1 @@
+DIST vdr-rotor-0.1.5.tgz 40027 RMD160 89806b83fe0d37e661401425890524b49fc7e49e SHA1 8da30583b3d5ff06422c7d3a522325af5de9ab68 SHA256 fa13b710a1d547d9df841b881c40c9fb301aaf969fca9e71f50360a9edfabab6
diff --git a/media-plugins/vdr-rotor/files/vdr-rotor-0.1.5_vdr-1.7.13.diff b/media-plugins/vdr-rotor/files/vdr-rotor-0.1.5_vdr-1.7.13.diff
new file mode 100644
index 000000000000..7e24f08d2e53
--- /dev/null
+++ b/media-plugins/vdr-rotor/files/vdr-rotor-0.1.5_vdr-1.7.13.diff
@@ -0,0 +1,30 @@
+http://www.forum.free-x.de/wbb/index.php?page=Thread&postID=13727#post13727
+
+fix compile problems vdr up 1.7.13
+diff -u orig/rotor-0.1.5/menu.c rotor-0.1.5/menu.c
+--- orig/rotor-0.1.5/menu.c 2009-10-04 14:54:22.000000000 +0300
++++ rotor-0.1.5/menu.c 2010-03-06 22:42:23.000000000 +0200
+@@ -139,7 +139,8 @@
+ RotorPos=RotorPositions.GetfromSource(OldChannel->Source());
+ Position=RotorPos->GetPos();
+ Frequenz=OldChannel->Frequency();
+- if ((*OldChannel).Polarization() == 'v' || (*OldChannel).Polarization() == 'V')
++ cDvbTransponderParameters dtp((*OldChannel).Parameters());
++ if (dtp.Polarization() == 'v' || dtp.Polarization() == 'V')
+ Pol='V';
+ else
+ Pol='H';
+Общие подкаталоги: orig/rotor-0.1.5/patches и rotor-0.1.5/patches
+Общие подкаталоги: orig/rotor-0.1.5/po и rotor-0.1.5/po
+diff -u orig/rotor-0.1.5/rotor.c rotor-0.1.5/rotor.c
+--- orig/rotor-0.1.5/rotor.c 2009-10-04 15:10:26.000000000 +0300
++++ rotor-0.1.5/rotor.c 2010-03-05 23:07:52.000000000 +0200
+@@ -93,7 +93,7 @@
+ {
+ if ((source->Code() & 0xC000) != 0x8000)
+ continue;
+- if ((diseqc=Diseqcs.Get(source->Code(),12000,'h')) || (diseqc=Diseqcs.Get(source->Code(),12000,'v')) || (diseqc=Diseqcs.Get(source->Code(),12000,'l')) || (diseqc=Diseqcs.Get(source->Code(),12000,'r')))
++ if ((diseqc=Diseqcs.Get(0,source->Code(),12000,'h')) || (diseqc=Diseqcs.Get(0,source->Code(),12000,'v')) || (diseqc=Diseqcs.Get(0,source->Code(),12000,'l')) || (diseqc=Diseqcs.Get(0,source->Code(),12000,'r')))
+ {
+ char *c=strdup(diseqc->Commands());
+ while (c = strchr(c, '['))
diff --git a/media-plugins/vdr-rotor/metadata.xml b/media-plugins/vdr-rotor/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-rotor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-rotor/vdr-rotor-0.1.5.ebuild b/media-plugins/vdr-rotor/vdr-rotor-0.1.5.ebuild
new file mode 100644
index 000000000000..882a7e0b90b5
--- /dev/null
+++ b/media-plugins/vdr-rotor/vdr-rotor-0.1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Add support for dishes with rotation control engine"
+HOMEPAGE="http://home.vrweb.de/~bergwinkl.thomas/"
+SRC_URI="http://home.vrweb.de/~bergwinkl.thomas/downro/${P}.tgz"
+LICENSE="GPL-2"
+
+KEYWORDS="x86 amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6.0[rotor]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ elog "Checking for patched vdr"
+ if ! grep -q SendDiseqcCmd /usr/include/vdr/device.h; then
+ ewarn "You need to emerge vdr with use-flag rotor set!"
+ die "Unpatched vdr detected!"
+ fi
+}
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-1.7.13"; then
+ epatch "${FILESDIR}/${P}_vdr-1.7.13.diff"
+ fi
+}