summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-04 10:59:02 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-04 11:30:16 +0100
commit3bf8155fb304bc2290d04d2237a65a82b7a921dd (patch)
treefa305a51bd42f3be83283076051b59b2e32787f0 /media-sound/terminatorx
parentapp-emulation/xen: drop old vulnerable version (diff)
downloadgentoo-3bf8155fb304bc2290d04d2237a65a82b7a921dd.tar.gz
gentoo-3bf8155fb304bc2290d04d2237a65a82b7a921dd.tar.bz2
gentoo-3bf8155fb304bc2290d04d2237a65a82b7a921dd.zip
media-sound/terminatorx: Version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-sound/terminatorx')
-rw-r--r--media-sound/terminatorx/Manifest1
-rw-r--r--media-sound/terminatorx/terminatorx-4.0.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/terminatorx/Manifest b/media-sound/terminatorx/Manifest
index 8e9191d2c7ee..71f2d6856a05 100644
--- a/media-sound/terminatorx/Manifest
+++ b/media-sound/terminatorx/Manifest
@@ -1 +1,2 @@
DIST terminatorX-3.84.tar.gz 572143 SHA256 0680b94aa3cbe77d1f1193be2b84a7d7b250c213cfa2da68241a2294ac5dfc37 SHA512 9b538007acc98b1dd7bb2e310be53bcf1971a94e5c03ea8ca48c59b05f1a0bddd75bf30ab4cfb03d49165098ba63643eaa3bda117cdf833df2438c29a774db6c WHIRLPOOL 1cf156623ff6ea410a701ac3b5613740b6d55ce9cd40ad22bd75e44fc404241fd6737705beeb75ff7631be0615ab84938f88d6fcb62cc5561be978be66d73290
+DIST terminatorX-4.0.1.tar.bz2 1832692 SHA256 96e2e7910d96b9bdadb315727c4127cfda579bd68d2b25d99cd9d35e9fbea56a SHA512 06128633e128f2158367dcde0e913dafc68d62644e7a5182a2391829dadcb9c46430d0cac16cb17113939623266f32cb4624a8548a51b8c01bdfa2860a6c0093 WHIRLPOOL d7bdf09d8d588e91f7a94c4fa679e5f7bff3363fff75b8ef7a29fbefee180b66eae37521f28d299fc8ab8a0f8843c76fb9c421f76e0dc488653e3489be19ef5b
diff --git a/media-sound/terminatorx/terminatorx-4.0.1.ebuild b/media-sound/terminatorx/terminatorx-4.0.1.ebuild
new file mode 100644
index 000000000000..bec9cd933502
--- /dev/null
+++ b/media-sound/terminatorx/terminatorx-4.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+MY_P=${P/terminatorx/terminatorX}
+DESCRIPTION='realtime audio synthesizer that allows you to "scratch" on digitally sampled audio data'
+HOMEPAGE="http://www.terminatorx.org/"
+SRC_URI="http://www.terminatorx.org/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X alsa debug mad pulseaudio vorbis sox"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ mad? ( media-sound/madplay )
+ pulseaudio? ( media-sound/pulseaudio )
+ vorbis? ( media-libs/libvorbis )
+ sox? ( media-sound/sox
+ media-sound/mpg123 )
+ x11-libs/gtk+:3
+ >=dev-libs/glib-2.2:2
+
+ X? (
+ x11-libs/libXi
+ x11-libs/libXxf86dga
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/xf86dgaproto )
+ dev-libs/libxml2:2
+ media-libs/audiofile:=
+ media-libs/ladspa-sdk
+ media-libs/ladspa-cmt
+ media-libs/liblrdf
+"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable mad) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable vorbis) \
+ $(use_enable sox) \
+ $(use_enable X x11)
+}