summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-02 09:49:10 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-02 09:51:50 +0100
commit492fa59cd6298e4d80717571bdbaaf01a9540c0e (patch)
tree6eea28ceda4a531c30264f5b87c9e056ae06fc69 /media-sound/umix
parentvcs-clean.eclass: Split off clean helpers from eutils.eclass. (diff)
downloadgentoo-492fa59cd6298e4d80717571bdbaaf01a9540c0e.tar.gz
gentoo-492fa59cd6298e4d80717571bdbaaf01a9540c0e.tar.bz2
gentoo-492fa59cd6298e4d80717571bdbaaf01a9540c0e.zip
media-sound/umix: Fix building against sys-libs/ncurses[tinfo] (bug #647164).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound/umix')
-rw-r--r--media-sound/umix/files/umix-1.0.2-tinfo.patch18
-rw-r--r--media-sound/umix/umix-1.0.2-r1.ebuild37
2 files changed, 55 insertions, 0 deletions
diff --git a/media-sound/umix/files/umix-1.0.2-tinfo.patch b/media-sound/umix/files/umix-1.0.2-tinfo.patch
new file mode 100644
index 000000000000..65c0d7158375
--- /dev/null
+++ b/media-sound/umix/files/umix-1.0.2-tinfo.patch
@@ -0,0 +1,18 @@
+--- a/configure.in
++++ b/configure.in
+@@ -89,6 +89,7 @@
+ then
+ AC_CHECK_LIB(curses, initscr, NCURSLIB="curses", NCURSLIB="")
+ fi
++ AC_SEARCH_LIBS(stdscr,tinfo)
+ fi
+ if test "x$NCURSLIB" != "x"
+ then
+@@ -97,6 +98,7 @@
+ AC_DEFINE(HAVE_NCURSES)
+ LIBS="$LIBS -l$NCURSLIB"
+ umix_CONDOBJS="$umix_CONDOBJS ui_ncurses.o"
++ AC_SEARCH_LIBS(stdscr,tinfo)
+ else
+ have_ncurses="no"
+ fi
diff --git a/media-sound/umix/umix-1.0.2-r1.ebuild b/media-sound/umix/umix-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..15fe8ccf878f
--- /dev/null
+++ b/media-sound/umix/umix-1.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Program for adjusting soundcard volumes"
+HOMEPAGE="http://umix.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="ncurses oss"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2 )"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+DOCS=(
+ AUTHORS ChangeLog NEWS README TODO
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ncurses || myconf="--disable-ncurses"
+ use oss || myconf="${myconf} --disable-oss"
+ econf ${myconf}
+}