summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-13 19:40:28 +0000
committerSam James <sam@gentoo.org>2024-11-13 19:48:34 +0000
commit38f7eb601588a17764b7c30298c2673d17f9e929 (patch)
tree840d9fcbee45aad90117af5827655de3b926a6c6 /media-sound
parentmedia-libs/alsa-lib: add 1.2.13 (diff)
downloadgentoo-38f7eb601588a17764b7c30298c2673d17f9e929.tar.gz
gentoo-38f7eb601588a17764b7c30298c2673d17f9e929.tar.bz2
gentoo-38f7eb601588a17764b7c30298c2673d17f9e929.zip
media-sound/alsa-utils: add 1.2.13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.2.13.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index 87400e9dc508..92094324e448 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,2 +1,3 @@
DIST alsa-utils-1.2.11.tar.bz2 1627148 BLAKE2B dcf96705f9e3f1b4abaa7e1f107d1154a05500bf1cd07c821e0fe8c4ba7d7f08de0cf126be8c9c8dda3980d85c144318c12ffc8a95d5da4e98c49a6e9c2ee8ef SHA512 5ce76807b53357584bfb4ace5acfdac4db9168ffaf5cdd1e499738eec046c36112bf84a99970f66368063a9baf73bad93af2d439630572f3eba5c9321071172d
DIST alsa-utils-1.2.12.tar.bz2 1631895 BLAKE2B 3b049af3f829c475e0d9a58fbd8adb7278f0a7a84d404d1141ac8c8639f8d66594efe9e7da239a2b7a54f788639df1bbade127b5fde9912de5227e2b959a9b4d SHA512 6631f9f8e32fbb1f7b06af086cdfb8349c2d70188c4509ab46fa105024fbde9985985d9cc738c7b5a743cacaaeae7a7006f8ef92f66a50762f7df5d714bf548b
+DIST alsa-utils-1.2.13.tar.bz2 1642028 BLAKE2B 9bc2bf8e21fb9308c2eabc6612da0848f9ddba45acb8bf8453d9cff7f73fa0267495430a150ea53b28fab8afb69a51e487e8b253dc7501e17d77ea3f6e90bcf7 SHA512 0e2fb5b6e497b977badba2ebe2bddfc819654d24001622e0299e4034210caeeea2f3c2c2d1d260a48caefb6584e0b989fdb7036c6012108c8c38d89b3cb04c78
diff --git a/media-sound/alsa-utils/alsa-utils-1.2.13.ebuild b/media-sound/alsa-utils/alsa-utils-1.2.13.ebuild
new file mode 100644
index 000000000000..0bb1474e3a26
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.2.13.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
+SRC_URI="https://www.alsa-project.org/files/pub/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bat doc +libsamplerate ieee1394 +ncurses nls selinux"
+
+DEPEND="
+ >=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ieee1394? ( media-libs/libffado )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:= )
+ bat? ( sci-libs/fftw:= )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-alsa )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.8-missing_header.patch
+)
+
+src_configure() {
+ export ac_cv_lib_ffado_ffado_streaming_init=$(usex ieee1394)
+
+ local myeconfargs=(
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod, bug #456214
+ --disable-alsaconf
+ --disable-maintainer-mode
+ --with-asound-state-dir="${EPREFIX}"/var/lib/alsa
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
+ $(use_enable bat)
+ $(use_enable libsamplerate alsaloop)
+ $(use_enable ncurses alsamixer)
+ $(use_enable nls)
+ $(usev !doc '--disable-xmlto')
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r8 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ -z ${REPLACING_VERSIONS} ]] && ! systemd_is_booted ; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}