summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-06-24 19:08:34 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-06-24 19:08:34 +0200
commit41512d646a73e1b1f54e3d318992d87cfdeeaa99 (patch)
treedf7206f78a8b50566aabd72f88e80dd8bd5aa278 /media-sound
parentmedia-plugins/vamp-aubio-plugins: eapi7, added python 3.10 & 3.11, deps cleanup (diff)
downloadgentoo-41512d646a73e1b1f54e3d318992d87cfdeeaa99.tar.gz
gentoo-41512d646a73e1b1f54e3d318992d87cfdeeaa99.tar.bz2
gentoo-41512d646a73e1b1f54e3d318992d87cfdeeaa99.zip
media-sound/patchage: removed obsolete 1.0.4
Bug: https://bugs.gentoo.org/850559 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/patchage/Manifest1
-rw-r--r--media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch48
-rw-r--r--media-sound/patchage/patchage-1.0.4.ebuild45
3 files changed, 0 insertions, 94 deletions
diff --git a/media-sound/patchage/Manifest b/media-sound/patchage/Manifest
index 001fd616cfc9..8fca8a198910 100644
--- a/media-sound/patchage/Manifest
+++ b/media-sound/patchage/Manifest
@@ -1,2 +1 @@
-DIST patchage-1.0.4.tar.bz2 661824 BLAKE2B 3e56b7513e19e0acb1ef524ba7d7754699abdb6a968547f7a545c8651f23a33c209b9728dae01d839022ec380185a1673ff58733c1553007a6a3b7c889aa7f03 SHA512 665d81ca16c1052f71c3037d2ad8f9a6120b09a323999468484dda1b4c4b567c36728ebe38c54152406b63a4107f04764d0dede52302bc7a7b124e82132749fb
DIST patchage-1.0.6.tar.bz2 664841 BLAKE2B 72d0de6d12e07ec160f4c59c51f138e1220a1b8994bdab90f56dd715bf16b6f561836d184ec5d5077de3bc7bb5c6778ea2b7bcbf0b33230be662f2b729eac568 SHA512 b7aedcb07da0c81842929833ab93a0b20c08e465bf05ebb4e47670d295c0d4d0d50f0f74001d9264c2c23ef08d3881232e7622ecf101d1d53ffcae2f8c0f31d3
diff --git a/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch b/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch
deleted file mode 100644
index aace519e630d..000000000000
--- a/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/src/JackDbusDriver.cpp b/src/JackDbusDriver.cpp
-index 23c12f2..f49a522 100644
---- a/src/JackDbusDriver.cpp
-+++ b/src/JackDbusDriver.cpp
-@@ -24,6 +24,7 @@
- #include "SignalDirection.hpp"
- #include "make_jack_driver.hpp"
- #include "warnings.hpp"
-+#include "AudioDriver.hpp"
-
- PATCHAGE_DISABLE_FMT_WARNINGS
- #include <fmt/core.h>
-@@ -61,7 +62,7 @@ namespace {
- class JackDriver : public AudioDriver
- {
- public:
-- explicit JackDriver(ILog& log, EventSink emit_event);
-+ explicit JackDriver(ILog& log, Driver::EventSink emit_event);
-
- JackDriver(const JackDriver&) = delete;
- JackDriver& operator=(const JackDriver&) = delete;
-@@ -75,7 +76,7 @@ public:
- void attach(bool launch_daemon) override;
- void detach() override;
- bool is_attached() const override;
-- void refresh(const EventSink& sink) override;
-+ void refresh(const Driver::EventSink& sink) override;
- bool connect(const PortID& tail_id, const PortID& head_id) override;
- bool disconnect(const PortID& tail_id, const PortID& head_id) override;
-
-@@ -129,7 +130,7 @@ private:
- dbus_uint64_t _graph_version;
- };
-
--JackDriver::JackDriver(ILog& log, EventSink emit_event)
-+JackDriver::JackDriver(ILog& log, Driver::EventSink emit_event)
- : AudioDriver{std::move(emit_event)}
- , _log(log)
- , _dbus_error()
-@@ -584,7 +585,7 @@ JackDriver::is_attached() const
- }
-
- void
--JackDriver::refresh(const EventSink& sink)
-+JackDriver::refresh(const Driver::EventSink& sink)
- {
- DBusMessage* reply_ptr = nullptr;
- DBusMessageIter iter = {};
diff --git a/media-sound/patchage/patchage-1.0.4.ebuild b/media-sound/patchage/patchage-1.0.4.ebuild
deleted file mode 100644
index b9a415d93c20..000000000000
--- a/media-sound/patchage/patchage-1.0.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE='threads(+)'
-inherit waf-utils python-any-r1 xdg
-
-DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
-HOMEPAGE="http://drobilla.net/software/patchage"
-SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="alsa debug jack-dbus"
-
-BDEPEND="
- ${PYTHON_DEPS}
- dev-libs/boost
- virtual/pkgconfig
-"
-RDEPEND="dev-cpp/glibmm:2
- dev-cpp/gtkmm:2.4
- media-libs/ganv
- virtual/jack
- alsa? ( media-libs/alsa-lib )
- jack-dbus? (
- dev-libs/dbus-glib
- sys-apps/dbus
- )"
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS NEWS README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-compilation.patch"
-)
-
-src_configure() {
- waf-utils_src_configure \
- $(use debug && echo "--debug") \
- $(use alsa || echo "--no-alsa") \
- $(use jack-dbus && echo "--jack-dbus")
-}