summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-10-16 10:28:12 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-10-16 10:28:12 +0200
commit5f1721daafe7e7860b4182b52653dd55a35d6555 (patch)
tree8ec484303098e4679e8bec1e7f6740d4b0134ff6 /media-sound
parentsec-keys/openpgp-keys-apache-tomcat: dropped obsolete 9.0.81 (diff)
downloadgentoo-5f1721daafe7e7860b4182b52653dd55a35d6555.tar.gz
gentoo-5f1721daafe7e7860b4182b52653dd55a35d6555.tar.bz2
gentoo-5f1721daafe7e7860b4182b52653dd55a35d6555.zip
media-sound/sidplayfp: bump to 2.5.0 + eapi8 + switched to media-libs/libpulse
Closes: https://bugs.gentoo.org/915832 Bug: https://bugs.gentoo.org/897808 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sidplayfp/Manifest1
-rw-r--r--media-sound/sidplayfp/sidplayfp-2.5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/sidplayfp/Manifest b/media-sound/sidplayfp/Manifest
index c32fb96f0fd3..37ea099bf009 100644
--- a/media-sound/sidplayfp/Manifest
+++ b/media-sound/sidplayfp/Manifest
@@ -1 +1,2 @@
DIST sidplayfp-1.4.4.tar.gz 183711 BLAKE2B 31ff002d4cd54e827117e2b2f86d253ee1e0bc07fb6ac777653109585c059311205e141e339a8d8cde08209e1c35776d6f0a0ccf0ad754f78eb5e5f4bafd3cfb SHA512 8375a249da80a10d9c0ef55b35c5b047bf0249393026ad8ff25fb8a2660151f1d482fe581a85c6982b3c70ea257807ce17e1c6011874f10c64bec54a1982ec04
+DIST sidplayfp-2.5.0.tar.gz 249111 BLAKE2B 6ac126ee1f26e2dafe649d1bc64fd053ac6762277996dcbc6704dbda788bd2b3d3d2810aba48a8d9fd62ae92f70773cc93a657198c414327ea18fc074da35c96 SHA512 271d1ef216ace5294084997dc902f74411679b24dd3426248c70004468c0525077f0d6cf187f24715d1b6465abf82236b328904b7c06d4e0f87e159594be6427
diff --git a/media-sound/sidplayfp/sidplayfp-2.5.0.ebuild b/media-sound/sidplayfp/sidplayfp-2.5.0.ebuild
new file mode 100644
index 000000000000..f1866978a2ef
--- /dev/null
+++ b/media-sound/sidplayfp/sidplayfp-2.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa oss pulseaudio"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ media-libs/libsidplayfp
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-libs/libpulse )"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )"
+
+DOCS=( AUTHORS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.4-musl-limits.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use alsa; then
+ sed -i -e 's:alsa >= 1.0:dIsAbLe&:' configure || die
+ fi
+
+ if ! use pulseaudio; then
+ sed -i -e 's:libpulse-simple >= 1.0:dIsAbLe&:' configure || die
+ fi
+}
+
+src_configure() {
+ export ac_cv_header_linux_soundcard_h=$(usex oss)
+
+ econf
+}