summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-06-05 23:52:41 +0400
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-29 11:53:39 +0200
commit7e661952b670451d1efcec5846e1a41003b5b980 (patch)
tree6115beb24f35346aa1f16116b2e83fe12452b06b /media-sound
parentnet-vpn/i2p: drop 2.3.0-r4 (diff)
downloadgentoo-7e661952b670451d1efcec5846e1a41003b5b980.tar.gz
gentoo-7e661952b670451d1efcec5846e1a41003b5b980.tar.bz2
gentoo-7e661952b670451d1efcec5846e1a41003b5b980.zip
media-sound/awesfx: update EAPI 7 -> 8, fix wrong function signature
Closes: https://bugs.gentoo.org/831176 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/37040 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/awesfx/awesfx-0.5.2-r1.ebuild (renamed from media-sound/awesfx/awesfx-0.5.2.ebuild)6
-rw-r--r--media-sound/awesfx/files/awesfx-0.5.2-return-type.patch12
2 files changed, 16 insertions, 2 deletions
diff --git a/media-sound/awesfx/awesfx-0.5.2.ebuild b/media-sound/awesfx/awesfx-0.5.2-r1.ebuild
index 4dc34b5e106d..082914feb1dd 100644
--- a/media-sound/awesfx/awesfx-0.5.2.ebuild
+++ b/media-sound/awesfx/awesfx-0.5.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -21,6 +21,8 @@ BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
+PATCHES="${FILESDIR}/${P}-return-type.patch"
+
src_prepare() {
default
eautoreconf
diff --git a/media-sound/awesfx/files/awesfx-0.5.2-return-type.patch b/media-sound/awesfx/files/awesfx-0.5.2-return-type.patch
new file mode 100644
index 000000000000..2fbe38abaea9
--- /dev/null
+++ b/media-sound/awesfx/files/awesfx-0.5.2-return-type.patch
@@ -0,0 +1,12 @@
+diff -ru a/alsa.c b/alsa.c
+--- a/alsa.c 2024-06-05 19:43:42.987168221 -0000
++++ b/alsa.c 2024-06-05 19:44:48.530787408 -0000
+@@ -139,7 +139,7 @@
+ return snd_hwdep_ioctl(hwdep, SNDRV_EMUX_IOCTL_MISC_MODE, &mode);
+ }
+
+-void seq_set_gus_bank(int bank)
++int seq_set_gus_bank(int bank)
+ {
+ struct sndrv_emux_misc_mode mode;
+ mode.port = -1;