summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-29 18:51:50 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-29 20:14:16 -0400
commit930896984ec102466237163e6672b3285d0649b3 (patch)
tree65dae7dfbdd78583d01e8c7d64b10c7d1e45da7c /media-sound
parentapp-misc/uptimed: add myself as maintainer (diff)
downloadgentoo-930896984ec102466237163e6672b3285d0649b3.tar.gz
gentoo-930896984ec102466237163e6672b3285d0649b3.tar.bz2
gentoo-930896984ec102466237163e6672b3285d0649b3.zip
media-sound/mumble: fix build with dev-lang/python-exec[-native-symlinks]
Closes: https://bugs.gentoo.org/show_bug.cgi?id=769935 Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mumble/mumble-1.3.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/media-sound/mumble/mumble-1.3.4.ebuild b/media-sound/mumble/mumble-1.3.4.ebuild
index 5c1fc367dd3e..b34bfa5eec22 100644
--- a/media-sound/mumble/mumble-1.3.4.ebuild
+++ b/media-sound/mumble/mumble-1.3.4.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop multilib-build qmake-utils xdg
+PYTHON_COMPAT=( python3_{8..10} )
+inherit desktop multilib-build python-any-r1 qmake-utils xdg
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -55,6 +56,7 @@ RDEPEND="
zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
>=dev-libs/boost-1.41.0
x11-base/xorg-proto
"
@@ -63,6 +65,10 @@ BDEPEND="
virtual/pkgconfig
"
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
# NB: qmake does not support multilib but it's fine to configure
# for the native ABI here
src_configure() {