summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-14 23:12:13 -0600
committerSam James <sam@gentoo.org>2024-06-20 18:15:42 +0100
commitf2e36b71c052cdb86b10bc7c2ed8e7adb9035eff (patch)
treeea2a2c5f87a10d64af466da7ae13537337b8dcd0 /media-sound
parentmedia-sound/liblc3: add multilib (diff)
downloadgentoo-f2e36b71c052cdb86b10bc7c2ed8e7adb9035eff.tar.gz
gentoo-f2e36b71c052cdb86b10bc7c2ed8e7adb9035eff.tar.bz2
gentoo-f2e36b71c052cdb86b10bc7c2ed8e7adb9035eff.zip
media-sound/liblc3: respect CC for tests
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/37167 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/liblc3/liblc3-1.1.1-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-sound/liblc3/liblc3-1.1.1-r1.ebuild b/media-sound/liblc3/liblc3-1.1.1-r1.ebuild
index 0a29e622ec90..2d0966b78592 100644
--- a/media-sound/liblc3/liblc3-1.1.1-r1.ebuild
+++ b/media-sound/liblc3/liblc3-1.1.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit python-any-r1 meson-multilib
+inherit python-any-r1 toolchain-funcs meson-multilib
DESCRIPTION="LC3 is an efficient low latency audio codec"
HOMEPAGE="https://github.com/google/liblc3"
@@ -50,7 +50,8 @@ multilib_src_configure() {
multilib_src_test() {
if multilib_is_native_abi; then
- V= emake -C "${S}" test CFLAGS:="${CPPFLAGS} ${CFLAGS} -I"$("${EPYTHON}" -c "import numpy;print(numpy.get_include())")""
+ V= emake -C "${S}" test CC="$(tc-getCC)" \
+ CFLAGS:="${CPPFLAGS} ${CFLAGS} -I"$("${EPYTHON}" -c "import numpy;print(numpy.get_include())")""
else
ewarn "Skipping test for non-native ABI: ${ABI}"
fi