summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilson Michaels <thebitpit@earthlink.net>2020-11-28 16:47:53 -0600
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-12 01:01:22 +0100
commitb63da8a7200e661b89994f3728c738ea43c23dd8 (patch)
tree628a51d4d3775d3f39f7c217cf3865fdf6141108 /media-tv
parentsys-kernel/gentoo-sources: Clean-up of 5.9.X series (diff)
downloadgentoo-b63da8a7200e661b89994f3728c738ea43c23dd8.tar.gz
gentoo-b63da8a7200e661b89994f3728c738ea43c23dd8.tar.bz2
gentoo-b63da8a7200e661b89994f3728c738ea43c23dd8.zip
media-tv/mythtv: cleanup Python 2.7, drop dev-qt/qtwebkit:5
Closes: https://bugs.gentoo.org/735986 Closes: https://bugs.gentoo.org/750887 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Wilson Michaels <thebitpit@austincustomerrands.com> Closes: https://github.com/gentoo/gentoo/pull/18443 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/Manifest2
-rw-r--r--media-tv/mythtv/files/mythtv-29.1-Fix_create_webbrowser_window.patch61
-rw-r--r--media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_Dereferencing_type-punned_pointer.patch34
-rw-r--r--media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_unitialized_variables.patch22
-rw-r--r--media-tv/mythtv/metadata.xml1
-rw-r--r--media-tv/mythtv/mythtv-30.0_p20190808-r3.ebuild432
-rw-r--r--media-tv/mythtv/mythtv-31.0-r4.ebuild (renamed from media-tv/mythtv/mythtv-31.0-r3.ebuild)6
7 files changed, 2 insertions, 556 deletions
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index 261a47d69a27..e2859fa32422 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,3 +1 @@
-DIST mythtv-30.0_p20190808-cast_constants_to_short.patch 24201 BLAKE2B d76e519666914f6c9a510fb0aec493e361e857f51e56bd7d120657f350b0bf5da329a89eb58c9789f8f030c6d08bfe0171750690b76d8c2add807942aa686d59 SHA512 c2724ad248222ac4190412cf68e54ee0b265fdde128996e68a2e178e6debe0180c23f9c7d1878466f9a5689fab8172370c6b31c90aa9a096fb5919ec6e8960fe
-DIST mythtv-30.0_p20190808.tar.gz 101208060 BLAKE2B af8966dd6353fc514c9a95083f28e8b7b19f16e1bd5a4f7590a946c306bf16a09f0028c76da975e423136834f8f06d7f2a570b43957ef4ae5e42ee241b579f0a SHA512 c02371c0b2162556e40a560a0fd9cb121f46f2ccedbc2ca74cd03aa9caf2b7ea4bbaa09ae6320eb782f932190f449e7fdd274a6d6ba9676e5fd9b7f5432632a2
DIST mythtv-31.0.tar.gz 102552136 BLAKE2B b09b41230eb2cae19d770c3cc59151863e0a56e95a86627473d52613e62f0acf3bd0c4bb37afb340ab874c222899f9d3c219ded470785d27960db9b39d784ceb SHA512 d53817231409934ef37d12739c38cf6936f04f816b0ba1c9738ce99b5b4ff387c70b683ccd84f649ff2f74992b2158829f5f1d1ffe06c8768da1922b90439f6e
diff --git a/media-tv/mythtv/files/mythtv-29.1-Fix_create_webbrowser_window.patch b/media-tv/mythtv/files/mythtv-29.1-Fix_create_webbrowser_window.patch
deleted file mode 100644
index 168c23379423..000000000000
--- a/media-tv/mythtv/files/mythtv-29.1-Fix_create_webbrowser_window.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Index: mythtv/libs/libmythui/mythuiwebbrowser.cpp
-Mythtv bug #13544
-===================================================================
---- a/libs/libmythui/mythuiwebbrowser.cpp
-+++ b/libs/libmythui/mythuiwebbrowser.cpp
-@@ -873,4 +873,8 @@
- void MythUIWebBrowser::Init(void)
- {
-+ // only do the initialisation for widgets not being stored in the global object store
-+ if (parent() == GetGlobalObjectStore())
-+ return;
-+
- if (m_initialized)
- return;
-@@ -1128,4 +1132,7 @@
- void MythUIWebBrowser::SetActive(bool active)
- {
-+ if (!m_browser)
-+ return;
-+
- if (m_active == active)
- return;
-@@ -1326,4 +1333,7 @@
- void MythUIWebBrowser::Scroll(int dx, int dy)
- {
-+ if (!m_browser)
-+ return;
-+
- QPoint startPos = m_browser->page()->currentFrame()->scrollPosition();
- QPoint endPos = startPos + QPoint(dx, dy);
-@@ -1435,4 +1445,7 @@
- void MythUIWebBrowser::UpdateScrollBars(void)
- {
-+ if (!m_browser)
-+ return;
-+
- QPoint position = m_browser->page()->currentFrame()->scrollPosition();
- if (m_verticalScrollbar)
-@@ -1461,5 +1474,5 @@
- UpdateScrollBars();
-
-- if (!m_image)
-+ if (!m_image || !m_browser)
- return;
-
-@@ -1480,4 +1493,7 @@
- void MythUIWebBrowser::Pulse(void)
- {
-+ if (!m_browser)
-+ return;
-+
- if (m_scrollAnimation.IsActive() &&
- m_destinationScrollPos !=
-@@ -1522,4 +1538,7 @@
- bool MythUIWebBrowser::keyPressEvent(QKeyEvent *event)
- {
-+ if (!m_browser)
-+ return false;
-+
- QStringList actions;
- bool handled = false;
diff --git a/media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_Dereferencing_type-punned_pointer.patch b/media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_Dereferencing_type-punned_pointer.patch
deleted file mode 100644
index bc0751c887c3..000000000000
--- a/media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_Dereferencing_type-punned_pointer.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/libs/libmythfreemheg/Programs.cpp
-+++ b/libs/libmythfreemheg/Programs.cpp
-@@ -232,7 +232,10 @@ void MHResidentProgram::CallProgram(bool fIsFork, const MHObjectRef &success, co
- for (int i = 0; i < format.Size(); i++)
- {
- unsigned char ch = format.GetAt(i);
-- char buffer[5]; // Largest text is 4 chars for a year + null terminator
-+ // Largest text is 4 chars for a year + null terminator
-+ // But... adding a constant to the value might be 5 chars + null terminator
-+ // Using 6 gets rid of compiler warning
-+ char buffer[6];
-
- if (ch == '%')
- {
-@@ -249,16 +252,16 @@ void MHResidentProgram::CallProgram(bool fIsFork, const MHObjectRef &success, co
- switch (ch)
- {
- case 'Y':
-- sprintf(buffer, "%04d", timeStr->tm_year + 1900);
-+ sprintf(buffer, "%04d", (unsigned short)(timeStr->tm_year + 1900));
- break;
- case 'y':
- sprintf(buffer, "%02d", timeStr->tm_year % 100);
- break;
- case 'X':
-- sprintf(buffer, "%02d", timeStr->tm_mon + 1);
-+ sprintf(buffer, "%02d", (unsigned short)(timeStr->tm_mon + 1));
- break;
- case 'x':
-- sprintf(buffer, "%1d", timeStr->tm_mon + 1);
-+ sprintf(buffer, "%1d", (unsigned short)(timeStr->tm_mon + 1));
- break;
- case 'D':
- sprintf(buffer, "%02d", timeStr->tm_mday);
diff --git a/media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_unitialized_variables.patch b/media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_unitialized_variables.patch
deleted file mode 100644
index db296242515c..000000000000
--- a/media-tv/mythtv/files/mythtv-30.0_p20190808-Fix_unitialized_variables.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/libs/libmythtv/eitfixup.cpp
-+++ b/libs/libmythtv/eitfixup.cpp
-@@ -842,7 +842,7 @@ void EITFixUp::SetUKSubtitle(DBEventEIT &event) const
- void EITFixUp::FixUK(DBEventEIT &event) const
- {
- int position1;
-- int position2;
-+ int position2 = 0;
- QString strFull;
-
- bool isMovie = event.m_category.startsWith("Movie",Qt::CaseInsensitive) ||
---- a/libs/libmythui/mythuitext.cpp
-+++ b/libs/libmythui/mythuitext.cpp
-@@ -1058,7 +1058,7 @@ int MythUIText::MoveCursor(int lines)
- int lineCount = 0;
- int currPos = 0;
- int layoutStartPos = 0;
-- int xPos;
-+ int xPos = 0;
-
- for (int x = 0; x < m_Layouts.count(); x++)
- {
diff --git a/media-tv/mythtv/metadata.xml b/media-tv/mythtv/metadata.xml
index 24e993307ee8..0de2e5e50fa6 100644
--- a/media-tv/mythtv/metadata.xml
+++ b/media-tv/mythtv/metadata.xml
@@ -34,7 +34,6 @@
<flag name="wrapper">Use Ubuntu mythtfrontend wrapper</flag>
<flag name="x265">Enable h265 encoding using x265</flag>
<flag name="xmltv">Support <pkg>media-tv/xmltv</pkg> TV listing - not used by Schedules Direct]</flag>
- <flag name="xnvctrl">External XNVCtrl support using Nvidia proprietary driver</flag>
</use>
<upstream>
<remote-id type="github">MythTV/mythtv</remote-id>
diff --git a/media-tv/mythtv/mythtv-30.0_p20190808-r3.ebuild b/media-tv/mythtv/mythtv-30.0_p20190808-r3.ebuild
deleted file mode 100644
index 4809398bba76..000000000000
--- a/media-tv/mythtv/mythtv-30.0_p20190808-r3.ebuild
+++ /dev/null
@@ -1,432 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-BACKPORTS="5cde0578d84926171b20c8f7e95a101e9b0b9457" # August 8, 2019
-
-MY_P=${P%_p*}
-MY_PV=${PV%_p*}
-
-inherit eutils flag-o-matic python-single-r1 qmake-utils readme.gentoo-r1 systemd user-info vcs-snapshot
-
-MYTHTV_BRANCH="fixes/${P%.*}"
-
-DESCRIPTION="Open Source DVR and media center hub"
-HOMEPAGE="https://www.mythtv.org"
-SRC_URI="https://github.com/MythTV/mythtv/archive/${BACKPORTS}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~juippis/distfiles/tmp/mythtv-30.0_p20190808-cast_constants_to_short.patch"
-
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-SLOT="0/${PV}"
-
-IUSE_INPUT_DEVICES="input_devices_joystick"
-IUSE_VIDEO_CAPTURE_DEVICES="v4l ivtv ieee1394 hdpvr hdhomerun vbox ceton"
-IUSE="alsa altivec asi autostart bluray cdda cdr cec debug dvd dvb egl exif fftw jack java
- +lame lcd libass lirc +opengl oss perl pulseaudio python raw systemd vaapi vdpau vpx
- +wrapper x264 x265 +xml xmltv xnvctrl +xvid +X zeroconf
- ${IUSE_INPUT_DEVICES} ${IUSE_VIDEO_CAPTURE_DEVICES}"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- bluray? ( xml )
- cdr? ( cdda )
-"
-COMMON_DEPEND="
- acct-user/mythtv
- dev-libs/glib:2
- dev-libs/lzo
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- opengl? ( dev-qt/qtopengl:5 )
- dev-qt/qtscript:5
- dev-qt/qtsql:5[mysql]
- dev-qt/qtwebkit:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- media-gfx/exiv2:=
- media-libs/freetype:2
- media-libs/libsamplerate
- media-libs/taglib
- lame? ( >=media-sound/lame-3.93.1 )
- sys-libs/zlib
- opengl? ( virtual/opengl )
- X? (
- x11-libs/libX11:=
- x11-libs/libXext:=
- x11-libs/libXinerama:=
- x11-libs/libXrandr:=
- x11-libs/libXv:=
- x11-libs/libXxf86vm:=
- x11-misc/wmctrl:=
- )
- alsa? ( >=media-libs/alsa-lib-1.0.24 )
- bluray? (
- media-libs/libbluray:=[java?]
- dev-libs/libcdio:=
- sys-fs/udisks:2
- )
- cec? ( dev-libs/libcec )
- dvd? (
- dev-libs/libcdio:=
- sys-fs/udisks:2
- )
- egl? ( media-libs/mesa[egl] )
- fftw? ( sci-libs/fftw:3.0=[threads] )
- hdhomerun? ( media-libs/libhdhomerun )
- ieee1394? (
- >=media-libs/libiec61883-1.0.0
- >=sys-libs/libavc1394-0.5.3
- >=sys-libs/libraw1394-1.2.0
- )
- jack? ( media-sound/jack-audio-connection-kit )
- java? ( dev-java/ant-core )
- lcd? ( app-misc/lcdproc )
- libass? ( >=media-libs/libass-0.9.11:= )
- lirc? ( app-misc/lirc )
- perl? (
- >=dev-perl/libwww-perl-5
- dev-perl/DBD-mysql
- dev-perl/HTTP-Message
- dev-perl/IO-Socket-INET6
- dev-perl/LWP-Protocol-https
- dev-perl/Net-UPnP
- )
- pulseaudio? ( media-sound/pulseaudio )
- systemd? ( sys-apps/systemd:= )
- vaapi? ( x11-libs/libva:=[opengl] )
- vdpau? ( x11-libs/libvdpau )
- vpx? ( <media-libs/libvpx-1.8.0:= )
- xnvctrl? ( x11-drivers/nvidia-drivers:=[tools,static-libs] )
- x264? ( >=media-libs/x264-0.0.20111220:= )
- x265? ( media-libs/x265 )
- xml? ( >=dev-libs/libxml2-2.6.0 )
- xvid? ( >=media-libs/xvid-1.1.0 )
- zeroconf? (
- dev-libs/openssl:0=
- net-dns/avahi[mdnsresponder-compat]
- )
-"
-RDEPEND="${COMMON_DEPEND}
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/lxml[${PYTHON_MULTI_USEDEP}]
- dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]
- dev-python/urlgrabber[${PYTHON_MULTI_USEDEP}]
- dev-python/future[${PYTHON_MULTI_USEDEP}]
- dev-python/requests-cache[${PYTHON_MULTI_USEDEP}]
- ')
- )
- media-fonts/corefonts
- media-fonts/dejavu
- media-fonts/liberation-fonts
- x11-apps/xinit
- autostart? (
- net-dialup/mingetty
- x11-apps/xset
- x11-wm/evilwm
- )
- dvd? ( media-libs/libdvdcss )
- xmltv? ( >=media-tv/xmltv-0.5.43 )
-"
-DEPEND="
- ${COMMON_DEPEND}
- dev-lang/yasm
- x11-base/xorg-proto
-"
-
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-respect_LDFLAGS.patch"
- "${DISTDIR}/${P}-cast_constants_to_short.patch"
- "${FILESDIR}/${P}-Fix_Dereferencing_type-punned_pointer.patch"
- "${FILESDIR}/${P}-Fix_unitialized_variables.patch"
- "${FILESDIR}/${PN}-29.1-Fix_create_webbrowser_window.patch"
- "${FILESDIR}/${PN}-31.0-Include_QPainterPath.patch"
-)
-
-# mythtv and mythplugins are separate builds in the github mythtv project
-S="${WORKDIR}/${P}/mythtv"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-If a MYSQL server is installed, a mythtv MySQL user and mythconverg database
-is created if it does not already exist.
-You will be prompted for your MySQL root password.
-
-A mythtv user is maintained by acct-user/mythtv. An existing mythtv user
-may be modified to the configuration defined by acct-user/mythtv.
-An existing mythtv user may be changed which may alter some functionality.
-If it breaks mythtv you may need to (choose one):
- * Restore the original mythtv user
- * Create custom acct-user/mythtv overlay for your system
- * Fix you system to use mythtv as daemon only
-Failure to emerge acct-user/mythtv indicates that the existing mythtv user
-is customized and not changed. Corrective action (choose one):
- * Ignore emerge failure
- * Create custom acct-user/mythtv overlay for your system
- * Fix you system to use mythtv as daemon only
- * Delete existing user and try again (dangerous)
-
-Mythtv is updated to use correct FHS/Gentoo policy paths.
-Updating mythtv installations may report:
- * mythtv is in use, cannot update home
- * There was an error when attempting to update the home directory for mythtv
- * Please update it manually on your system (as root):
- * usermod -d "/var/lib/mythtv" "mythtv"
-This can be ignored. The previous default was "/home/mythtv".
-Use caution if you change the home directory.
-
-To have this machine operate as recording host for MythTV,
-mythbackend must be running. Run the following:
-rc-update add mythbackend default
-
-Your recordings folder must be owned 'mythtv'. e.g.
-chown -R mythtv /var/lib/mythtv
-
-Want mythfrontend to start automatically?
-Set USE=autostart. Details can be found at:
-https://dev.gentoo.org/~cardoe/mythtv/autostart.html
-
-Note that the systemd unit now restarts by default and logs
-to journald via the console at the notice verbosity.
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- # The acct-user/mythtv package creates/manages the user 'mythtv'
-}
-
-src_prepare() {
- default
-
- # Perl bits need to go into vender_perl and not site_perl
- sed -e "s:pure_install:pure_install INSTALLDIRS=vendor:" \
- -i "${S}"/bindings/perl/Makefile || die "Cannot convert site_perl to vendor_perl!"
-
- # Fix up the version info since we are using the fixes/${PV} branch
- echo "SOURCE_VERSION=\"v${MY_PV}\"" > "${S}"/VERSION
- echo "BRANCH=\"${MYTHTV_BRANCH}\"" >> "${S}"/VERSION
- echo "SOURCE_VERSION=\"${BACKPORTS}\"" > "${S}"/EXPORTED_VERSION
- echo "BRANCH=\"${MYTHTV_BRANCH}\"" >> "${S}"/EXPORTED_VERSION
-
- echo "setting.extra -= -ldconfig" >> "${S}"/programs/mythfrontend/mythfrontend.pro
-}
-
-src_configure() {
- local -a myconf
-
- # Setup paths
- myconf+=(--prefix="${EPREFIX}"/usr)
- myconf+=(--libdir="${EPREFIX}"/usr/$(get_libdir))
- myconf+=(--libdir-name=$(get_libdir))
- myconf+=(--mandir="${EPREFIX}"/usr/share/man)
-
- if use debug; then
- myconf+=(--compile-type=debug)
- myconf+=(--disable-stripping) # FIXME: does not disable for all files, only for some
- myconf+=(--enable-valgrind) # disables timeouts for valgrind memory debugging
- else
- myconf+=(--compile-type=release)
- fi
-
- # Build boosters
- has ccache "${FEATURES}" || myconf+=(--disable-ccache)
- has distcc "${FEATURES}" || myconf+=(--disable-distcc)
-
- # CPU settings
- # Mythtv's configure is borrowed from ffmpeg,
- # Bug #172723
- # Try to get cpu type based on CFLAGS.
- # We need to do this so that features of that CPU will be better used
- # If they contain an unknown CPU it will not hurt since ffmpeg's configure
- # will just ignore it.
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
- [ "${i}" = "native" ] && i="host" # bug #273421
- myconf+=(--cpu="${i}")
- break
- done
- myconf+=($(use_enable altivec))
-
- # Sound Output Support
- myconf+=(
- $(use_enable oss audio-oss)
- $(use_enable alsa audio-alsa)
- $(use_enable jack audio-jack)
- $(use_enable pulseaudio audio-pulseoutput)
- )
-
- # Input Support
- myconf+=(
- $(use_enable lirc)
- $(use_enable input_devices_joystick joystick-menu)
- $(use_enable cec libcec)
- $(use_enable ieee1394 firewire)
- $(use_enable hdhomerun)
- $(use_enable vbox)
- $(use_enable ceton)
- $(use_enable v4l v4l2)
- $(use_enable ivtv)
- $(use_enable hdpvr)
- $(use_enable dvb)
- $(use_enable asi)
- )
-
- # Video Output Support
- myconf+=(
- $(use_enable X x11)
- $(use_enable xnvctrl)
- $(use_enable X xrandr)
- $(use_enable X xv)
- )
-
- # Hardware accellerators
- myconf+=(
- $(use_enable vdpau)
- $(use_enable vaapi)
- $(use_enable vaapi vaapi2)
- $(use_enable opengl opengl-video)
- $(use_enable opengl opengl-themepainter)
- $(use_enable libass)
- )
-
- # System tools
- myconf+=(
- $(use_enable systemd systemd_notify)
- $(use_enable systemd systemd_journal)
- $(use_enable xml libxml2)
- $(use_enable zeroconf libdns-sd)
- )
-
- # Bindings
- if use perl && use python; then
- myconf+=(--with-bindings=perl,python)
- elif use perl; then
- myconf+=(--without-bindings=python)
- myconf+=(--with-bindings=perl)
- elif use python; then
- myconf+=(--without-bindings=perl)
- myconf+=(--with-bindings=python)
- else
- myconf+=(--without-bindings=perl,python)
- fi
- use python && myconf+=(--python="${EPYTHON}")
- myconf+=($(use_enable java bdjava))
-
- # External codec library options (used for mythffmpeg and streaming transcode)
- # lame is required for some broadcasts for silence detection of commercials
- # default enable in IUSE with +lame
- myconf+=(
- $(use_enable lame libmp3lame)
- $(use_enable xvid libxvid)
- $(use_enable x264 libx264)
- $(use_enable x265 libx265)
- $(use_enable vpx libvpx)
- )
-
- # Clean up DSO load times and other compiler bits
- myconf+=(--enable-symbol-visibility)
- myconf+=(--enable-pic)
-
- if tc-is-cross-compiler ; then
- myconf+=(--enable-cross-compile --arch=$(tc-arch-kernel))
- myconf+=(--cross-prefix="${CHOST}"-)
- fi
-
- myconf+=($(use_enable bluray libbluray_external))
-
- # econf sets these options that are not handled by configure:
- # --build --host --infodir --localstatedir --sysconfdir
-
- einfo "Running ./configure ${myconf[@]} - THIS MAY TAKE A WHILE."
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --cc="$(tc-getCC)" \
- --cxx="$(tc-getCXX)" \
- --ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-cxxflags="${CXXFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --qmake=$(qt5_get_bindir)/qmake \
- "${myconf[@]}"
-}
-
-src_install() {
- emake STRIP="true" INSTALL_ROOT="${D}" install
- use python && python_optimize # does all packages by default
- dodoc AUTHORS UPGRADING README
- readme.gentoo_create_doc
-
- insinto /usr/share/mythtv/database
- doins database/*
-
- newinitd "${FILESDIR}"/mythbackend.init-r2 mythbackend
- newconfd "${FILESDIR}"/mythbackend.conf-r1 mythbackend
- if use systemd; then
- systemd_newunit "${FILESDIR}"/mythbackend.service-28 mythbackend.service
- fi
-
- dodoc keys.txt
-
- keepdir /etc/mythtv
- fowners -R mythtv /etc/mythtv
- keepdir /var/log/mythtv
- fowners -R mythtv /var/log/mythtv
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/mythtv.logrotate.d-r4 mythtv
-
- insinto /usr/share/mythtv/contrib
- # Ensure we don't install scripts needing the perl bindings (bug #516968)
- use perl || find contrib/ -name '*.pl' -exec rm -f {} \;
- # Ensure we don't install scripts needing the python bindings (bug #516968)
- use python || find contrib/ -name '*.py' -exec rm -f {} \;
- doins -r contrib/*
-
- # Install our mythfrontend wrapper which is similar to Mythbuntu's
- if use wrapper; then
- mv "${ED}/usr/bin/mythfrontend" "${ED}/usr/bin/mythfrontend.real" || die "Failed to install mythfrontend.real"
- newbin "${FILESDIR}"/mythfrontend.wrapper mythfrontend
- newconfd "${FILESDIR}"/mythfrontend.conf mythfrontend
- fi
-
- if use autostart; then
- echo CONFIG_PROTECT=\"$(egethome mythtv)\" > "${T}"/95mythtv
- doenvd "${T}"/95mythtv
-
- insinto $(egethome mythtv)
- newins "${FILESDIR}"/bash_profile .bash_profile
- newins "${FILESDIR}"/xinitrc-r1 .xinitrc
- fi
-
- # Make Python files executable but not files named "__init__.py"
- find "${ED}/usr/share/mythtv" -type f -name '*.py' -exec expr \( {} : '.*__init__.py' \) = 0 \; \
- -exec chmod a+x {} \; || die "Failed to make python file $(basename ${file}) executable"
-
- # Ensure that Python scripts are executed by Python 2
- use python && python_fix_shebang "${ED}/usr/share/mythtv"
-
- # Make shell & perl scripts executable
- find "${ED}" -type f \( -name '*.sh' -o -name '*.pl' \) -exec chmod a+x {} \; || die "Failed to make script executable"
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
-
-pkg_info() {
- return
-}
-
-pkg_config() {
- if [[ -e "${EROOT}"/usr/bin/mysql ]]; then
- "${EROOT}"/usr/bin/mysql -u root -p < "${EROOT}"/usr/share/mythtv/database/mc.sql
- fi
-}
diff --git a/media-tv/mythtv/mythtv-31.0-r3.ebuild b/media-tv/mythtv/mythtv-31.0-r4.ebuild
index b45f36f1ae77..1a3a406636bb 100644
--- a/media-tv/mythtv/mythtv-31.0-r3.ebuild
+++ b/media-tv/mythtv/mythtv-31.0-r4.ebuild
@@ -105,7 +105,6 @@ RDEPEND="
xml? ( dev-libs/libxml2:2 )
xmltv? (
dev-perl/XML-LibXML
- dev-qt/qtwebkit:5
media-tv/xmltv
)
xvid? ( media-libs/xvid )
@@ -162,6 +161,8 @@ S="${WORKDIR}/${P}/mythtv"
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="
+Suppport for Python 2.7 has been removed.
+
If a MYSQL server is installed, a mythtv MySQL user and mythconverg database
is created if it does not already exist.
You will be prompted for your MySQL root password.
@@ -200,9 +201,6 @@ chown -R mythtv /var/lib/mythtv
Want mythfrontend to start automatically?
Set USE=autostart. Details can be found at:
https://dev.gentoo.org/~cardoe/mythtv/autostart.html
-
-Note that the systemd unit now restarts by default and logs
-to journald via the console at the notice verbosity.
"
pkg_setup() {