summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-23 13:01:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-26 03:37:13 +0100
commit49ec06dfd7c927b61924c1ce4cc3f5f669e5e3fc (patch)
tree6d4c5d00f39191b93288970201c320143eb7f82b /media-video
parentapp-vim/zoomwin: add <stabilize-allarches/> (diff)
downloadgentoo-49ec06dfd7c927b61924c1ce4cc3f5f669e5e3fc.tar.gz
gentoo-49ec06dfd7c927b61924c1ce4cc3f5f669e5e3fc.tar.bz2
gentoo-49ec06dfd7c927b61924c1ce4cc3f5f669e5e3fc.zip
media-video/dvdauthor: EAPI8 bump, fix #914235
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/914235 Closes: https://github.com/gentoo/gentoo/pull/34441 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.2-r3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-video/dvdauthor/dvdauthor-0.7.2-r3.ebuild b/media-video/dvdauthor/dvdauthor-0.7.2-r3.ebuild
new file mode 100644
index 000000000000..bac3629b21c1
--- /dev/null
+++ b/media-video/dvdauthor/dvdauthor-0.7.2-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools for generating DVD files to be played on standalone DVD players"
+HOMEPAGE="https://dvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="graphicsmagick +imagemagick"
+
+RDEPEND=">=dev-libs/fribidi-0.19.2
+ dev-libs/libxml2
+ >=media-libs/freetype-2
+ media-libs/libdvdread
+ media-libs/libpng:0=
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:= )
+ imagemagick? ( media-gfx/imagemagick:= )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-freetype-pkgconfig.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use imagemagick && has_version '>=media-gfx/imagemagick-7.0.1.0' ; then
+ eapply "${FILESDIR}/${PN}-0.7.2-imagemagick7.patch"
+ fi
+
+ if use graphicsmagick ; then
+ sed -i -e 's:ExportImagePixels:dIsAbLeAuToMaGiC&:' configure \
+ || die
+ fi
+}
+
+src_configure() {
+ use graphicsmagick && \
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags GraphicsMagick)" #459976
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)" #417041
+ econf
+}