summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/aimsniff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/aimsniff')
-rw-r--r--net-analyzer/aimsniff/Manifest2
-rw-r--r--net-analyzer/aimsniff/aimsniff-0.9d.ebuild110
-rw-r--r--net-analyzer/aimsniff/files/aimsniff.rc18
-rw-r--r--net-analyzer/aimsniff/metadata.xml12
4 files changed, 142 insertions, 0 deletions
diff --git a/net-analyzer/aimsniff/Manifest b/net-analyzer/aimsniff/Manifest
new file mode 100644
index 000000000000..1677df2e8458
--- /dev/null
+++ b/net-analyzer/aimsniff/Manifest
@@ -0,0 +1,2 @@
+DIST aimsniff-0.9d.tar.gz 24044 SHA256 11ce4cd3e1dcdabee0319dbb8a52c176debfbcd59c0c0c913078bb4b85619ac1 SHA512 eba8d1ff21c6c841f5e1b344769c38bf00936613c975dd60e0c3922e67805733c2e949006be36a83d75fc6c9c77de510a6914d184c6159e46b9d35cc4f12efa6 WHIRLPOOL 40a882204e0da03843a6a461b036dfb6a84f29fbee22f83c4d962ba0ca838b71499b51f8736ff99eadad7a0ecd30405c7df743081d258b0f4a7141bb20ef69cd
+DIST was-0.1.2b.tar.gz 73651 SHA256 0d1af84e7ed529cf0f8a63f4c72e8656ceccf0316cc42dcc9d856cbf8091635b SHA512 afbe8554c16df8305e781cf2dde3af1e7b25345dc1f5defc7723654479cc91d8f6fe9ddc3850fd487f77b241d40274edb2b7328ab011df93996264f14b98e6cd WHIRLPOOL cabbdbb0131ff633472b18226ed424c5d905f0dfbb92a36ccdd08cdba024ba94b88e4b497e10d9d6c4ebd000efa832a0a66ecd105e50a894ed48591633d80d16
diff --git a/net-analyzer/aimsniff/aimsniff-0.9d.ebuild b/net-analyzer/aimsniff/aimsniff-0.9d.ebuild
new file mode 100644
index 000000000000..201fa4b00416
--- /dev/null
+++ b/net-analyzer/aimsniff/aimsniff-0.9d.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils webapp eutils depend.apache
+
+WAS_VER="0.1.2b"
+
+DESCRIPTION="Utility for monitoring and archiving AOL Instant Messenger messages across a network"
+HOMEPAGE="http://sourceforge.net/projects/aimsniff/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ http? ( mirror://sourceforge/${PN}/was-${WAS_VER}.tar.gz )
+"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+#SLOT empty due to webapp
+IUSE="samba mysql http"
+
+RDEPEND="
+ dev-lang/perl[gdbm]
+ dev-perl/Net-Pcap
+ dev-perl/NetPacket
+ dev-perl/Unicode-String
+ dev-perl/Proc-Daemon
+ dev-perl/Proc-Simple
+ dev-perl/DBI
+ dev-perl/Unix-Syslog
+ mysql? ( virtual/mysql dev-perl/DBD-mysql )
+ samba? ( net-fs/samba )
+"
+
+want_apache2 http
+
+pkg_setup() {
+ depend.apache_pkg_setup http
+
+ use http && webapp_pkg_setup
+}
+
+src_install() {
+ use http && webapp_src_preinst
+
+ newsbin aimSniff.pl aimsniff
+ insinto /etc/${PN}
+ doins aimsniff.config
+ insinto /usr/share/doc/${PF}
+ doins table.struct
+ dodoc README ChangeLog
+
+ if use http; then
+ cp ../was-${WAS_VER}/docs/README README.WAS
+ dodoc README.WAS
+
+ rm -rf ../was-${WAS_VER}/docs
+ mv ../was-${WAS_VER}/ "${D}"${MY_HTDOCSDIR}/was
+
+ webapp_serverowned ${MY_HTDOCSDIR}/was
+
+ # This file needs to be serverowned as the server won't be able to write to it if it were
+ # webapp_configfile'ed.
+ webapp_serverowned ${MY_HTDOCSDIR}/was/.config.php
+
+ webapp_src_install
+ fi
+
+ newinitd "${FILESDIR}"/aimsniff.rc aimsniff
+}
+
+pkg_postinst() {
+ if use mysql
+ then
+ echo
+ elog "To create and enable the mysql database, please run: "
+ elog "emerge --config =${PF}"
+
+ if use http; then
+ echo "To create and enable the mysql database, please run:
+ emerge --config =${PF}" > apache-postinst
+ webapp_postinst_txt en apache-postinst
+ fi
+ fi
+
+ if use http; then
+ elog
+ elog "Go to http://${HOSTNAME}/was/admin.php to configure WAS."
+
+ echo "Go to http://${HOSTNAME}/was/admin.php to configure WAS." > was-postinst
+ webapp_postinst_txt en was-postinst
+ fi
+}
+
+pkg_config() {
+ echo
+ einfo "Creating mysql database aimsniff using /usr/share/doc/${PF}/table.struct:"
+ echo -n "Please enter your mysql root password: "
+ read mysql_root
+ /usr/bin/mysqladmin -p$mysql_root -u root create aimsniff
+ /usr/bin/mysql -p$mysql_root -u root aimsniff < /usr/share/doc/${PF}/table.struct
+ echo -n "Please enter your username that you want to connect to the database with: "
+ read user
+ echo -n "Please enter the password that you want to use for your database: "
+ read password
+ einfo "Granting permisions on database using 'GRANT ALL ON aimsniff.* TO $user IDENTIFIED BY '$password';'"
+ echo "GRANT ALL ON aimsniff.* TO $user@localhost IDENTIFIED BY '$password';" | /usr/bin/mysql -p$mysql_root -u root aimsniff
+ echo
+}
diff --git a/net-analyzer/aimsniff/files/aimsniff.rc b/net-analyzer/aimsniff/files/aimsniff.rc
new file mode 100644
index 000000000000..d94f6a9dcc79
--- /dev/null
+++ b/net-analyzer/aimsniff/files/aimsniff.rc
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting asniff"
+ start-stop-daemon -o --quiet --start --exec /usr/sbin/aimsniff -- \
+ -C=/etc/aimsniff/aimsniff.config
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping asniff"
+ start-stop-daemon -o --stop -p /var/run/aimsniff_parent.pid -s QUIT
+ eend $?
+}
diff --git a/net-analyzer/aimsniff/metadata.xml b/net-analyzer/aimsniff/metadata.xml
new file mode 100644
index 000000000000..b17448781b40
--- /dev/null
+++ b/net-analyzer/aimsniff/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>aimsniff is a utility used for retrieving and storing AIM messages across a network.</longdescription>
+ <use>
+ <flag name="http">Install the WAS (Web AIM Sniff) frontend</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">aimsniff</remote-id>
+ </upstream>
+</pkgmetadata>