summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ifstatus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ifstatus')
-rw-r--r--net-analyzer/ifstatus/Manifest1
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch10
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch22
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild40
-rw-r--r--net-analyzer/ifstatus/metadata.xml8
5 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/Manifest b/net-analyzer/ifstatus/Manifest
new file mode 100644
index 000000000000..c2625e628c23
--- /dev/null
+++ b/net-analyzer/ifstatus/Manifest
@@ -0,0 +1 @@
+DIST ifstatus-v1.1.0.tar.gz 25233 SHA256 0ca8a8655a1edf07698efbd5e1d4adc962dbb1bfb078b4899062e89bb05eac10 SHA512 2660310be7186067315414218e3d3d269499e391c7ffa12022ac53a0456ddbe0f7d5562b788fe6b2569b7d0eba7acf5699e0386769a91606a3e14b51239a2766 WHIRLPOOL 7aebc62d229160a07a28e876d2d7daa6847ed16d6c6b0f457de70d85584afce36f6e4903befb383720426f6ee20def4d1d02245fabf8671a6df367517d2a648b
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
new file mode 100644
index 000000000000..27111d7576f4
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- a/Main.h
++++ b/Main.h
+@@ -38,6 +38,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <curses.h>
++#include <stdlib.h>
+
+ #include <sys/time.h>
+ #include <sys/types.h>
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
new file mode 100644
index 000000000000..e2c14e6add71
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,7 @@
+ # Makefile for IFStatus
+ # Gabriel Montenegro
+
+-GCC = g++
+-LDFLAGS = -lncurses
+-CFLAGS = -O2 -Wall
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
+
+ BIN = ifstatus
+ OBJ = BorderDecorator.o\
+@@ -30,7 +28,7 @@
+ all : ifstatus printdone
+
+ ifstatus : $(OBJ)
+- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
++ $(LINK.cc) $^ $(LDLIBS) -o $@
+
+ printdone:
+ @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f5cad000f1d8
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+KEYWORDS="amd64 arm ~ppc x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time"
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-4.2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tinfo.patch"
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}
diff --git a/net-analyzer/ifstatus/metadata.xml b/net-analyzer/ifstatus/metadata.xml
new file mode 100644
index 000000000000..0bda9893d463
--- /dev/null
+++ b/net-analyzer/ifstatus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">ifstatus</remote-id>
+ </upstream>
+</pkgmetadata>