summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nessus-libraries
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nessus-libraries')
-rw-r--r--net-analyzer/nessus-libraries/Manifest1
-rw-r--r--net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch61
-rw-r--r--net-analyzer/nessus-libraries/metadata.xml6
-rw-r--r--net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild48
4 files changed, 116 insertions, 0 deletions
diff --git a/net-analyzer/nessus-libraries/Manifest b/net-analyzer/nessus-libraries/Manifest
new file mode 100644
index 000000000000..50ec07ea7b23
--- /dev/null
+++ b/net-analyzer/nessus-libraries/Manifest
@@ -0,0 +1 @@
+DIST nessus-libraries-2.2.9.tar.gz 426560 SHA256 5a3c32d6eab8ccc8a22ab5bb224228152e10731c06561f679c41b92263c7ef18
diff --git a/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch b/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch
new file mode 100644
index 000000000000..41cd2b21c938
--- /dev/null
+++ b/net-analyzer/nessus-libraries/files/nessus-libraries-2.2.9-linking.patch
@@ -0,0 +1,61 @@
+ Makefile | 4 ++--
+ libhosts_gatherer/Makefile | 2 +-
+ libnessus/Makefile | 4 ++--
+ libnessus/kb.c | 1 +
+ 4 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 938d1b2..672d8cf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,8 +3,8 @@ include nessus.tmpl
+ ALLDEPS = nessus.tmpl nessus-config
+
+ all: $(ALLDEPS) $(PCAP_MAKE)
+- cd libnessus && ${MAKE}
+- cd libhosts_gatherer && ${MAKE}
++ ${MAKE} -C libnessus
++ ${MAKE} -C libhosts_gatherer
+
+ nessus-config: nessus-config.pre Makefile nessus.tmpl
+ @echo Creating $@ ...
+diff --git a/libhosts_gatherer/Makefile b/libhosts_gatherer/Makefile
+index e2a647c..7d628d8 100644
+--- a/libhosts_gatherer/Makefile
++++ b/libhosts_gatherer/Makefile
+@@ -22,7 +22,7 @@ install : libhosts_gatherer.la
+ $(LIBTOOL) --finish $(DESTDIR)${libdir}
+
+ libhosts_gatherer.la : $(OBJS)
+- $(LIBTOOL) $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
++ $(LIBTOOL) $(CC) $(LDFLAGS) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ hg_utils.o : hg_utils.h hosts_gatherer.h hg_utils.c
+diff --git a/libnessus/Makefile b/libnessus/Makefile
+index c5a96db..211f57a 100644
+--- a/libnessus/Makefile
++++ b/libnessus/Makefile
+@@ -100,8 +100,8 @@ kb.o: kb.c
+ snprintf.o : snprintf.c
+ $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
+ libnessus.la: $(OBJS)
+- $(LIBTOOL) $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
+- -version-info ${PACKAGE_VERSION}
++ $(LIBTOOL) $(CC) $(LDFLAGS) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
++ -version-info ${PACKAGE_VERSION} `pcap-config --libs` `pkg-config --libs openssl`
+
+ install : libnessus.la
+ test -d $(DESTDIR)${libdir} || $(INSTALL_DIR) -m 755 $(DESTDIR)${libdir}
+diff --git a/libnessus/kb.c b/libnessus/kb.c
+index 921c1a1..cbfd840 100644
+--- a/libnessus/kb.c
++++ b/libnessus/kb.c
+@@ -20,6 +20,7 @@
+ */
+
+ #include <includes.h>
++#include <fnmatch.h>
+ #define HASH_MAX 65537
+
+
diff --git a/net-analyzer/nessus-libraries/metadata.xml b/net-analyzer/nessus-libraries/metadata.xml
new file mode 100644
index 000000000000..6f2576670f1f
--- /dev/null
+++ b/net-analyzer/nessus-libraries/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>A remote security scanner for Linux (nessus-libraries)</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild b/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..021412e61162
--- /dev/null
+++ b/net-analyzer/nessus-libraries/nessus-libraries-2.2.9-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (nessus-libraries)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="crypt debug static-libs"
+
+# Hard dep on SSL since libnasl won't compile when this package is emerged -ssl.
+DEPEND="
+ dev-libs/openssl
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linking.patch
+
+ sed -i -e "s:^\(LDFLAGS=\):\1 ${LDFLAGS}:g" nessus.tmpl.in || die
+ sed -i -e '/sbindir/d' Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable crypt cypher) \
+ $(use_enable debug) \
+ $(use_enable debug debug-ssl) \
+ $(use_enable static-libs static) \
+ --enable-shared \
+ --with-ssl="${EPREFIX}/usr/$(get_libdir)" \
+ --disable-nessuspcap
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}