summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-10-26 21:26:09 +0200
committerSam James <sam@gentoo.org>2022-11-23 01:43:10 +0000
commitec5815bc780db7720a5df13b83f1554a247b57c9 (patch)
tree6459e8847dcfe5fa8ef0cefc2c661ab3cc9bc9c8 /net-analyzer/wtfis
parentnet-analyzer/shodan: new package, add 1.28.0, 9999 (diff)
downloadgentoo-ec5815bc780db7720a5df13b83f1554a247b57c9.tar.gz
gentoo-ec5815bc780db7720a5df13b83f1554a247b57c9.tar.bz2
gentoo-ec5815bc780db7720a5df13b83f1554a247b57c9.zip
net-analyzer/wtfis: new package, add 0.4.0, 9999
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/27966 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/wtfis')
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/metadata.xml22
-rw-r--r--net-analyzer/wtfis/wtfis-0.4.0.ebuild38
-rw-r--r--net-analyzer/wtfis/wtfis-9999.ebuild38
4 files changed, 99 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
new file mode 100644
index 000000000000..da10d284853e
--- /dev/null
+++ b/net-analyzer/wtfis/Manifest
@@ -0,0 +1 @@
+DIST wtfis-0.4.0.gh.tar.gz 459363 BLAKE2B 10338f17700815aa8f25bd1e9587855795710925481ea3d7bd85782fea657055053d965977f601bc25d624352c97c639008d33d30aa3ac248ea7504c7e0ceaa7 SHA512 bb19923668e8172fd07b86159839c95a1b32d9975edcf1e9ab99bb574eae24f70c3a6bf83cc8ade66c1e5f57632625e7f604966ee06445839df87a9af4962573
diff --git a/net-analyzer/wtfis/metadata.xml b/net-analyzer/wtfis/metadata.xml
new file mode 100644
index 000000000000..495aa987e99e
--- /dev/null
+++ b/net-analyzer/wtfis/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ wtfis is a commandline tool that gathers information about a domain,
+ FQDN or IP address using various OSINT services. Unlike other tools of
+ its kind, it's built specifically for human consumption, providing
+ results that are pretty (YMMV) and easy to read and understand.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pirxthepilot/wtfis</remote-id>
+ <remote-id type="pypi">wtfis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/wtfis/wtfis-0.4.0.ebuild b/net-analyzer/wtfis/wtfis-0.4.0.ebuild
new file mode 100644
index 000000000000..f8b9786fcce5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/net-analyzer/wtfis/wtfis-9999.ebuild b/net-analyzer/wtfis/wtfis-9999.ebuild
new file mode 100644
index 000000000000..f8b9786fcce5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest