summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 09:22:10 +0000
committerSam James <sam@gentoo.org>2023-02-17 09:48:20 +0000
commite015868ec8a52a4ee7b253801535d932a0e43bf0 (patch)
tree934f1201f3eaa2d6afe5aff44120041a673b399b /net-analyzer
parentdev-python/pygccxml: skip pycodestyle tests (diff)
downloadgentoo-e015868ec8a52a4ee7b253801535d932a0e43bf0.tar.gz
gentoo-e015868ec8a52a4ee7b253801535d932a0e43bf0.tar.bz2
gentoo-e015868ec8a52a4ee7b253801535d932a0e43bf0.zip
net-analyzer/pypacker: add 5.2
Closes: https://bugs.gentoo.org/893482 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pypacker/Manifest1
-rw-r--r--net-analyzer/pypacker/pypacker-5.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/Manifest b/net-analyzer/pypacker/Manifest
index a25819448386..df9f53f48a94 100644
--- a/net-analyzer/pypacker/Manifest
+++ b/net-analyzer/pypacker/Manifest
@@ -1 +1,2 @@
DIST pypacker-5.1.tar.gz 623638 BLAKE2B 329e8ec2af336118a4ff8d200ced2e356a10dae5217582fb69b77be336e830d3c2356165ea42be6224ef8fd2291637b23fde35733652969affae1f81eb2411dc SHA512 427d2afc45735e920867098c77be8256e28840031a7a01dfae5c9817ff78d2ddb699bf94721eda3b1f4b568bb70bd3bd25ccb8cb77076b84e2aa71898ba0bf57
+DIST pypacker-v5.2.tar.bz2 544026 BLAKE2B 3401b47a496e8c76d2b925e63c43838d2a05af01655a3e470ddfd0c2c57ab6b37ba1b9acd49386232b5c0fb4bc8d061f8992eac07f5729306502fa76413c51f5 SHA512 3ccb82ff2a352553819991c0e24fb6da8a26091f5cdced3d3358192ecf6598153fb3b36d48b1f51cdc1dd7f54e136c073e8e5a2f3fb050af24f83c77e1bda3b4
diff --git a/net-analyzer/pypacker/pypacker-5.2.ebuild b/net-analyzer/pypacker/pypacker-5.2.ebuild
new file mode 100644
index 000000000000..a6c1afe33845
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="https://gitlab.com/mike01/pypacker/-/archive/v${PV}/pypacker-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${EPYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}