summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-03 17:28:33 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-05 18:08:02 -0600
commitebc286e18dda4b62bbe823971208d95992931311 (patch)
tree393e1627a64da692b4fb3bd6fd1c3ea11a3f2380 /net-im/hangups/files
parentdev-python/ReParser: initial ebuild (diff)
downloadgentoo-ebc286e18dda4b62bbe823971208d95992931311.tar.gz
gentoo-ebc286e18dda4b62bbe823971208d95992931311.tar.bz2
gentoo-ebc286e18dda4b62bbe823971208d95992931311.zip
net-im/hangups: initial ebuild
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'net-im/hangups/files')
-rw-r--r--net-im/hangups/files/unpin-dependencies.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-im/hangups/files/unpin-dependencies.patch b/net-im/hangups/files/unpin-dependencies.patch
new file mode 100644
index 000000000000..37c8795cdd8d
--- /dev/null
+++ b/net-im/hangups/files/unpin-dependencies.patch
@@ -0,0 +1,41 @@
+diff --git a/setup.py b/setup.py
+index 740ce61..67e3b84 100644
+--- a/setup.py
++++ b/setup.py
+@@ -65,15 +65,15 @@ with open('README.rst') as f:
+ # hangups from breaking when new versions of dependencies are released,
+ # especially for end-users (non-developers) who use pip to install hangups.
+ install_requires = [
+- 'ConfigArgParse==0.11.0',
++ 'ConfigArgParse>=0.11.0',
+ 'aiohttp>=1.2,<1.3',
+- 'appdirs==1.4.0',
+- 'readlike==0.1.2',
++ 'appdirs>=1.4.0',
++ 'readlike>=0.1.2',
+ 'requests>=2.6.0,<3', # uses semantic versioning (after 2.6)
+- 'ReParser==1.4.3',
++ 'ReParser>=1.4.3',
+ 'protobuf>=3.1.0,<3.2.0',
+- 'urwid==1.3.1',
+- 'MechanicalSoup==0.6.0',
++ 'urwid>=1.3.1',
++ 'MechanicalSoup>=0.6.0',
+ ]
+
+
+@@ -109,10 +109,10 @@ setup(
+ packages=['hangups', 'hangups.ui'],
+ install_requires=install_requires,
+ tests_require=[
+- 'pytest==3.0.5',
+- 'pylint==1.6.4',
+- 'pycodestyle==2.2.0',
+- 'httpretty==0.8.14',
++ 'pytest>=3.0.5',
++ 'pylint>=1.6.4',
++ 'pycodestyle>=2.2.0',
++ 'httpretty>=0.8.14',
+ ],
+ cmdclass={
+ 'test': PytestCommand,