summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2023-02-25 23:37:25 +0100
committerSam James <sam@gentoo.org>2023-03-15 05:03:32 +0000
commit99a1ef8729d13a3a7f80feec594608eec634c0ae (patch)
tree539a74b9c7c0b3b158c3f1758782d9424d8d4903 /net-im
parentnet-news/liferea: drop 1.14.0 (diff)
downloadgentoo-99a1ef8729d13a3a7f80feec594608eec634c0ae.tar.gz
gentoo-99a1ef8729d13a3a7f80feec594608eec634c0ae.tar.bz2
gentoo-99a1ef8729d13a3a7f80feec594608eec634c0ae.zip
net-im/telegram-desktop: Bump to 4.6.5
Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/metadata.xml2
-rw-r--r--net-im/telegram-desktop/telegram-desktop-4.6.5.ebuild206
3 files changed, 208 insertions, 1 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index a8767374a5d1..947383072b2a 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,3 +1,4 @@
DIST tdesktop-4.4.1-full.tar.gz 50077498 BLAKE2B 6196c474c0771197c56b386bbfd67e4a014569cb8bd9676990e323005f06cb6938aad0c0dd00fd74cab9fca1ac50c7bf7227f34aa39ae598b4f003199fa8cd00 SHA512 91038f0a615ef7ae1050cbfa614041a3d6a45fdbd26d120ef98cca3c31377612c3bb1e80f9aff58c4853a1726bf2cfb427f752a4f88a796f05b381516c981563
DIST tdesktop-4.5.3-full.tar.gz 63718129 BLAKE2B 85492ad92ea2643dd5e74c831609a4f7be9671648d2b542c24f415dbb19b66521ccecb2a545eadfbf9fa7f934d35d32de085b5b8403dce54bed0b85c54ea98fe SHA512 58a9c5d096e236090347388e1ed480527f841045a80771079dc0c3e35e12ce8ac11753987e87bb57870d9bd8488fc6a4734114648ecec7823d8544744b06c6b1
DIST tdesktop-4.6.3-full.tar.gz 63791674 BLAKE2B 291ed09dc96bb419c38d6c679c14ac5db1a361114c363ed4cfcbbab8e81927a75e87c5c8839bb348cf3395ff167e8e1eae9d6e499b4448e54e705b34ce997e59 SHA512 c01a1b57c71d8e3509664f8dfb8f7aa932e830732ea75211718150c8e4eafaf501f4271e5cb9e0c3348cd398091bc8236ff0cf79c0c6a45e5f897f9e3610566a
+DIST tdesktop-4.6.5-full.tar.gz 63793549 BLAKE2B a425aaf8d1f1c633b3b8ddacff5bb7cc26e6063d4238413fea76db6a4608497d229061a614c79464373e7f1aa3bb854d9718083638e119538e989a202741b3d6 SHA512 4a337e375d7746cb1fa652f5851f8be5718b7b9d9676bba8ab040489b8492b2a665a51848adba28117a910789aa942c386318a01f6c99b4caa12a1eac682c780
diff --git a/net-im/telegram-desktop/metadata.xml b/net-im/telegram-desktop/metadata.xml
index 059c51b94001..cd141868ce56 100644
--- a/net-im/telegram-desktop/metadata.xml
+++ b/net-im/telegram-desktop/metadata.xml
@@ -11,7 +11,7 @@
</maintainer>
<use>
<flag name="enchant">Use the <pkg>app-text/aspell</pkg> spell-checking backend instead of <pkg>app-text/hunspell</pkg></flag>
- <flag name="hunspell">Enable the <pkg>app-text/hunspell</pkg> spell-checking backend (deprecated)</flag>
+ <flag name="hunspell">Enable the <pkg>app-text/hunspell</pkg> spell-checking backend (old flag)</flag>
<flag name="fonts">Use builtin patched copy of open-sans fonts (overrides fontconfig)</flag>
<flag name="qt6">Build with Qt6 support</flag>
<flag name="qt6-imageformats">Add support for HEIF, AVIF and JpegXL by bundling kde-frameworks/kimageformats</flag>
diff --git a/net-im/telegram-desktop/telegram-desktop-4.6.5.ebuild b/net-im/telegram-desktop/telegram-desktop-4.6.5.ebuild
new file mode 100644
index 000000000000..cf71ac36b019
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-4.6.5.ebuild
@@ -0,0 +1,206 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit xdg cmake python-any-r1 optfeature flag-o-matic
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+IUSE="+dbus enchant +fonts +jemalloc screencast qt6 qt6-imageformats wayland +X"
+REQUIRED_USE="
+ qt6-imageformats? ( qt6 )
+"
+
+KIMAGEFORMATS_RDEPEND="
+ media-libs/libavif:=
+ media-libs/libheif:=
+ media-libs/libjxl
+"
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/abseil-cpp:=
+ dev-libs/glib:2
+ dev-libs/libdispatch
+ dev-libs/libsigc++:2
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig:=
+ media-libs/libjpeg-turbo:=
+ ~media-libs/libtgvoip-2.4.4_p20221208
+ media-libs/openal
+ media-libs/opus:=
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20230105:=[screencast=,X=]
+ media-video/ffmpeg:=[opus,vpx]
+ sys-libs/zlib:=[minizip]
+ virtual/opengl
+ dbus? ( dev-cpp/glibmm:2.68 )
+ !enchant? ( >=app-text/hunspell-1.7:= )
+ enchant? ( app-text/enchant:= )
+ jemalloc? ( dev-libs/jemalloc:=[-lazy-lock] )
+ !qt6? (
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5[dbus?,jpeg,png,wayland?,X?]
+ >=dev-qt/qtimageformats-5.15:5
+ >=dev-qt/qtnetwork-5.15:5[ssl]
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5[png,X?]
+ kde-frameworks/kcoreaddons:=
+ )
+ qt6? (
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[dbus?,gui,network,opengl,widgets,X?]
+ dev-qt/qtimageformats:6
+ dev-qt/qtsvg:6
+ wayland? ( dev-qt/qtwayland:6 )
+ qt6-imageformats? ( ${KIMAGEFORMATS_RDEPEND} )
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/range-v3
+ >=dev-cpp/ms-gsl-4
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+"
+# dev-libs/jemalloc:=[-lazy-lock] -> https://bugs.gentoo.org/803233
+
+PATCHES=(
+ "${FILESDIR}/tdesktop-4.2.4-jemalloc-only-telegram.patch"
+ "${FILESDIR}/tdesktop-4.4.1-fix-dupe-main-decl.patch"
+)
+
+# Current desktop-file-utils-0.26 does not understand Version=1.5
+QA_DESKTOP_FILE="usr/share/applications/${PN}.desktop"
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # Bundle kde-frameworks/kimageformats for qt6, since it's impossible to
+ # build in gentoo right now.
+ if use qt6-imageformats; then
+ sed -e 's/DESKTOP_APP_USE_PACKAGED_LAZY/TRUE/' -i \
+ cmake/external/kimageformats/CMakeLists.txt || die
+ printf "%s\n" \
+ 'Q_IMPORT_PLUGIN(QAVIFPlugin)' \
+ 'Q_IMPORT_PLUGIN(HEIFPlugin)' \
+ 'Q_IMPORT_PLUGIN(QJpegXLPlugin)' \
+ >> cmake/external/qt/qt_static_plugins/qt_static_plugins.cpp || die
+ fi
+
+ # kde-frameworks/kcoreaddons is bundled when using qt6, see:
+ # cmake/external/kcoreaddons/CMakeLists.txt
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # The ABI of media-libs/tg_owt breaks if the -DNDEBUG flag doesn't keep
+ # the same state across both projects.
+ # See https://bugs.gentoo.org/866055
+ append-cppflags '-DNDEBUG'
+
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
+ -DQT_VERSION_MAJOR=$(usex qt6 6 5)
+
+ -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION=$(usex !dbus)
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex !X)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex !wayland)
+ -DDESKTOP_APP_DISABLE_JEMALLOC=$(usex !jemalloc)
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant) # enables enchant and disables hunspell
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=$(usex !fonts) # use system fonts instead of bundled ones
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! use X && ! use screencast; then
+ ewarn "both the 'X' and 'screencast' USE flags are disabled, screen sharing won't work!"
+ ewarn
+ fi
+ if has_version '<dev-qt/qtcore-5.15.2-r10'; then
+ ewarn "Versions of dev-qt/qtcore lower than 5.15.2-r10 might cause telegram"
+ ewarn "to crash when pasting big images from the clipboard."
+ ewarn
+ fi
+ if ! use jemalloc && use elibc_glibc; then
+ # https://github.com/telegramdesktop/tdesktop/issues/16084
+ # https://github.com/desktop-app/cmake_helpers/pull/91#issuecomment-881788003
+ ewarn "Disabling USE=jemalloc on glibc systems may cause very high RAM usage!"
+ ewarn "Do NOT report issues about RAM usage without enabling this flag first."
+ ewarn
+ fi
+ if use qt6; then
+ ewarn "Qt6 support in gentoo is experimental."
+ ewarn "Please report any issues you may find, but don't expect"
+ ewarn "everything to work correctly as of yet."
+ ewarn
+ fi
+ if use wayland && ! use qt6; then
+ ewarn "Wayland-specific integrations have been deprecated with Qt5."
+ ewarn "The app will continue to function under wayland, but some"
+ ewarn "functionality may be reduced."
+ ewarn "These integrations are only supported when built with Qt6."
+ ewarn
+ fi
+ if use qt6 && ! use qt6-imageformats; then
+ elog "Enable USE=qt6-imageformats for AVIF, HEIF and JpegXL support"
+ elog
+ fi
+ optfeature_header
+ optfeature "shop payment support (requires USE=dbus enabled)" net-libs/webkit-gtk:4
+ if ! use qt6; then
+ optfeature "AVIF, HEIF and JpegXL image support" kde-frameworks/kimageformats[avif,heif,jpegxl]
+ fi
+}