summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-01 20:01:58 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-02 11:12:35 +0200
commita389c9caf6a96ab0ccfff98c0dc1441d5623a4e8 (patch)
tree132cf627b2f35d624775ea7985aeaf0b56c3adcf /net-im
parentprofiles: Mask/unmask USE=curl_quic_openssl where appropriate (diff)
downloadgentoo-a389c9caf6a96ab0ccfff98c0dc1441d5623a4e8.tar.gz
gentoo-a389c9caf6a96ab0ccfff98c0dc1441d5623a4e8.tar.bz2
gentoo-a389c9caf6a96ab0ccfff98c0dc1441d5623a4e8.zip
net-im/bitlbee-facebook: bump EAPI, fix pkgcheck issues
Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/37868 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/bitlbee-facebook/bitlbee-facebook-1.2.2-r1.ebuild39
-rw-r--r--net-im/bitlbee-facebook/bitlbee-facebook-9999.ebuild11
2 files changed, 44 insertions, 6 deletions
diff --git a/net-im/bitlbee-facebook/bitlbee-facebook-1.2.2-r1.ebuild b/net-im/bitlbee-facebook/bitlbee-facebook-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..7563f3db8c1c
--- /dev/null
+++ b/net-im/bitlbee-facebook/bitlbee-facebook-1.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2017-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Facebook protocol plugin for BitlBee"
+HOMEPAGE="https://github.com/bitlbee/bitlbee-facebook"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bitlbee/bitlbee-facebook"
+else
+ SRC_URI="https://github.com/bitlbee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=net-im/bitlbee-3[plugins]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/net-im/bitlbee-facebook/bitlbee-facebook-9999.ebuild b/net-im/bitlbee-facebook/bitlbee-facebook-9999.ebuild
index f7a43704ab51..7563f3db8c1c 100644
--- a/net-im/bitlbee-facebook/bitlbee-facebook-9999.ebuild
+++ b/net-im/bitlbee-facebook/bitlbee-facebook-9999.ebuild
@@ -1,17 +1,13 @@
-# Copyright 2017-2019 Gentoo Authors
+# Copyright 2017-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
DESCRIPTION="Facebook protocol plugin for BitlBee"
HOMEPAGE="https://github.com/bitlbee/bitlbee-facebook"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee-facebook"
@@ -20,6 +16,9 @@ else
KEYWORDS="~amd64 ~x86"
fi
+LICENSE="GPL-2"
+SLOT="0"
+
RDEPEND="
dev-libs/glib:2
dev-libs/json-glib