summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2024-10-30 14:26:24 +0100
committerSam James <sam@gentoo.org>2024-10-30 15:10:50 +0000
commitb3131c6d4af946f0a4e358a85755595445f29dc8 (patch)
tree087952cfe1e00a283573fd9332d97703a26d5af6 /net-irc
parentnet-irc/soju: add tmpfiles.d config (diff)
downloadgentoo-b3131c6d4af946f0a4e358a85755595445f29dc8.tar.gz
gentoo-b3131c6d4af946f0a4e358a85755595445f29dc8.tar.bz2
gentoo-b3131c6d4af946f0a4e358a85755595445f29dc8.zip
net-irc/soju: drop 0.8.0
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Closes: https://github.com/gentoo/gentoo/pull/39157 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/soju/Manifest2
-rw-r--r--net-irc/soju/soju-0.8.0.ebuild74
2 files changed, 0 insertions, 76 deletions
diff --git a/net-irc/soju/Manifest b/net-irc/soju/Manifest
index 57042043d326..7d4dd1823322 100644
--- a/net-irc/soju/Manifest
+++ b/net-irc/soju/Manifest
@@ -1,4 +1,2 @@
-DIST soju-0.8.0-deps.tar.xz 79434480 BLAKE2B 4cb3bbcd7d4c0fc610dffc585291fe07981c0d5d08e81fe800c6a08f3655eb999e097e17fe59342b896091a8e5640782f65bba351b94948ff9ed0f548fe6280c SHA512 a1f82740e673ed95cde2917d5dad53645b8cfcdefd673f44cd5b0573238c39a17355ea27e55572bb03625529202be50bf00f4bb57322ffa8857409cb1b190872
-DIST soju-0.8.0.tar.gz 154571 BLAKE2B 737fc3e44ea04b42c6a5029db0c6c65a03c22dd30c26196439c97abe2ee9f1379b9cd49ef2cf15e25a911c0d05af1f17fcfea585c85278e081e4f3b7d9d55342 SHA512 22fb0815704b70dd302d75c4a00d80ac22cd622175066e7365277ef7d5a531537aa308b53703d15651a5ae841e2a02a3d7f19165c847078c5a0ae3c40d750738
DIST soju-0.8.2-deps.tar.xz 72699036 BLAKE2B 5abfa3d683a0f06be7361bfeec751b6f4892fde51f1d9216cca163eac125e72f68a8116279b16b8ce6f5076293b7ad67b6098f887ac3cea3f099f2b27643ed48 SHA512 64fa60a90a33021661f51f2f6456bf8f2e8d01282143ad41b966ade105e6b4f2310f83f81f45bcea6baa2f76857e549f1548844ec1c3f17c1f1e0615523ef813
DIST soju-0.8.2.tar.gz 155059 BLAKE2B 17f220440c8135abeb570808d7a4cb5cdb6993c076ffe9eb2fa0bb0e8487f9b29831049b2702692cc0903277399603dbe8e0ad27ed6356b932c29979a6eeddef SHA512 7e5bc27394223c021ce6e1b9d93b617ade5bd803f37e030ea05e079efdf343ff0128753803a2e1c86ca2c83786bdaf21600cb6457b4404dd0cf2ff0e5646c62b
diff --git a/net-irc/soju/soju-0.8.0.ebuild b/net-irc/soju/soju-0.8.0.ebuild
deleted file mode 100644
index 43d0b770ae70..000000000000
--- a/net-irc/soju/soju-0.8.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-EAPI=8
-
-inherit go-module systemd
-
-DESCRIPTION="soju is a user-friendly IRC bouncer"
-HOMEPAGE="https://soju.im/"
-SRC_URI="https://git.sr.ht/~emersion/${PN}/refs/download/v${PV}/${P}.tar.gz"
-SRC_URI+=" https://github.com/alfredfo/${PN}-deps/raw/master/${P}-deps.tar.xz"
-
-LICENSE="AGPL-3 Apache-2.0 MIT BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
-IUSE="moderncsqlite +sqlite pam"
-REQUIRED_USE="?? ( moderncsqlite sqlite )"
-
-BDEPEND="
- app-text/scdoc
-"
-RDEPEND="
- acct-user/soju
- acct-group/soju
- sqlite? ( dev-db/sqlite:3 )
-"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- # musl removed legacy LFS64 interfaces in version 1.2.4 temporarily
- # reenabled using _LARGEFILE64_SOURCE until this is resolved
- # upstream https://github.com/mattn/go-sqlite3/issues/1164
- CGO_CFLAGS="${CGO_CFLAGS}"
- if use sqlite; then
- GOFLAGS+=" -tags=libsqlite3"
- CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
- elif use moderncsqlite; then
- GOFLAGS+=" -tags=moderncsqlite"
- CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
- else
- GOFLAGS+=" -tags=nosqlite"
- fi
- # Only way to pass CFLAGS to CGO at the
- # moment. https://github.com/gentoo/gentoo/pull/33539/
- export CGO_CFLAGS
- use pam && GOFLAGS+=" -tags=pam"
-
- ego build ${GOFLAGS} ./cmd/soju
- ego build ${GOFLAGS} ./cmd/sojudb
- ego build ${GOFLAGS} ./cmd/sojuctl
-
- scdoc <doc/soju.1.scd >doc/soju.1 || die
- scdoc <doc/sojuctl.1.scd >doc/sojuctl.1 || die
-}
-
-src_install() {
- dobin soju
- dobin sojudb
- dobin sojuctl
-
- doman doc/soju.1
- doman doc/sojuctl.1
- systemd_dounit contrib/soju.service
- keepdir /etc/soju
- insinto /etc/soju
- newins config.in config
- newinitd "${FILESDIR}"/soju.initd soju
- einstalldocs
-}
-
-pkg_postinst() {
- elog "${PN} requires a user database for authenticating clients."
- elog "As the soju user, create a database using:"
- elog "$ sojudb -config ${EROOT}/etc/soju/config create-user <username> [-admin]"
-}