summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin Podshumok <kpp.live+signed@gmail.com>2020-05-18 20:47:20 +0300
committerMichał Górny <mgorny@gentoo.org>2020-06-08 19:56:01 +0200
commitfca729a33472e3af4d8d54acedfe6a7da3f70640 (patch)
tree826f50ba3f3b547988ab9fc73697af001e850c18 /net-libs/cppzmq/files
parentnet-libs/cppzmq: drop old (diff)
downloadgentoo-fca729a33472e3af4d8d54acedfe6a7da3f70640.tar.gz
gentoo-fca729a33472e3af4d8d54acedfe6a7da3f70640.tar.bz2
gentoo-fca729a33472e3af4d8d54acedfe6a7da3f70640.zip
net-libs/cppzmq: bump v4.6.0, add tests
Closes: https://bugs.gentoo.org/634076 Closes: https://github.com/gentoo/gentoo/pull/15868 Signed-off-by: Konstantin Podshumok <kpp.live+signed@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/cppzmq/files')
-rw-r--r--net-libs/cppzmq/files/cppzmq-disable-static.patch35
-rw-r--r--net-libs/cppzmq/files/cppzmq-use-system-catch2.patch27
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/cppzmq/files/cppzmq-disable-static.patch b/net-libs/cppzmq/files/cppzmq-disable-static.patch
new file mode 100644
index 000000000000..12b1c2231205
--- /dev/null
+++ b/net-libs/cppzmq/files/cppzmq-disable-static.patch
@@ -0,0 +1,35 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,7 +20,7 @@
+ message(FATAL_ERROR "ZeroMQ was not found, neither as a CMake package nor via pkg-config")
+ endif()
+
+-if (ZeroMQ_FOUND AND (NOT TARGET libzmq OR NOT TARGET libzmq-static))
++if (ZeroMQ_FOUND AND NOT TARGET libzmq)
+ message(FATAL_ERROR "ZeroMQ version not supported!")
+ endif()
+
+@@ -43,19 +43,20 @@
+ zmq_addon.hpp
+ )
+
+-foreach (target cppzmq cppzmq-static)
++set (cppzmq_targets cppzmq cppzmq-static)
++
++foreach (target ${cppzmq_targets})
+ add_library(${target} INTERFACE)
+ target_include_directories(${target} INTERFACE $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+ $<INSTALL_INTERFACE:include>)
+ endforeach()
+
+ target_link_libraries(cppzmq INTERFACE libzmq)
+-target_link_libraries(cppzmq-static INTERFACE libzmq-static)
+
+ include(GNUInstallDirs)
+ include(CMakePackageConfigHelpers)
+
+-install(TARGETS cppzmq cppzmq-static
++install(TARGETS ${cppzmq_targets}
+ EXPORT ${PROJECT_NAME}-targets)
+
+ install(FILES ${CPPZMQ_HEADERS}
diff --git a/net-libs/cppzmq/files/cppzmq-use-system-catch2.patch b/net-libs/cppzmq/files/cppzmq-use-system-catch2.patch
new file mode 100644
index 000000000000..b15b9172ad43
--- /dev/null
+++ b/net-libs/cppzmq/files/cppzmq-use-system-catch2.patch
@@ -0,0 +1,27 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -9,9 +9,10 @@
+ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/${CMAKE_INSTALL_LIBDIR})
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/${CMAKE_INSTALL_BINDIR})
+
++find_package(Catch2 REQUIRED)
+ include(CTest)
+-include(cmake/catch.cmake)
+-include(${CATCH_MODULE_PATH}/Catch.cmake)
++include(Catch)
++find_path(CATCH_INCLUDE_DIR "catch.hpp" HINT /usr/include/catch/)
+
+ find_package(Threads)
+
+@@ -31,9 +32,9 @@
+ utilities.cpp
+ )
+
+-add_dependencies(unit_tests catch)
++add_dependencies(unit_tests Catch2::Catch2)
+
+-target_include_directories(unit_tests PUBLIC ${CATCH_MODULE_PATH})
++target_include_directories(unit_tests PUBLIC ${CATCH_INCLUDE_DIR})
+ target_link_libraries(
+ unit_tests
+ PRIVATE cppzmq