summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-31 23:10:04 -0300
committerMatt Turner <mattst88@gentoo.org>2023-08-02 10:51:42 -0400
commit532c05862399c1413abfde964df867829d54980a (patch)
treec3057cbe756ba1cb0bb0a00f387fbc6bed33420e /net-libs/gupnp
parentdev-python/urllib3: Stabilize 2.0.3 hppa, #909712 (diff)
downloadgentoo-532c05862399c1413abfde964df867829d54980a.tar.gz
gentoo-532c05862399c1413abfde964df867829d54980a.tar.bz2
gentoo-532c05862399c1413abfde964df867829d54980a.zip
net-libs/gupnp: Version bump to 1.6.5
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32124 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/gupnp')
-rw-r--r--net-libs/gupnp/Manifest1
-rw-r--r--net-libs/gupnp/gupnp-1.6.5.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
index e7f799744fd1..9f37d4302801 100644
--- a/net-libs/gupnp/Manifest
+++ b/net-libs/gupnp/Manifest
@@ -1,3 +1,4 @@
DIST gupnp-1.4.3.tar.xz 154812 BLAKE2B b41a8805853061399412f5eb7267e9913adb3054ebf8a3bd78f6df4c1607d4a944654f3bc6e154fefa98f1289a80055d0feb0168801d83a1ad59c25f5fcac784 SHA512 1963ce917458168c8bc5d669ee30a4071d83d3768ce1be8cbbd81c767853ca01950623a88628a0b1e403d1cce1f0bbc9df80acf4b75f91bfc0403e0d0e6bcedb
DIST gupnp-1.6.3.tar.xz 2216496 BLAKE2B 635aafa78f8cb7b9542eab14545864a93d5fe01296444397ddb1d1868d51c9bb8013e17e659dce550581f7ae9cbc31a74fb30563d1961b341c3f672390d08f6a SHA512 423605e15dafb1f3789910289604912212a04595bad174654cce5b7717ab0d307ad7e021fc8f0ce59fb090d285fbcf633de63dc40c5f6cebad6a28553a5d6f17
DIST gupnp-1.6.4.tar.xz 242944 BLAKE2B 485052a7f6448b8a09767987aaf679ee5a5946557ef49e402b94d05218fcedf646a45e89f670a1bce5b54951aeb85f327dfdc7094b22d8e02cff27551fad2ea3 SHA512 00fe34960f366f69915f3627637905d3a32d1a2757155f16f67fd434601106b38368a5e28c8f13dc57030e4fcf74755e5149f7e36b6a4a4abe6fe12a41034333
+DIST gupnp-1.6.5.tar.xz 163380 BLAKE2B 92c29db56a0fe9596bb0c523fc31be0783d6cf95b1926868a6e8a5e95ed9e28aa04ddf0f6740681995244c5020cfddb9b8ab8aeaf2baeb622185aa3a76a2986e SHA512 c34def9accb0984e17298156b7d325eebd89cc0f0f9568740b15f20a05ce523c8f97b5cc98cee1245c0bdea0a5b4fe97878b810c3325239d87d7d577cd0742a5
diff --git a/net-libs/gupnp/gupnp-1.6.5.ebuild b/net-libs/gupnp/gupnp-1.6.5.ebuild
new file mode 100644
index 000000000000..65a1aa08e3f7
--- /dev/null
+++ b/net-libs/gupnp/gupnp-1.6.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org meson-multilib python-single-r1 vala xdg
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gupnp"
+
+LICENSE="LGPL-2+ GPL-2+" # gupnp-binding-tool is GPL-2+
+SLOT="1.6/1.6-0" # <API version>-<soname>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="connman gtk-doc +introspection networkmanager +vala"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( connman networkmanager )
+ gtk-doc? ( introspection )
+"
+
+# prefix: uuid dependency can be adapted to non-linux platforms
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.70:2[${MULTILIB_USEDEP}]
+ >=net-libs/gssdp-1.6.2:1.6=[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.99.0:3.0[introspection?,${MULTILIB_USEDEP}]
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ virtual/pkgconfig
+ !connman? ( !networkmanager? ( kernel_linux? ( sys-kernel/linux-headers ) ) )
+ vala? ( $(vala_depend)
+ >=net-libs/gssdp-1.5.2:1.6[vala]
+ net-libs/libsoup:3.0[vala]
+ )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+
+ # This makes sense for upstream but not for us downstream, bug #906124.
+ sed -i -e '/-Werror=deprecated-declarations/d' meson.build || die
+}
+
+multilib_src_configure() {
+ local backend=system
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ local emesonargs=(
+ -Dcontext_manager=${backend}
+ $(meson_native_use_bool introspection)
+ $(meson_native_use_bool vala vapi)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Dexamples=false
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ python_fix_shebang "${ED}"/usr/bin/gupnp-binding-tool-1.6
+ if use gtk-doc ; then
+ mkdir "${ED}"/usr/share/gtk-doc || die
+ mv "${ED}"/usr/share/{doc,gtk-doc}/gupnp-1.6 || die
+ fi
+}