summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-09-25 09:45:27 +0100
committerMatthew Smith <matthew@gentoo.org>2022-09-25 09:46:35 +0100
commit00df04e7f79700a48a65765c825741b74668afca (patch)
tree67a4804b36245b88e5e71b47bf9e4ff8e62de602 /net-mail
parentdev-lang/erlang: drop 24.3.3-r1, security cleanup (diff)
downloadgentoo-00df04e7f79700a48a65765c825741b74668afca.tar.gz
gentoo-00df04e7f79700a48a65765c825741b74668afca.tar.bz2
gentoo-00df04e7f79700a48a65765c825741b74668afca.zip
net-mail/mu: add 1.8.10
Closes: https://bugs.gentoo.org/872779 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.8.10.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 2fd4bf0df999..0c63da4d6d4b 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
+DIST mu-1.8.10.tar.xz 541408 BLAKE2B e1533d5fb83df2913a6041526adc1efa15d7eca2933f21765d1b9f405d69043932dfc9a9a65eca81bb898bb7bb9d0213fca7025dfc4e8dd729fe46daccb9a5b8 SHA512 56e4d51b40b406b53857b883b60eda2499b6c07fa3bad7c2bfdfab472f1fe60aa33eeb2b24fdeef1cc2655c8a0e9d799e81dad96fba3d7152e66e80a1d7f0bce
DIST mu-1.8.7.tar.xz 539664 BLAKE2B 2f0081f350c0d6da4b7920c0380a02aab42eda12062011bd03a46ceb925c179089b794b501df53b4fc84daa38e6e977a3510801685aa7c91c1c0be58c9c78929 SHA512 04c2027acec80c7569f055c8324f947862721aa36b093dba07ac80b9051229a51225e5371af7cd48fae71c9d5148bd3dc2081f591b9f733bccb5650b4853df67
DIST mu-1.8.8.tar.xz 540092 BLAKE2B 3cd3d5f41aaf145dee66fc6d5e71256a650b16d0ee99da253d7ffc87df2e36b5fef6d19dd8831002d040c5d6ed13a53e9df69d18d7c002a05a64fb22fe32f5f5 SHA512 deb48ef7d12d76575f14e5313e9c94a40a04dc916943fa45d4281aa637b6549cbcee3cc0879b9daab51e0409cdfdc619acae12bf2ff3edaeb84fb77c3bee8982
DIST mu-1.8.9.tar.xz 541308 BLAKE2B 418458f5e04d15cce9aa0ea650e06377c5eb2a3f08e47610ce8ac63b68f5e7914b3d70ec4e07c5b89399aaad8a6e340dd6943980e6de94b02ff299358d99d07f SHA512 534bf2c0889d436601638afa7f214492b927f1a3aa4f36509ac607132dcc17f2181e7b1d2113fdf00989bf5eb71cf7ad9b19411393fe1edbb8de162b7f7636bf
diff --git a/net-mail/mu/mu-1.8.10.ebuild b/net-mail/mu/mu-1.8.10.ebuild
new file mode 100644
index 000000000000..2e8ad733ced5
--- /dev/null
+++ b/net-mail/mu/mu-1.8.10.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common meson
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+IUSE="emacs readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/texinfo
+ virtual/pkgconfig
+"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_prepare() {
+ default
+
+ # Don't install NEWS.org into /usr/share/doc.
+ sed -i '/NEWS.org/,+1 d' meson.build || die
+ sed -i '/mu4e-about.org/d' mu4e/meson.build || die
+
+ # Don't compress the info file.
+ sed -i '/gzip/d' build-aux/meson-install-info.sh || die
+
+ # Instead, put it in /usr/share/doc/${PF}.
+ sed -i "/MU_DOC_DIR/s/mu/${PF}/" mu4e/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature readline)
+ -Demacs="$(usex emacs "${EMACS}" emacs-not-enabled)"
+ # NOTE: Guile interface is deprecated to be removed shortly.
+ -Dguile=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Since meson no longer installs NEWS.org, install it with dodoc.
+ # Also, it must be uncompressed so that it can be viewed with
+ # mu4e-info.
+ docompress -x /usr/share/doc/${PF}/NEWS.org
+ dodoc NEWS.org
+
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}