summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-08-07 13:00:30 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-07 21:32:34 +0200
commit8af93c014c2cec57b4f93b963756266f5967c35c (patch)
tree18ea7da39a5ec30ed5722cc53943ce225b38da80 /net-mail
parentnet-mail/altermime: drop 0.3.11-r1 (diff)
downloadgentoo-8af93c014c2cec57b4f93b963756266f5967c35c.tar.gz
gentoo-8af93c014c2cec57b4f93b963756266f5967c35c.tar.bz2
gentoo-8af93c014c2cec57b4f93b963756266f5967c35c.zip
net-mail/mailfront: respect AR, RANLIB and LDFLAGS
Closes: https://bugs.gentoo.org/727834 Closes: https://bugs.gentoo.org/792249 Closes: https://bugs.gentoo.org/792252 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailfront/mailfront-2.22-r1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/net-mail/mailfront/mailfront-2.22-r1.ebuild b/net-mail/mailfront/mailfront-2.22-r1.ebuild
index 1ca496fbbd32..d7880f49f5c7 100644
--- a/net-mail/mailfront/mailfront-2.22-r1.ebuild
+++ b/net-mail/mailfront/mailfront-2.22-r1.ebuild
@@ -19,13 +19,26 @@ RDEPEND="${DEPEND}
virtual/qmail
net-libs/cvm"
+src_prepare() {
+ default
+ local sed_args=(
+ # make compilation more verbose
+ -e '/exec/ {h;s/exec/echo/g;G}'
+ # replace AR and be more verbose, bug #792249
+ -e "/ar cr/ {h;s/ar/echo &/;G;s:ar:$(tc-getAR):g}"
+ # replace RANLIB and be more verbose, bug #792252
+ -e "/ranlib/ {h;s/ranlib/echo &/;G;s:ranlib:$(tc-getRANLIB):g}"
+ )
+ sed -i "${sed_args[@]}" Makefile || die
+}
+
src_configure() {
echo "${EPREFIX}/var/qmail" > conf-qmail || die
echo "/var/qmail/bin" > conf-bin || die
echo "/usr/$(get_libdir)/mailfront" > conf-modules || die
echo "/usr/include" > conf-include || die
echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
- echo "$(tc-getCC) ${CFLAGS} -fPIC -shared" > conf-ccso || die
+ echo "$(tc-getCC) ${CFLAGS} -fPIC -shared ${LDFLAGS}" > conf-ccso || die
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
}