summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-04-08 08:31:12 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-13 10:41:30 +0300
commit46efb4476075643dc57161ef2503e270fb3e1e58 (patch)
tree5e0473dcb7e40fe7e3c779e58eb4ceff95a05dfd /net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild
parentnet-misc/asterisk-g729: version bump post asterisk-16. (diff)
downloadgentoo-46efb4476075643dc57161ef2503e270fb3e1e58.tar.gz
gentoo-46efb4476075643dc57161ef2503e270fb3e1e58.tar.bz2
gentoo-46efb4476075643dc57161ef2503e270fb3e1e58.zip
net-misc/asterisk-opus: version bump post asterisk-16
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/15266 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild')
-rw-r--r--net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild b/net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild
new file mode 100644
index 000000000000..43c46db99b3b
--- /dev/null
+++ b/net-misc/asterisk-opus/asterisk-opus-16.0.1.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="OPUS codec and supporting files for asterisk"
+HOMEPAGE="https://wiki.asterisk.org/wiki/display/AST/Codec+Opus"
+
+AST_PV="$(ver_cut 1-2)"
+MY_PV="$(ver_rs 2 _)"
+
+SRC_URI="amd64? (
+ https://downloads.digium.com/pub/telephony/codec_opus/asterisk-${AST_PV}/x86-64/codec_opus-${MY_PV}-x86_64.tar.gz
+)
+x86? (
+ https://downloads.digium.com/pub/telephony/codec_opus/asterisk-${AST_PV}/x86-32/codec_opus-${MY_PV}-x86_32.tar.gz
+)"
+
+LICENSE="Digium"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=net-misc/asterisk-${PV%%.*}*"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ QA_FLAGS_IGNORED="/usr/$(get_libdir)/asterisk/modules/codec_opus.so"
+}
+
+src_install() {
+ local arch
+
+ if use x86; then
+ arch=x86_32
+ elif use amd64; then
+ arch=x86_64
+ fi
+
+ dodoc codec_opus-${MY_PV}-${arch}/README
+ insinto /usr/$(get_libdir)/asterisk/modules/
+ doins "codec_opus-${MY_PV}-${arch}/codec_opus.so"
+
+ insinto /var/lib/asterisk/documentation/thirdparty
+ doins "codec_opus-${MY_PV}-${arch}/codec_opus_config-en_US.xml"
+}