summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-06-14 21:47:22 -0400
committerBrian Evans <grknight@gentoo.org>2018-06-14 21:47:22 -0400
commit06cbece7cf78f7cf9589ee01b2dd862fd47d833c (patch)
tree2a4b42d3d3a5f61c415715c9096407d6a07631bf /net-misc/omnisync/omnisync-1.0_p20180614.ebuild
parentdev-libs/xerces-c: support Prefix. (diff)
downloadgentoo-06cbece7cf78f7cf9589ee01b2dd862fd47d833c.tar.gz
gentoo-06cbece7cf78f7cf9589ee01b2dd862fd47d833c.tar.bz2
gentoo-06cbece7cf78f7cf9589ee01b2dd862fd47d833c.zip
net-misc/omnisync: Add new snapshot release
This snapshot incorporates Robin Johnson's (robbat2) patches. A real configuration with cmake now exists. Also, a move to GnuTLS to fill memory leaks due to improper use of OpenSSL, and poorly documented on how to call it so a connecting client does not leak. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc/omnisync/omnisync-1.0_p20180614.ebuild')
-rw-r--r--net-misc/omnisync/omnisync-1.0_p20180614.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/omnisync/omnisync-1.0_p20180614.ebuild b/net-misc/omnisync/omnisync-1.0_p20180614.ebuild
new file mode 100644
index 000000000000..c074a15980df
--- /dev/null
+++ b/net-misc/omnisync/omnisync-1.0_p20180614.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils vcs-snapshot
+
+SNAPSHOT="b3a759af454552f4bbd3b1e097b41bd0d1d7fcf5"
+
+DESCRIPTION="A driver for NTPd for people who are firewall-challenged"
+HOMEPAGE="https://www.vanheusden.com/time/omnisync"
+LICENSE="GPL-2"
+SRC_URI="https://gitlab.com/grknight/omnisync/-/archive/${SNAPSHOT}/omnisync-${SNAPSHOT}.tar.bz2 -> ${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-libs/gnutls:= net-analyzer/net-snmp:="
+DEPEND="${RDEPEND}"
+DOCS=( readme.txt Changes )
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR%/}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR%/}/${PN}.confd" ${PN}
+ einstalldocs
+}
+
+pkg_postinst() {
+ local isConfigured=$(grep 'OMNISYNC_MODE=""' "${ROOT%/}/etc/conf.d/${PN}")
+ if [[ -n "${isConfigured}" ]] ; then
+ elog "Be sure to configure ${PN} in ${ROOT%/}/etc/conf.d before trying to start the service"
+ fi
+}