summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2023-03-04 20:35:41 +0100
committerSam James <sam@gentoo.org>2023-03-19 04:47:07 +0000
commit7e5252f929e16aaf42f4ea14941fb3844c20137e (patch)
tree02843bc0639f36aaf540ceed58e13b75c0f81d76 /net-misc
parentdev-util/premake: drop 3.7-r1, 4.4_beta5 (diff)
downloadgentoo-7e5252f929e16aaf42f4ea14941fb3844c20137e.tar.gz
gentoo-7e5252f929e16aaf42f4ea14941fb3844c20137e.tar.bz2
gentoo-7e5252f929e16aaf42f4ea14941fb3844c20137e.zip
net-misc/seafile: version bump to 9.0.0
Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/seafile/Manifest1
-rw-r--r--net-misc/seafile/seafile-9.0.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/seafile/Manifest b/net-misc/seafile/Manifest
index 0ea1f1b800d3..9c914ccea01b 100644
--- a/net-misc/seafile/Manifest
+++ b/net-misc/seafile/Manifest
@@ -1,2 +1,3 @@
DIST seafile-8.0.10.gh.tar.gz 749686 BLAKE2B 76c5f6e71dcf12c6950bfde17e529ea8d24efed78069d9bbc93c78f04167be371884aa069b6665afc21be5114352b7a73e5cf09d6f7f9cea6bad323c956ef254 SHA512 9ef1f01d180fe08452c39bd35683610844ff849fa261d98ac7366fde6af27886e823976f6fa2e82407fb844dcb4de8160658abd807eb1d4932e999a4ad75dd50
DIST seafile-8.0.9.gh.tar.gz 740920 BLAKE2B c62c7ccea536934a92166db5d2acea45b65f5508c1e5d4f70749c922c12d29da11bc2265203c91e87fe0096cc3f4b6ec4f6125b538a4de88725583871b05e67e SHA512 c4621ea4c08fcd9c5d4cf683152f7504c37212272b5a9535da869de846b71a7f5e9a72c5544f9b7487ad8025a6cdf2866c15788828cc27937209d8242fc13cb8
+DIST seafile-9.0.0.tar.gz 749947 BLAKE2B df9e68d1ee46c03d5d7cab35f141b6e7a890e78a5864bf55b4ac2913a214e24660f57157123845b62aa72c6ad1e689d6cf53bbe6b43f44c0178a867cb0e6c78e SHA512 3ab5a62faf7210e27df58a33f790b4aaeeb5b897532ec45af283bbaf70bdf40532c8be6481ef43752fc1e646e2d8d1c890f3e039df1d058d7067e2bae99e40fb
diff --git a/net-misc/seafile/seafile-9.0.0.ebuild b/net-misc/seafile/seafile-9.0.0.ebuild
new file mode 100644
index 000000000000..45069b35de3e
--- /dev/null
+++ b/net-misc/seafile/seafile-9.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# Upstream is moving tags repeatedly, then we use commit hash.
+RELEASE_COMMIT="c244a274912070a39864369a6a21c55566fe2fda"
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/${RELEASE_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ dev-libs/openssl:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/jansson:=
+ dev-libs/libevent:=
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ net-libs/libwebsockets[client]
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ $(vala_depend)"
+
+S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ vala_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"/usr/bin/seaf-cli
+}