summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-06-16 21:29:03 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-06-16 21:36:23 +0200
commited5629df8381f940de93a0e6c0b193d0e5260d04 (patch)
tree945bac4b8f6bbf3ad4acb64167ab450e27d03129 /net-p2p/airdcpp-webclient
parentprofiles: Mask kde-plasma/ksysguard for removal (diff)
downloadgentoo-ed5629df8381f940de93a0e6c0b193d0e5260d04.tar.gz
gentoo-ed5629df8381f940de93a0e6c0b193d0e5260d04.tar.bz2
gentoo-ed5629df8381f940de93a0e6c0b193d0e5260d04.zip
net-p2p/airdcpp-webclient: fix build with miniupnpc 2.2.8, #934055
Also: * fix ebuild variable order. * enable Python 3.13. Closes: https://bugs.gentoo.org/934055 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild8
-rw-r--r--net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.12.1-miniupnpc-2.2.8.patch22
2 files changed, 28 insertions, 2 deletions
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild
index 848b7f674f46..e6d1af1f4eed 100644
--- a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.12.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit cmake python-any-r1 systemd
@@ -11,9 +11,9 @@ DESCRIPTION="Cross-platform Direct Connect client"
HOMEPAGE="https://airdcpp-web.github.io/"
SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="amd64 ~riscv x86"
LICENSE="GPL-2+"
SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
IUSE="debug nat-pmp +tbb +webui"
RDEPEND="
@@ -38,6 +38,10 @@ BDEPEND="
"
PDEPEND="webui? ( www-apps/airdcpp-webui )"
+PATCHES=(
+ "${FILESDIR}/${P}-miniupnpc-2.2.8.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_NATPMP=$(usex nat-pmp)
diff --git a/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.12.1-miniupnpc-2.2.8.patch b/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.12.1-miniupnpc-2.2.8.patch
new file mode 100644
index 000000000000..64dcce950d48
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.12.1-miniupnpc-2.2.8.patch
@@ -0,0 +1,22 @@
+https://github.com/airdcpp/airdcpp-windows/commit/2b1cd3d05774ce8134186bb9977a45cf00aaaef5
+
+From 2b1cd3d05774ce8134186bb9977a45cf00aaaef5 Mon Sep 17 00:00:00 2001
+From: maksis <maksis@adrenaline-network.com>
+Date: Thu, 13 Jun 2024 20:05:17 +0300
+Subject: [PATCH] Add support for miniupnpc 2.2.8
+
+--- a/airdcpp-core/airdcpp/Mapper_MiniUPnPc.cpp
++++ b/airdcpp-core/airdcpp/Mapper_MiniUPnPc.cpp
+@@ -108,7 +108,12 @@ bool Mapper_MiniUPnPc::init() {
+ UPNPUrls urls;
+ IGDdatas data;
+
++#if (MINIUPNPC_API_VERSION >= 18)
++ auto ret = UPNP_GetValidIGD(devices, &urls, &data, 0, 0, nullptr, 0);
++#else
+ auto ret = UPNP_GetValidIGD(devices, &urls, &data, 0, 0);
++#endif
++
+
+ bool ok = ret == 1;
+ if(ok) {