summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-16 03:49:53 +0100
committerSam James <sam@gentoo.org>2024-08-16 04:57:41 +0100
commita9b4ac314a1cf9ed1fa9d391c8cbdb24cb06c6d8 (patch)
treecfedef19f62bfd6f6568ec59c2bbbc24676ca5ab /net-print
parentmedia-libs/opencv: addwrite "/proc/self/task" instead of sandbox_write (diff)
downloadgentoo-a9b4ac314a1cf9ed1fa9d391c8cbdb24cb06c6d8.tar.gz
gentoo-a9b4ac314a1cf9ed1fa9d391c8cbdb24cb06c6d8.tar.bz2
gentoo-a9b4ac314a1cf9ed1fa9d391c8cbdb24cb06c6d8.zip
net-print/cups-filters: add 2.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-2.0.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 3e7f08806c56..2d26c97c2a70 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -1,2 +1,3 @@
DIST cups-filters-1.28.17.tar.xz 1516052 BLAKE2B 87258391901d55d9e59b06d54603d014e54d224a373529bd70fcd38cded9dc96c88ca73bcea63d7633c065caea3f9e3274cd450aec5f1bd90130d9a88c0d3421 SHA512 320544a48206165581adafb28dbef58f39c66bebd3641be3d180a692605349d9e6af6d464044db9f7bda17a67f4a079370d8cc880cd7873d684b2209882deb35
DIST cups-filters-2.0.0.tar.xz 447648 BLAKE2B be5e2aab4eb921aa67bfcc93aa5f95a9f1fe1a269ed73d18273a0e9a3e816187e9e32750ba6521c3ab083c3c7b7a60bb1fa679e16d4a5917f911a4ba8d4b7207 SHA512 fc8ba3bbf92d5ede295884023d1c42422c4c250dbbf21c948f160a04ded3259784df4bd17eea64492f9417f866e566be1a9fcde47d29655cd4204ef4cc7af134
+DIST cups-filters-2.0.1.tar.xz 447288 BLAKE2B 5bab10e10890332e873944f42cf53f00055a74898cd8139c3e3ee98f76f369f68c2a6c70f336167dbc43a48d92c3030e29cdfb30864bc52cdc5eb5e7b5158e7a SHA512 e80783a03722228fdd67ab5041082d1c2ad9c5c5d59a60ac1aee51a4600b2e9c0c90b78f6fdbc2c7928c2bf2bb634df7c1ec5db23de65e867a0498372f7a2c00
diff --git a/net-print/cups-filters/cups-filters-2.0.1.ebuild b/net-print/cups-filters/cups-filters-2.0.1.ebuild
new file mode 100644
index 000000000000..2d11adb47728
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-2.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+SRC_URI="https://github.com/OpenPrinting/cups-filters/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+foomatic"
+
+RDEPEND="
+ net-print/libcupsfilters
+ net-print/libppd
+ >=net-print/cups-1.7.3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# The tests are composed of:
+# - built program
+# - test case itself: filter/test.sh
+#
+# The latter is not wired up, and it becomes immediately evident why.
+# Bow to this reality and don't claim we can run anything. As a side
+# effect, don't compile in src_test, that which we never use.
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-imagefilters
+ --enable-driverless
+ --enable-poppler
+ --localstatedir="${EPREFIX}"/var
+ --with-fontdir="fonts/conf.avail"
+ # These are just probed for the path. Always enable them.
+ --with-gs-path="${EPREFIX}"/usr/bin/gs
+ --with-mutool-path="${EPREFIX}"/usr/bin/mutool
+
+ $(use_enable foomatic)
+ )
+
+ econf "${myeconfargs[@]}"
+}