summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 13:59:35 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 14:17:01 -0500
commit70dc30f5ebc6e800c0de8a5724e384eb34cf0418 (patch)
treec3c4c4f93dfd8ba7d08d672adfd582cbdc906016 /net-proxy/havp
parentnet-proxy/dnsproxy: remove old version (diff)
downloadgentoo-70dc30f5ebc6e800c0de8a5724e384eb34cf0418.tar.gz
gentoo-70dc30f5ebc6e800c0de8a5724e384eb34cf0418.tar.bz2
gentoo-70dc30f5ebc6e800c0de8a5724e384eb34cf0418.zip
net-proxy/havp: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-proxy/havp')
-rw-r--r--net-proxy/havp/files/havp.initd4
-rw-r--r--net-proxy/havp/havp-0.92a-r2.ebuild74
2 files changed, 76 insertions, 2 deletions
diff --git a/net-proxy/havp/files/havp.initd b/net-proxy/havp/files/havp.initd
index 44b00fcd0fbe..1c42fca33a50 100644
--- a/net-proxy/havp/files/havp.initd
+++ b/net-proxy/havp/files/havp.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
diff --git a/net-proxy/havp/havp-0.92a-r2.ebuild b/net-proxy/havp/havp-0.92a-r2.ebuild
new file mode 100644
index 000000000000..60fd0c143ede
--- /dev/null
+++ b/net-proxy/havp/havp-0.92a-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs user
+
+DESCRIPTION="HTTP AntiVirus Proxy"
+HOMEPAGE="http://www.server-side.de/"
+SRC_URI="http://www.server-side.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="clamav ssl"
+
+DEPEND="clamav? ( >=app-antivirus/clamav-0.98.5 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /etc/${PN} ${PN}
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.92a-run.patch \
+ "${FILESDIR}"/${PF}-pkg-config-libclamav.patch
+ sed -i configure.in -e '/^CFLAGS=/d' || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+ export CFLAGS="${CXXFLAGS}"
+ econf \
+ $(use_enable clamav) \
+ $(use_enable ssl ssl-tunnel) \
+ --localstatedir=/var
+}
+
+src_install() {
+ dosbin ${PN}/${PN}
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ insinto /etc
+ rm -r etc/${PN}/${PN}.config.in
+ doins -r etc/${PN}
+
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "/var/tmp/${PN} must be on a filesystem with mandatory locks!"
+ ewarn "You should add \"mand\" to the mount options on the relevant line in /etc/fstab."
+
+ if use ssl; then
+ echo
+ ewarn "Note: ssl USE flag only enable SSL pass-through, which means that"
+ ewarn " HTTPS pages will not be scanned for viruses!"
+ ewarn " It is impossible to decrypt data sent through SSL connections without knowing"
+ ewarn " the private key of the used certificate."
+ fi
+
+ if use clamav; then
+ echo
+ ewarn "If you plan to use clamav daemon, you should make sure clamav user can read"
+ ewarn "/var/tmp/${PN} content. This can be accomplished by enabling AllowSupplementaryGroups"
+ ewarn "in /etc/clamd.conf and adding clamav user to the ${PN} group."
+ fi
+}