summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2016-11-19 13:24:44 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2016-11-20 19:07:19 -0500
commitc80c974ca610595155e99e287545be41fe07f898 (patch)
treeb97731e5e8dd2c057a13fd74c8117b1ee6e257b1 /net-proxy/torsocks
parentdev-perl/JSON-Parse: Bump to version 0.480.0 (diff)
downloadgentoo-c80c974ca610595155e99e287545be41fe07f898.tar.gz
gentoo-c80c974ca610595155e99e287545be41fe07f898.tar.bz2
gentoo-c80c974ca610595155e99e287545be41fe07f898.zip
net-proxy/torsocks: bump to version 2.2.0
- disable network tests (bug #562848) - drop unecessary patch - use default DOCS (same installed files) Gentoo-Bug: https://bugs.gentoo.org/562848 Gentoo-Bug: https://bugs.gentoo.org/597642
Diffstat (limited to 'net-proxy/torsocks')
-rw-r--r--net-proxy/torsocks/Manifest1
-rw-r--r--net-proxy/torsocks/torsocks-2.2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-proxy/torsocks/Manifest b/net-proxy/torsocks/Manifest
index bfef683f3a04..5a0b5b3efdf3 100644
--- a/net-proxy/torsocks/Manifest
+++ b/net-proxy/torsocks/Manifest
@@ -1,2 +1,3 @@
DIST torsocks-1.2.tar.gz 456453 SHA256 bea57d3624d723724fd1e260f0e6b2a354c0da742c023aa994c7692270d111d4 SHA512 c48cf466c1d4f6204c90ccb5f741d14304b24651d18d080a73952b9a06bbe146e3f6e6c4343ed06ed7a73714d86561cde3eba369e17fc4e155f3553a8d0f3890 WHIRLPOOL af892c2a6f8070308f6867154c50ee8ce6fd20c761dbd6466ea1ae3b46730452ce0757e9de8bf698f8bd455649f3f76a4e9a0bd883408f464c619c1d41e937cf
DIST torsocks-2.1.0.tar.gz 106339 SHA256 a72c3ea757f5fe81d1ab91e0d5f0d83f195e235aae66d4df2f88a20db7028104 SHA512 5bdec6fd6c2d99effb73e418acd37ee135b3c912fad7811bfc8c724282370beea23149c6e94b995cfed0e61be43e63ac11d8c6ef420ba0137a19b96d8ac370e5 WHIRLPOOL 4511c9bff51ec25efb9b6f211d4b37931ba9c23ad89b1b272adf6b60351308e59a5e3d5157ba4adfab9e085deba435a9a1a8b4c69ec98514069c42561799c25c
+DIST torsocks-2.2.0.tar.gz 115269 SHA256 36216a1e30f47fa0e5be84761e0d72133196c8a042716017da56e9439338c87d SHA512 903d11d58ece76eaf75ff8fc11a27e4a29f94be530f2d77d1a6f0982d556a4b9c78677a43eed88f2451054d0e985672900ecf73b360fa09e80195c3b9006622b WHIRLPOOL 3ce3ec9807a9b0bb55572f71541b0ba918223e3037914ed070cd97927446bd0b8666a70b568ebd5d7a5d310cd3c6fd4103f1ae8e616cc35e8a6a92d4a6b9051e
diff --git a/net-proxy/torsocks/torsocks-2.2.0.ebuild b/net-proxy/torsocks/torsocks-2.2.0.ebuild
new file mode 100644
index 000000000000..c088f9d4e9a7
--- /dev/null
+++ b/net-proxy/torsocks/torsocks-2.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools versionator
+
+MY_PV="$(replace_version_separator 3 -)"
+MY_PF="${PN}-${MY_PV}"
+S=${WORKDIR}/${MY_PF}
+
+DESCRIPTION="Use most socks-friendly applications with Tor"
+HOMEPAGE="https://github.com/dgoulet/torsocks"
+SRC_URI="https://github.com/dgoulet/torsocks/archive/v${MY_PV}.tar.gz -> ${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+# We do not depend on tor which might be running on a different box
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Disable tests requiring network access.
+ local test
+ for test in dns fd_passing getpeername; do
+ sed -i -e "/^ test_${test} \\\\\$/d" tests/Makefile.am || \
+ die "failed to disable network tests"
+ done
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove libtool .la files
+ find "${D}" -name '*.la' -delete || die
+}