summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-03-11 19:56:41 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-04-19 12:05:17 +0200
commit99c3c6c25de89c3f5a0e791884038559e77a541e (patch)
tree66ac60454764d8bc7ae9c36c82b848490cfb6075 /net-vpn
parentnet-vpn/eduvpn-client: add 4.2.99.0 (diff)
downloadgentoo-99c3c6c25de89c3f5a0e791884038559e77a541e.tar.gz
gentoo-99c3c6c25de89c3f5a0e791884038559e77a541e.tar.bz2
gentoo-99c3c6c25de89c3f5a0e791884038559e77a541e.zip
net-vpn/eduvpn-client: sync live
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/eduvpn-client/eduvpn-client-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild b/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
index 6e6179988a41..5139e8373158 100644
--- a/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
+++ b/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,12 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/eduvpn/python-${PN}.git"
S="${WORKDIR}/${P}"
else
- VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn.asc
+ # Development Versions use a different release signing key
+ if [[ $(ver_cut 2) == 99 || $(ver_cut 3) == 99 ]] ; then
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn-dev.asc
+ else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn.asc
+ fi
inherit verify-sig
MY_P="python-${P}"
SRC_URI="
@@ -40,11 +45,11 @@ RESTRICT="test"
RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- >=net-vpn/eduvpn-common-1.2.0[${PYTHON_USEDEP}]
+ >=net-vpn/eduvpn-common-1.99.0[${PYTHON_USEDEP}]
"
if [[ ${PV} != *9999* ]] ; then
- BDEPEND="verify-sig? ( sec-keys/openpgp-keys-eduvpn )"
+ BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-eduvpn-20240307 )"
fi
PATCHES=(