summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-calculators/hcalc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-calculators/hcalc')
-rw-r--r--sci-calculators/hcalc/Manifest2
-rw-r--r--sci-calculators/hcalc/files/1.0-gentoo.patch57
-rw-r--r--sci-calculators/hcalc/hcalc-1.0-r1.ebuild36
-rw-r--r--sci-calculators/hcalc/hcalc-1.2.ebuild25
-rw-r--r--sci-calculators/hcalc/metadata.xml11
5 files changed, 131 insertions, 0 deletions
diff --git a/sci-calculators/hcalc/Manifest b/sci-calculators/hcalc/Manifest
new file mode 100644
index 000000000000..0ae91d5134df
--- /dev/null
+++ b/sci-calculators/hcalc/Manifest
@@ -0,0 +1,2 @@
+DIST hcalc-1.2.tar.xz 15456 SHA256 4e453e6ed9f83689c63f913492725e5243d9511eb8892520ba2ea202c1feb5bc SHA512 c21dac80d31f7adc5a1e7a02e5a755ac8d68547a9f25622d55e6d87c924a2535ac496ecfebcae52b1995aa414362a9005be4e2b390d0e01dab22bd692b16bf49 WHIRLPOOL b6232b4535f87db41ed040acb53067de927e30c280b09300807e77dd0c367929ec48c22e80417540f0df49330d41d687edd47752fa729f0641579214a9ccbc6e
+DIST hcalc.tar.gz 6014 SHA256 03f6fcdeb9cfafc54d4d9a138ae3489c90b529b3576434847bcc753359bdccf8
diff --git a/sci-calculators/hcalc/files/1.0-gentoo.patch b/sci-calculators/hcalc/files/1.0-gentoo.patch
new file mode 100644
index 000000000000..a2b24031fab8
--- /dev/null
+++ b/sci-calculators/hcalc/files/1.0-gentoo.patch
@@ -0,0 +1,57 @@
+diff --git a/Makefile b/Makefile
+index 5386821..eb5db3e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,5 @@
+-CC = gcc
+-CFLAGS = -g -O2 -MMD
++CC ?= gcc
++CFLAGS += -MMD
+
+ OBJS = \
+ hcalc.o \
+@@ -10,7 +10,7 @@ OBJS = \
+ $E
+
+ hcalc : $(OBJS)
+- gcc -o $@ $^ -L/usr/X11R6/lib -lXpm -lX11
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lXpm -lX11
+
+ clean :
+ -rm -f *.o *.d *~ \#* hcalc core
+diff --git a/draw.c b/draw.c
+index 5bde83d..c3bdeb2 100644
+--- a/draw.c
++++ b/draw.c
+@@ -3,6 +3,7 @@
+ http://www.delorie.com/store/hcalc/
+ */
+ #include "hcalc.h"
++#include <string.h>
+
+ static char shown_offsets[15];
+ static int shown_bitmask;
+diff --git a/input.c b/input.c
+index d7de47c..f1d45f5 100644
+--- a/input.c
++++ b/input.c
+@@ -5,6 +5,7 @@
+ #include "hcalc.h"
+ #include <ctype.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ char pending_op = 0;
+ int making_number = 0;
+diff --git a/setupx.c b/setupx.c
+index 238c1e2..74e574b 100644
+--- a/setupx.c
++++ b/setupx.c
+@@ -3,6 +3,7 @@
+ http://www.delorie.com/store/hcalc/
+ */
+ #include "hcalc.h"
++#include <stdlib.h>
+
+ Display *display=0;
+ int screen=0;
diff --git a/sci-calculators/hcalc/hcalc-1.0-r1.ebuild b/sci-calculators/hcalc/hcalc-1.0-r1.ebuild
new file mode 100644
index 000000000000..a920e559fc90
--- /dev/null
+++ b/sci-calculators/hcalc/hcalc-1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="DJ's Hex Calculator"
+HOMEPAGE="http://www.delorie.com/store/hcalc/"
+SRC_URI="http://www.delorie.com/store/hcalc/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo "Enter hcalc to run and use kill or ctrl-c to exit."
+}
diff --git a/sci-calculators/hcalc/hcalc-1.2.ebuild b/sci-calculators/hcalc/hcalc-1.2.ebuild
new file mode 100644
index 000000000000..119a78d99a77
--- /dev/null
+++ b/sci-calculators/hcalc/hcalc-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="DJ's Hex Calculator"
+HOMEPAGE="http://www.delorie.com/store/hcalc/ https://github.com/jlec/hcalc"
+SRC_URI="mirror://github/jlec/hcalc/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ einfo "Enter hcalc to run and use kill or ctrl-c to exit."
+}
diff --git a/sci-calculators/hcalc/metadata.xml b/sci-calculators/hcalc/metadata.xml
new file mode 100644
index 000000000000..cc77603f55d0
--- /dev/null
+++ b/sci-calculators/hcalc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Small X hexadecimal calculator
+</longdescription>
+ <upstream>
+ <remote-id type="github">jlec/hcalc</remote-id>
+ </upstream>
+</pkgmetadata>