summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-10-16 08:53:02 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-10-17 09:44:23 +0200
commit19fe16046fa6f252c6bcb50bb876eaef814f88bb (patch)
treec98dbbd7a87e1c2daa5d4ded87ff6dcbd9ae73fc /sci-calculators/qalculate-qt
parentsci-calculators/qalculate-gtk: Add optfeature for sci-libs/libqalculate[gnuplot] (diff)
downloadgentoo-19fe16046fa6f252c6bcb50bb876eaef814f88bb.tar.gz
gentoo-19fe16046fa6f252c6bcb50bb876eaef814f88bb.tar.bz2
gentoo-19fe16046fa6f252c6bcb50bb876eaef814f88bb.zip
sci-calculators/qalculate-qt: Add optfeature for sci-libs/libqalculate[gnuplot]
Bug: https://bugs.gentoo.org/939748 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/38994 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-calculators/qalculate-qt')
-rw-r--r--sci-calculators/qalculate-qt/qalculate-qt-5.3.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-calculators/qalculate-qt/qalculate-qt-5.3.0.ebuild b/sci-calculators/qalculate-qt/qalculate-qt-5.3.0.ebuild
index 9b69a62f2ae6..aff7118fefda 100644
--- a/sci-calculators/qalculate-qt/qalculate-qt-5.3.0.ebuild
+++ b/sci-calculators/qalculate-qt/qalculate-qt-5.3.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Bump with sci-libs/libqalculate and sci-calculators/qalculate-gtk!
-inherit qmake-utils xdg
+inherit optfeature qmake-utils xdg
DESCRIPTION="Qt-based UI for libqalculate"
HOMEPAGE="https://github.com/Qalculate/qalculate-qt"
@@ -29,3 +29,9 @@ src_configure() {
src_install() {
emake INSTALL_ROOT="${ED}" install
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "gnuplot support" sci-libs/libqalculate[gnuplot]
+}