summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-06-19 15:48:34 +0200
committerPacho Ramos <pacho@gentoo.org>2023-06-19 16:00:19 +0200
commitea0092118654e1e058a6d2b7f35687885e176ec8 (patch)
treef20bd33c194a38848bf4c81338394a2f2a545667 /sci-chemistry
parentdev-python/pypdf: Require more pillow codecs for tests (diff)
downloadgentoo-ea0092118654e1e058a6d2b7f35687885e176ec8.tar.gz
gentoo-ea0092118654e1e058a6d2b7f35687885e176ec8.tar.bz2
gentoo-ea0092118654e1e058a6d2b7f35687885e176ec8.zip
sci-chemistry/GromacsWrapper: add 0.8.4
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild40
-rw-r--r--sci-chemistry/GromacsWrapper/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild
new file mode 100644
index 000000000000..e5c508fd6ca1
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+if [[ ${PV} = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="https://github.com/Becksteinlab/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="https://gromacswrapper.readthedocs.io"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/numkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( >=dev-python/pandas-0.17[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
diff --git a/sci-chemistry/GromacsWrapper/Manifest b/sci-chemistry/GromacsWrapper/Manifest
index 38f5f6269fbc..413b6307fb54 100644
--- a/sci-chemistry/GromacsWrapper/Manifest
+++ b/sci-chemistry/GromacsWrapper/Manifest
@@ -1 +1,2 @@
DIST GromacsWrapper-0.8.2.tar.gz 1954926 BLAKE2B c05995667f925a7519e07e59519e985693effa2fd511d228d236bff978d05430d422003e1360f9fda26564e40bb69183ae8e9b7334e0427c2b177f019df38a6a SHA512 b8a3e7da43eaabaf0fe12f4c06ff80f018847f9386c16eb66c96b3840c66b79d02ee47e675c08ed81df0ef495261c3b557d64c62caac0e484f661ef6b3a5be73
+DIST GromacsWrapper-0.8.4.tar.gz 1955167 BLAKE2B 59f0301263eefaa4d7c139b34a48172c218a76f0f9488477d6203d9cd732098468dae5a73ff46aa74eb2b4433268c77bc265e506129e4c14a357042453d5f97f SHA512 822edc33c77ca4dbfbc1e4172686744345ed3c0d2305f4b19abab15576a1433bbb3b23b96f637398ad4f72cd5414d96ee531ab4a329d3acb462d90b95437a6a5