summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-17 09:40:43 +0000
committerSam James <sam@gentoo.org>2023-12-17 09:43:49 +0000
commitda31d13917542ce5d62f939834df91166762643d (patch)
tree1829d0171ea916e72b8a8da750f1761962d8010e /sci-libs/hdf5
parentprofiles/package.mask: mask erroneous dev-ruby/elasticsearch slots (diff)
downloadgentoo-da31d13917542ce5d62f939834df91166762643d.tar.gz
gentoo-da31d13917542ce5d62f939834df91166762643d.tar.bz2
gentoo-da31d13917542ce5d62f939834df91166762643d.zip
sci-libs/hdf5: add 1.14.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/Manifest1
-rw-r--r--sci-libs/hdf5/hdf5-1.14.3.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/sci-libs/hdf5/Manifest b/sci-libs/hdf5/Manifest
index f146f8d34066..cef49f76a841 100644
--- a/sci-libs/hdf5/Manifest
+++ b/sci-libs/hdf5/Manifest
@@ -2,3 +2,4 @@ DIST hdf5-1.10.5.tar.bz2 8706317 BLAKE2B ac326be8fe4ccc4b0153f15bc7d65aa8f1adc2a
DIST hdf5-1.12.2.tar.bz2 10494264 BLAKE2B 99ca5b57f6f54fa044c909f0773de62b218c1f0ec3c011f88f3c227536dd719e77ddbe42d562b1214e8843e41d8fc56db499d7f122876fdd36ef31b235229cb7 SHA512 cbb4663570de76b11adb6bf62cfdb754371d31eeab04691479a5764a45207a9c1309665ab80f51c63a4b9b87354f9cbe6835cef506a9fd554d142c6d2bec21e5
DIST hdf5-1.14.1.tar.bz2 16257319 BLAKE2B fbabbe2a61fca3f841d0206e3918390001ec1ec713696b69845eb6390595794a63740db9a7b48fd132814268e216d8fea6288cd23b04b2fa981058b557113e73 SHA512 b4dd3fca88547fdcbb2afcc22cb11bb45b7b15c3c01d9e11b7f06030ffff1a9d5c4995abb6cf27b0c4e748f1a7ca497a7f2d995ba00586f447fcd2fa537e0e16
DIST hdf5-1.14.2.tar.bz2 16070491 BLAKE2B 04acdc5352f7f0455bf6304ef07ddf51b99125bb585984bd3e27a521a784a6ad6723d64aa3b4179e4bd382334b7e68d06650404d7d4617a696d3f64917487dbc SHA512 1e1bfdff50c2e0e172d399c2d5b79b9ad0c7c72b9b30c4849aad7c5656393e8cf2af788cdf62b51fbe596023483fbc7fa23fdebf37bfe3109dae7f0783ea590f
+DIST hdf5-1.14.3.tar.bz2 16320137 BLAKE2B 4c58edc04788db739c5c74d6edbfb9277011e2d6776862404fc29b30bb2c06a4314eb317393c230ebd2617a9a362ff78183d39ae80ce08f8963bdf6c02e8a865 SHA512 06d51638a56f387f6d0ef484b72e182509c15ab639315052be9821adeed6ad08551c50d7fe84d2b550b64211f68484cf3022a4660c8004cd0afd90eaa83c1bb1
diff --git a/sci-libs/hdf5/hdf5-1.14.3.ebuild b/sci-libs/hdf5/hdf5-1.14.3.ebuild
new file mode 100644
index 000000000000..47b70efe199b
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.14.3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+# We've reverted *back* to autotools from CMake because of
+# https://github.com/HDFGroup/hdf5/issues/1814.
+inherit autotools fortran-2 flag-o-matic toolchain-funcs prefix
+
+MY_P=${PN}-${PV/_p/-patch}
+MAJOR_P=${PN}-$(ver_cut 1-2)
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="https://www.hdfgroup.org/HDF5/"
+SRC_URI="https://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="NCSA-HDF"
+SLOT="0/${PV%%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="cxx debug examples fortran +hl mpi szip test threads unsupported zlib"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ !unsupported? (
+ cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran !hl )
+ )
+"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ szip? ( virtual/szip )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/hdf5-1.14.2-0001-Make-sure-that-during-runtime-we-ll-use-the-same-lib.patch
+ "${FILESDIR}"/hdf5-1.14.2-0002-Disable-forced-stripping.patch
+ "${FILESDIR}"/hdf5-1.14.2-0003-Drop-broken-Werror-stripping.patch
+)
+
+pkg_setup() {
+ # Workaround for bug 285148
+ tc-export CXX CC AR
+
+ use fortran && fortran-2_pkg_setup
+
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Respect Gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+
+ if ! use examples; then
+ # bug #409091
+ sed -e '/^install:/ s/install-examples//' \
+ -i Makefile.am || die
+ fi
+
+ # Enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" bin/h5cc.in || die
+ hprefixify m4/libtool.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug #686620
+ use sparc && tc-is-gcc && append-flags -fno-tree-ccp
+
+ local myeconfargs=(
+ --disable-static
+ --disable-doxygen-errors
+ --enable-deprecated-symbols
+ --enable-build-mode=$(usex debug debug production)
+ --with-default-plugindir="${EPREFIX}/usr/$(get_libdir)/${PN}/plugin"
+ $(use_enable cxx)
+ $(use_enable debug codestack)
+ $(use_enable fortran)
+ $(use_enable hl)
+ $(use_enable mpi parallel)
+ $(use_enable test tests)
+ $(use_enable threads threadsafe)
+ $(use_enable unsupported)
+ $(use_with szip szlib)
+ $(use_with threads pthread)
+ $(use_with zlib)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" EPREFIX="${EPREFIX}" install
+
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
+}