summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-19 13:12:39 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-19 13:26:34 -0500
commit2d9bc6d5e9e0bfc614f40ac791816c200d949848 (patch)
tree7284ce7e95e894ef26adf7955609525c1b9e75b7 /sci-libs/libsc
parentsci-libs/libsc: add 2.8.5 (diff)
downloadgentoo-2d9bc6d5e9e0bfc614f40ac791816c200d949848.tar.gz
gentoo-2d9bc6d5e9e0bfc614f40ac791816c200d949848.tar.bz2
gentoo-2d9bc6d5e9e0bfc614f40ac791816c200d949848.zip
sci-libs/libsc: drop 9999
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/libsc')
-rw-r--r--sci-libs/libsc/libsc-9999.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sci-libs/libsc/libsc-9999.ebuild b/sci-libs/libsc/libsc-9999.ebuild
deleted file mode 100644
index 8d6bdbb8314c..000000000000
--- a/sci-libs/libsc/libsc-9999.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="Support for parallel scientific applications"
-HOMEPAGE="http://www.p4est.org/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/cburstedde/${PN}.git"
- EGIT_BRANCH="develop"
-else
- SRC_URI="https://github.com/cburstedde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE="debug examples mpi openmp threads"
-
-RDEPEND="
- sys-apps/util-linux
- sys-libs/zlib
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi[romio] )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.8.3-fix_build_system.patch
- "${FILESDIR}"/${P}-set_version.patch
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- local mycmakeargs=(
- -Dmpi="$(usex mpi)"
- -Dopenmp="$(usex openmp)"
- -Dlibrary_reldir="$(get_libdir)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- rm -r "${ED}"/usr/include/getopt.h \
- "${ED}"/usr/include/getopt_int.h \
- "${ED}"/usr/include/sc_builtin || die "rm failed"
-
- mv "${ED}"/usr/share/docs/SC/* "${ED}"/usr/share/doc/${P}/ || die "mv failed"
- rm -r "${ED}"/usr/share/docs || die "rm failed"
-}