summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-07-14 20:23:44 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-07-14 21:15:12 -0500
commitdeade5ff52628efc8005c16ca711917bf8565f99 (patch)
treee9d2de22661eb01bc30c413fc99712a1a3e964a9 /sci-libs/libsc
parentapp-benchmarks/stress-ng: add 0.16.02, drop 0.16.01 (diff)
downloadgentoo-deade5ff52628efc8005c16ca711917bf8565f99.tar.gz
gentoo-deade5ff52628efc8005c16ca711917bf8565f99.tar.bz2
gentoo-deade5ff52628efc8005c16ca711917bf8565f99.zip
sci-libs/libsc: add 2.3.6
This partially reverts commit 406d3fc821c6be208814445bc2ad98bed3c2e9b4 and bumps 2.3.3 to 2.3.6. In turns out that libsc/p4est-2.8.5 has a massive performance regression which necessitates to use the "stable" version 2.3.6. Thus, bring it back into the tree Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/libsc')
-rw-r--r--sci-libs/libsc/Manifest1
-rw-r--r--sci-libs/libsc/files/libsc-2.3-autoconf_lua_version.patch64
-rw-r--r--sci-libs/libsc/files/libsc-2.3.6-override_soname.patch13
-rw-r--r--sci-libs/libsc/libsc-2.3.6.ebuild100
-rw-r--r--sci-libs/libsc/metadata.xml3
5 files changed, 181 insertions, 0 deletions
diff --git a/sci-libs/libsc/Manifest b/sci-libs/libsc/Manifest
index af1e9c81cb76..d17cc1e97d93 100644
--- a/sci-libs/libsc/Manifest
+++ b/sci-libs/libsc/Manifest
@@ -1,2 +1,3 @@
+DIST libsc-2.3.6.tar.gz 346618 BLAKE2B 6da88f1eec572a5d30ebef5e17554874e3d88d124fbbb7582092bd43a85a547f130a5406ffd40f86d564c95a3e600b2eb854ee0378b8e0c2d755a7d45d55ff1e SHA512 9037ebeebcf84d1dc3026172ee3fd3182729fbdbdadb478e8c05670b17bd3e2f3b192bac9a509bd99312c5f944a10fb7eb0636e8c7bd133b30677eb5ead6d117
DIST libsc-2.8.3.tar.gz 360755 BLAKE2B 2d7e3a16b97de551678ebb33f362e1ef7ebb0bcbf8d00b1a5317bfbf6732cf7bb9be2d215c79395809f3c616c23da5236c4f0f436a7b8bb07171141aaf08bbb3 SHA512 9def8850898f2d7d7a6ffaffd0872bc18af28026407356a1fe10f2b4f6d4a32ae6febe59c91cfa8817969624f995d48f64e0d5424b475e3a4c501338f4de70de
DIST libsc-2.8.5.tar.gz 401520 BLAKE2B 28f74c03dc9a6238c254683585e3a6e372718bbf147f1a1bfe051d9a9079491650eca645bb695ce4c36920dda459904be6f9d41fb53163952d9076302072e181 SHA512 d7854a77cb574531d410c978af5768782d6201c730a3248371a822172cb99fe0b2efc8c2e4f495160924fb867ed77ab1b9ac17a1db349d8a6495228698cf970b
diff --git a/sci-libs/libsc/files/libsc-2.3-autoconf_lua_version.patch b/sci-libs/libsc/files/libsc-2.3-autoconf_lua_version.patch
new file mode 100644
index 000000000000..9881d0aa6227
--- /dev/null
+++ b/sci-libs/libsc/files/libsc-2.3-autoconf_lua_version.patch
@@ -0,0 +1,64 @@
+diff --git a/config/sc_include.m4 b/config/sc_include.m4
+index f6f7873..3befe0e 100644
+--- a/config/sc_include.m4
++++ b/config/sc_include.m4
+@@ -281,8 +281,7 @@ AC_DEFUN([SC_CHECK_LIBRARIES],
+ [
+ SC_REQUIRE_LIB([m], [fabs])
+ SC_CHECK_LIB([z], [adler32_combine], [ZLIB], [$1])
+-SC_CHECK_LIB([lua53 lua5.3 lua52 lua5.2 lua51 lua5.1 lua lua5], [lua_createtable],
+- [LUA], [$1])
++SC_CHECK_LIB([$LUA_IMPL], [lua_createtable], [LUA], [$1])
+ SC_CHECK_BLAS_LAPACK([$1])
+ SC_BUILTIN_ALL_PREFIX([$1])
+ SC_CHECK_PTHREAD([$1])
+diff --git a/configure.ac b/configure.ac
+index ce462e0..b291685 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -78,7 +78,7 @@ echo "o---------------------------------------"
+ AC_CHECK_HEADERS([fcntl.h sys/ioctl.h sys/select.h sys/stat.h])
+ AC_CHECK_HEADERS([linux/videodev2.h])
+ AC_CHECK_HEADERS([execinfo.h signal.h sys/time.h sys/types.h time.h])
+-AC_CHECK_HEADERS([lua.h lua5.1/lua.h lua5.2/lua.h lua5.3/lua.h])
++AC_CHECK_HEADERS([$LUA_IMPL/lua.h])
+
+ echo "o---------------------------------------"
+ echo "| Checking functions"
+diff --git a/src/sc_lua.h b/src/sc_lua.h
+index 770b52f..a6db175 100644
+--- a/src/sc_lua.h
++++ b/src/sc_lua.h
+@@ -30,29 +30,9 @@
+
+ SC_EXTERN_C_BEGIN;
+
+-#ifdef SC_HAVE_LUA5_3_LUA_H
+-#include <lua5.3/lua.h>
+-#include <lua5.3/lualib.h>
+-#include <lua5.3/lauxlib.h>
+-#else
+-#ifdef SC_HAVE_LUA5_2_LUA_H
+-#include <lua5.2/lua.h>
+-#include <lua5.2/lualib.h>
+-#include <lua5.2/lauxlib.h>
+-#else
+-#ifdef SC_HAVE_LUA5_1_LUA_H
+-#include <lua5.1/lua.h>
+-#include <lua5.1/lualib.h>
+-#include <lua5.1/lauxlib.h>
+-#else
+-#ifdef SC_HAVE_LUA_H
+-#include <lua.h>
+-#include <lualib.h>
+-#include <lauxlib.h>
+-#endif
+-#endif
+-#endif
+-#endif
++#include <@LUA_IMPL@/lua.h>
++#include <@LUA_IMPL@/lualib.h>
++#include <@LUA_IMPL@/lauxlib.h>
+
+ SC_EXTERN_C_END;
+
diff --git a/sci-libs/libsc/files/libsc-2.3.6-override_soname.patch b/sci-libs/libsc/files/libsc-2.3.6-override_soname.patch
new file mode 100644
index 000000000000..54a45294c380
--- /dev/null
+++ b/sci-libs/libsc/files/libsc-2.3.6-override_soname.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 914237c..0bf982a 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -45,7 +45,7 @@ src_libsc_la_SOURCES = \
+ src_libsc_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBSC_CPPFLAGS)
+ ## This is the official API versioning scheme of libtool. Please see:
+ ## Read https://www.gnu.org/software/libtool/manual/libtool.html#Versioning
+-src_libsc_la_LDFLAGS = -version-info 1:0:0
++src_libsc_la_LDFLAGS = -release $(VERSION)
+ LDADD += src/libsc.la
+
+ nodist_include_HEADERS += $(libsc_generated_headers)
diff --git a/sci-libs/libsc/libsc-2.3.6.ebuild b/sci-libs/libsc/libsc-2.3.6.ebuild
new file mode 100644
index 000000000000..fcea0df228e5
--- /dev/null
+++ b/sci-libs/libsc/libsc-2.3.6.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} )
+
+inherit autotools lua-single toolchain-funcs
+
+DESCRIPTION="Support for parallel scientific applications"
+HOMEPAGE="http://www.p4est.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cburstedde/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/cburstedde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="debug examples mpi openmp romio threads"
+REQUIRED_USE="
+ ${LUA_REQUIRED_USE}
+ romio? ( mpi )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ sys-apps/util-linux
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[romio?] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3-autoconf_lua_version.patch
+ "${FILESDIR}"/${PN}-2.3.6-override_soname.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "s/@LUA_IMPL@/${ELUA}/" "${S}"/src/sc_lua.h || die
+
+ # Inject a version number into the build system
+ echo "${PV}" > "${S}"/.tarball-version || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable debug)
+ $(use_enable mpi)
+ $(use_enable openmp openmp)
+ $(use_enable romio mpiio)
+ $(use_enable threads pthread)
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ econf LUA_IMPL="${ELUA}" "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/*
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ # Remove compiled example binaries in case of -examples:
+ rm -r "${ED}"/usr/bin || die "rm failed"
+ fi
+
+ # Remove ac files, bug #619806
+ rm -r "${ED}"/usr/share/aclocal || die "rm failed"
+
+ # Fix wrong installation paths:
+ dodir /usr/share/libsc
+ mv "${ED}"/etc/* "${ED}"/usr/share/libsc || die "mv failed"
+ rmdir "${ED}"/etc/ || die "rmdir failed"
+ mv "${ED}"/usr/share/ini/* "${ED}"/usr/share/libsc || die "mv failed"
+ rmdir "${ED}"/usr/share/ini || die "rmdir failed"
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/libsc/metadata.xml b/sci-libs/libsc/metadata.xml
index ff1113592d21..9267d0132a0b 100644
--- a/sci-libs/libsc/metadata.xml
+++ b/sci-libs/libsc/metadata.xml
@@ -13,6 +13,9 @@
The SC Library provides support for parallel scientific applications.
This support library is primarily used by <pkg>sci-libs/p4est</pkg>.
</longdescription>
+ <use>
+ <flag name="romio">Build with support for the ROMIO MPI-IO component</flag>
+ </use>
<upstream>
<remote-id type="github">cburstedde/libsc</remote-id>
</upstream>