summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/shapelib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/shapelib')
-rw-r--r--sci-libs/shapelib/Manifest1
-rw-r--r--sci-libs/shapelib/files/fix-shapelib-test.diff30
-rw-r--r--sci-libs/shapelib/files/makefile-fix.patch9
-rw-r--r--sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch118
-rw-r--r--sci-libs/shapelib/files/stdlib_include_fix.patch30
-rw-r--r--sci-libs/shapelib/metadata.xml6
-rw-r--r--sci-libs/shapelib/shapelib-1.3.0-r1.ebuild67
7 files changed, 261 insertions, 0 deletions
diff --git a/sci-libs/shapelib/Manifest b/sci-libs/shapelib/Manifest
new file mode 100644
index 000000000000..86aae200b2f3
--- /dev/null
+++ b/sci-libs/shapelib/Manifest
@@ -0,0 +1 @@
+DIST shapelib-1.3.0.tar.gz 156301 SHA256 23d474016158ab5077db2f599527631706ba5c0dc7c4178a6a1d685bb014f68f SHA512 286a9faf7d7a6d88db3cceffb4e0fe335e5d754244b4e83110862ba0f88904aa10dd2814aa0c93d7531781cb318052d3f683160c9644f83f93e7d20108ac3b60 WHIRLPOOL 79b44dac05f8ca5e10809f7af1e9d0d1f1f5a2c7009698aa5dd33260a362c75b7e7f09cf535d58b6510f355ff5dfb193f2a0c7d14ef913caa4a0d5b099ef3a5b
diff --git a/sci-libs/shapelib/files/fix-shapelib-test.diff b/sci-libs/shapelib/files/fix-shapelib-test.diff
new file mode 100644
index 000000000000..859a5838047b
--- /dev/null
+++ b/sci-libs/shapelib/files/fix-shapelib-test.diff
@@ -0,0 +1,30 @@
+--- makeshape.sh.orig 2003-04-07 15:03:22.000000000 +0200
++++ makeshape.sh 2009-09-06 11:31:37.000000000 +0200
+@@ -5,17 +5,17 @@
+ # should display in ARCView II.
+ #
+
+-shpcreate test polygon
+-dbfcreate test.dbf -s Description 30 -n TestInt 6 0 -n TestDouble 16 5
++./shpcreate test polygon
++./dbfcreate test.dbf -s Description 30 -n TestInt 6 0 -n TestDouble 16 5
+
+-shpadd test 0 0 100 0 100 100 0 100 0 0 + 20 20 20 30 30 30 20 20
+-dbfadd test.dbf "Square with triangle missing" 1.5 2.5
++./shpadd test 0 0 100 0 100 100 0 100 0 0 + 20 20 20 30 30 30 20 20
++./dbfadd test.dbf "Square with triangle missing" 1.5 2.5
+
+-shpadd test 150 150 160 150 180 170 150 150
+-dbfadd test.dbf "Smaller triangle" 100 1000.25
++./shpadd test 150 150 160 150 180 170 150 150
++./dbfadd test.dbf "Smaller triangle" 100 1000.25
+
+-shpadd test 150 150 160 150 180 170 150 150
+-dbfadd test.dbf "" "" ""
++./shpadd test 150 150 160 150 180 170 150 150
++./dbfadd test.dbf "" "" ""
+
+-shpdump test.shp
+-dbfdump test.dbf
++./shpdump test.shp
++./dbfdump test.dbf
diff --git a/sci-libs/shapelib/files/makefile-fix.patch b/sci-libs/shapelib/files/makefile-fix.patch
new file mode 100644
index 000000000000..f30bbfc2d215
--- /dev/null
+++ b/sci-libs/shapelib/files/makefile-fix.patch
@@ -0,0 +1,9 @@
+--- Makefile.orig 2009-10-17 23:37:30.307257014 -0700
++++ Makefile 2009-10-17 23:38:25.914190883 -0700
+@@ -1,6 +1,7 @@
+
+ #LINKOPT = /usr/local/lib/libdbmalloc.a
++LINKOPT = $(LDFLAGS)
+ CFLAGS = -g
+
+ default: all
diff --git a/sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch b/sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch
new file mode 100644
index 000000000000..04963108ec42
--- /dev/null
+++ b/sci-libs/shapelib/files/shapelib-1.3.0-respect-user.patch
@@ -0,0 +1,118 @@
+ Makefile | 41 ++++++++++++++++++++---------------------
+ 1 file changed, 20 insertions(+), 21 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0c41d8a..4149412 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,9 @@
+
+-PREFIX = /usr/local
+-CFLAGS = -g -Wall -fPIC
++PREFIX ?= /usr/localxs
++CFLAGS ?= -g -Wall -fPIC
+ #CFLAGS = -g -DUSE_CPL
+ #CC = g++
++AR ?= ar
+
+ LIBOBJ = shpopen.o dbfopen.o safileio.o shptree.o
+ SHPBIN = shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump \
+@@ -10,7 +11,7 @@ SHPBIN = shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump \
+
+ default: all
+
+-all: $(SHPBIN) shptest lib
++all: $(SHPBIN) lib
+
+ shpopen.o: shpopen.c shapefil.h
+ $(CC) $(CFLAGS) -c shpopen.c
+@@ -25,46 +26,46 @@ safileio.o: safileio.c shapefil.h
+ $(CC) $(CFLAGS) -c safileio.c
+
+ shpcreate: shpcreate.c shpopen.o safileio.o
+- $(CC) $(CFLAGS) shpcreate.c shpopen.o safileio.o $(LINKOPT) -o shpcreate
++ $(CC) $(CFLAGS) $(LDFLAGS) shpcreate.c shpopen.o safileio.o -o shpcreate
+
+ shpadd: shpadd.c shpopen.o safileio.o
+- $(CC) $(CFLAGS) shpadd.c shpopen.o safileio.o $(LINKOPT) -o shpadd
++ $(CC) $(CFLAGS) $(LDFLAGS) shpadd.c shpopen.o safileio.o -o shpadd
+
+ shpdump: shpdump.c shpopen.o safileio.o
+- $(CC) $(CFLAGS) shpdump.c shpopen.o safileio.o $(LINKOPT) -o shpdump
++ $(CC) $(CFLAGS) $(LDFLAGS) shpdump.c shpopen.o safileio.o -o shpdump
+
+ shprewind: shprewind.c shpopen.o safileio.o
+- $(CC) $(CFLAGS) shprewind.c shpopen.o safileio.o $(LINKOPT) -o shprewind
++ $(CC) $(CFLAGS) $(LDFLAGS) shprewind.c shpopen.o safileio.o -o shprewind
+
+ dbfcreate: dbfcreate.c dbfopen.o safileio.o
+- $(CC) $(CFLAGS) dbfcreate.c dbfopen.o safileio.o $(LINKOPT) -o dbfcreate
++ $(CC) $(CFLAGS) $(LDFLAGS) dbfcreate.c dbfopen.o safileio.o -o dbfcreate
+
+ dbfadd: dbfadd.c dbfopen.o safileio.o
+- $(CC) $(CFLAGS) dbfadd.c dbfopen.o safileio.o $(LINKOPT) -o dbfadd
++ $(CC) $(CFLAGS) $(LDFLAGS) dbfadd.c dbfopen.o safileio.o -o dbfadd
+
+ dbfdump: dbfdump.c dbfopen.o safileio.o
+- $(CC) $(CFLAGS) dbfdump.c dbfopen.o safileio.o $(LINKOPT) -o dbfdump
++ $(CC) $(CFLAGS) $(LDFLAGS) dbfdump.c dbfopen.o safileio.o -o dbfdump
+
+ shptest: shptest.c shpopen.o safileio.o
+- $(CC) $(CFLAGS) shptest.c shpopen.o safileio.o $(LINKOPT) -o shptest
++ $(CC) $(CFLAGS) $(LDFLAGS) shptest.c shpopen.o safileio.o -o shptest
+
+ shputils: shputils.c shpopen.o safileio.o dbfopen.o
+- $(CC) $(CFLAGS) shputils.c shpopen.o safileio.o dbfopen.o $(LINKOPT) -o shputils
++ $(CC) $(CFLAGS) $(LDFLAGS) shputils.c shpopen.o safileio.o dbfopen.o -o shputils
+
+ shptreedump: shptreedump.c shptree.o shpopen.o safileio.o
+- $(CC) $(CFLAGS) shptreedump.c shptree.o shpopen.o safileio.o $(LINKOPT) \
++ $(CC) $(CFLAGS) $(LDFLAGS) shptreedump.c shptree.o shpopen.o safileio.o \
+ -o shptreedump
+
+ clean:
+ rm -f *.o shptest $(SHPBIN) libshp.a
+
+-test: test2 test3
++test: shptest test2 test3
+
+ #
+ # Note this stream only works if example data is accessable.
+ # Fetch ftp://gdal.velocet.ca/pub/outgoing/shape_eg_data.zip
+ #
+-test1:
++test1: shptest
+ @./stream1.sh > s1.out
+ @if test "`diff s1.out stream1.out`" = '' ; then \
+ echo "******* Stream 1 Succeeded *********"; \
+@@ -74,7 +75,7 @@ test1:
+ diff s1.out stream1.out; \
+ fi
+
+-test2:
++test2: shptest
+ @./stream2.sh > s2.out
+ @if test "`diff s2.out stream2.out`" = '' ; then \
+ echo "******* Stream 2 Succeeded *********"; \
+@@ -85,7 +86,7 @@ test2:
+ diff s2.out stream2.out; \
+ fi
+
+-test3:
++test3: shptest
+ @./makeshape.sh > s3.out
+ @if test "`diff s3.out stream3.out`" = '' ; then \
+ echo "******* Stream 3 Succeeded *********"; \
+@@ -97,10 +98,8 @@ test3:
+ fi
+
+
+-lib: libshp.a
+-
+-libshp.a: $(LIBOBJ)
+- ar r libshp.a $(LIBOBJ)
++lib: $(LIBOBJ)
++ $(AR) r libshp.a $(LIBOBJ)
+
+ lib_install: libshp.a
+ cp libshp.a $(PREFIX)/lib
diff --git a/sci-libs/shapelib/files/stdlib_include_fix.patch b/sci-libs/shapelib/files/stdlib_include_fix.patch
new file mode 100644
index 000000000000..ce0b575e1b62
--- /dev/null
+++ b/sci-libs/shapelib/files/stdlib_include_fix.patch
@@ -0,0 +1,30 @@
+--- shpcreate.c.orig 2009-09-15 20:09:39.641422056 -0700
++++ shpcreate.c 2009-09-15 20:20:31.310673754 -0700
+@@ -51,6 +51,7 @@
+ static char rcsid[] =
+ "$Id$";
+
++#include <stdlib.h>
+ #include "shapefil.h"
+
+ int main( int argc, char ** argv )
+--- shpdump.c.orig 2009-09-15 20:09:47.615421028 -0700
++++ shpdump.c 2009-09-15 20:20:29.654673421 -0700
+@@ -67,6 +67,7 @@
+ static char rcsid[] =
+ "$Id$";
+
++#include <stdlib.h>
+ #include "shapefil.h"
+
+ int main( int argc, char ** argv )
+--- shprewind.c.orig 2009-09-15 20:09:58.193422322 -0700
++++ shprewind.c 2009-09-15 20:20:26.954542660 -0700
+@@ -43,6 +43,7 @@
+ *
+ */
+
++#include <stdlib.h>
+ #include "shapefil.h"
+
+ int main( int argc, char ** argv )
diff --git a/sci-libs/shapelib/metadata.xml b/sci-libs/shapelib/metadata.xml
new file mode 100644
index 000000000000..6ecd4996da1e
--- /dev/null
+++ b/sci-libs/shapelib/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <longdescription>Shapelib is for working with ESRI shape files, a format used by the commercial ArcInfo GIS package.</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/shapelib/shapelib-1.3.0-r1.ebuild b/sci-libs/shapelib/shapelib-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3dd5a923dcb0
--- /dev/null
+++ b/sci-libs/shapelib/shapelib-1.3.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs multilib versionator
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+static_to_shared() {
+ local libstatic=${1}; shift
+ local libname=$(basename ${libstatic%.a})
+ local soname=${libname}$(get_libname $(get_version_component_range 1-2))
+ local libdir=$(dirname ${libstatic})
+
+ einfo "Making ${soname} from ${libstatic}"
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ ${LINK:-$(tc-getCC)} ${LDFLAGS} \
+ -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
+ -Wl,-all_load -Wl,${libstatic} \
+ "$@" -o ${libdir}/${soname} || die "${soname} failed"
+ else
+ ${LINK:-$(tc-getCC)} ${LDFLAGS} \
+ -shared -Wl,-soname=${soname} \
+ -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
+ "$@" -o ${libdir}/${soname} || die "${soname} failed"
+ [[ $(get_version_component_count) -gt 1 ]] && \
+ ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version))
+ ln -s ${soname} ${libdir}/${libname}$(get_libname)
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-respect-user.patch
+ tc-export CC AR
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" lib
+ static_to_shared lib*.a
+ rm *.o *.a
+ emake
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin shp{create,dump,add} dbf{create,dump,add}
+ insinto /usr/include/libshp
+ doins shapefil.h
+ use test && dobin shptest
+ dolib.so lib*$(get_libname)*
+ dodoc ChangeLog README*
+ use static-libs && dolib.a lib*.a
+}