summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-07-12 20:41:52 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-07-12 20:46:04 -0400
commit1bb87cbc93f5de9323dd7e4bea1fbd29164c757d (patch)
tree52a912d56275811c65762153671692771bc07223 /sci-libs
parentdev-util/difftastic: add 0.48.0 (diff)
downloadgentoo-1bb87cbc93f5de9323dd7e4bea1fbd29164c757d.tar.gz
gentoo-1bb87cbc93f5de9323dd7e4bea1fbd29164c757d.tar.bz2
gentoo-1bb87cbc93f5de9323dd7e4bea1fbd29164c757d.zip
sci-libs/openblas: work around test parallelism issue.
Something weird is going on when we run "make tests" and the solution isn't obvious to me, so let's -j1 it for now. Unrelated to that, we don't need to build our custom shared-blas-lapack target unless USE=eselect-ldso is set, so let's not. Closes: https://bugs.gentoo.org/910174 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/openblas/openblas-0.3.23.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/openblas/openblas-0.3.23.ebuild b/sci-libs/openblas/openblas-0.3.23.ebuild
index 7638b7e3d707..0324e3a62e4c 100644
--- a/sci-libs/openblas/openblas-0.3.23.ebuild
+++ b/sci-libs/openblas/openblas-0.3.23.ebuild
@@ -122,8 +122,7 @@ src_prepare() {
src_compile() {
default
- cd interface || die
- emake shared-blas-lapack
+ use eselect-ldso && emake -C interface shared-blas-lapack
if use index-64bit; then
emake -C"${S}-index-64bit" \
@@ -133,7 +132,8 @@ src_compile() {
}
src_test() {
- emake tests
+ # https://github.com/xianyi/OpenBLAS/issues/4139
+ emake -j1 tests
}
src_install() {