summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-04-11 16:22:21 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-14 16:15:06 +0200
commit58cabfdf158ec5485bd3401f7e2ebad6d3046fdd (patch)
tree8c7432d8ddb02af14db3f5ab5c4aa6e5583f0e3f /sci-libs
parentprofiles/base: stable mask media-gfx/freecad[qt6] (diff)
downloadgentoo-58cabfdf158ec5485bd3401f7e2ebad6d3046fdd.tar.gz
gentoo-58cabfdf158ec5485bd3401f7e2ebad6d3046fdd.tar.bz2
gentoo-58cabfdf158ec5485bd3401f7e2ebad6d3046fdd.zip
sci-libs/opencascade: add tk dep, don't set USE_QT
Closes: https://bugs.gentoo.org/928674 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/opencascade/opencascade-7.7.1-r1.ebuild (renamed from sci-libs/opencascade/opencascade-7.7.1.ebuild)4
-rw-r--r--sci-libs/opencascade/opencascade-7.7.2-r1.ebuild (renamed from sci-libs/opencascade/opencascade-7.7.2.ebuild)4
-rw-r--r--sci-libs/opencascade/opencascade-7.8.0.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sci-libs/opencascade/opencascade-7.7.1.ebuild b/sci-libs/opencascade/opencascade-7.7.1-r1.ebuild
index 58050d6c5717..2c547bf457dd 100644
--- a/sci-libs/opencascade/opencascade-7.7.1.ebuild
+++ b/sci-libs/opencascade/opencascade-7.7.1-r1.ebuild
@@ -70,6 +70,7 @@ RDEPEND="
freeimage? ( media-libs/freeimage )
tbb? ( dev-cpp/tbb:= )
vtk? (
+ dev-lang/tk:=
sci-libs/vtk:=[rendering]
tbb? (
sci-libs/vtk:=[tbb,-cuda]
@@ -181,7 +182,6 @@ src_configure() {
# no package in tree
-DUSE_OPENVR="no"
-DUSE_RAPIDJSON="$(usex json)"
- -DUSE_QT="$(usex gui)"
-DUSE_TBB="$(usex tbb)"
-DUSE_TK="$(usex tk)"
-DUSE_VTK="$(usex vtk)"
@@ -195,7 +195,7 @@ src_configure() {
)
fi
- if use gui; then
+ if use examples || use gui; then
mycmakeargs+=(
-D3RDPARTY_QT_DIR="${ESYSROOT}/usr"
-DBUILD_SAMPLES_QT="$(usex examples)"
diff --git a/sci-libs/opencascade/opencascade-7.7.2.ebuild b/sci-libs/opencascade/opencascade-7.7.2-r1.ebuild
index a83c28ed566c..ce92fcc889e0 100644
--- a/sci-libs/opencascade/opencascade-7.7.2.ebuild
+++ b/sci-libs/opencascade/opencascade-7.7.2-r1.ebuild
@@ -70,6 +70,7 @@ RDEPEND="
freeimage? ( media-libs/freeimage )
tbb? ( dev-cpp/tbb:= )
vtk? (
+ dev-lang/tk:=
sci-libs/vtk:=[rendering]
tbb? (
sci-libs/vtk:=[tbb,-cuda]
@@ -181,7 +182,6 @@ src_configure() {
# no package in tree
-DUSE_OPENVR="no"
-DUSE_RAPIDJSON="$(usex json)"
- -DUSE_QT="$(usex gui)"
-DUSE_TBB="$(usex tbb)"
-DUSE_TK="$(usex tk)"
-DUSE_VTK="$(usex vtk)"
@@ -195,7 +195,7 @@ src_configure() {
)
fi
- if use gui; then
+ if use examples || use gui; then
mycmakeargs+=(
-D3RDPARTY_QT_DIR="${ESYSROOT}/usr"
-DBUILD_SAMPLES_QT="$(usex examples)"
diff --git a/sci-libs/opencascade/opencascade-7.8.0.ebuild b/sci-libs/opencascade/opencascade-7.8.0.ebuild
index ffa9e2065e14..fb390401a82b 100644
--- a/sci-libs/opencascade/opencascade-7.8.0.ebuild
+++ b/sci-libs/opencascade/opencascade-7.8.0.ebuild
@@ -70,6 +70,7 @@ RDEPEND="
jemalloc? ( dev-libs/jemalloc )
tbb? ( dev-cpp/tbb:= )
vtk? (
+ dev-lang/tk:=
sci-libs/vtk:=[rendering]
tbb? (
sci-libs/vtk:=[tbb,-cuda]
@@ -182,7 +183,6 @@ src_configure() {
# no package in tree
-DUSE_OPENVR="no"
-DUSE_RAPIDJSON="$(usex json)"
- -DUSE_QT="$(usex gui)"
-DUSE_TBB="$(usex tbb)"
-DUSE_TK="$(usex tk)"
-DUSE_VTK="$(usex vtk)"
@@ -210,7 +210,7 @@ src_configure() {
)
fi
- if use gui; then
+ if use examples || use gui; then
mycmakeargs+=(
-D3RDPARTY_QT_DIR="${ESYSROOT}/usr"
-DBUILD_SAMPLES_QT="$(usex examples)"