summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-12-11 09:49:32 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-12-11 11:15:16 -0500
commit8446d91279ec4b4c8058ab3a8b6eb9696c5dda7e (patch)
tree535dcccee98b20b379df1173d88074173b2b8969 /sci-libs
parentwww-client/firefox-bin: add 133.0.3 (diff)
downloadgentoo-8446d91279ec4b4c8058ab3a8b6eb9696c5dda7e.tar.gz
gentoo-8446d91279ec4b4c8058ab3a8b6eb9696c5dda7e.tar.bz2
gentoo-8446d91279ec4b4c8058ab3a8b6eb9696c5dda7e.zip
sci-libs/fplll: add 5.5.0
Closes: https://bugs.gentoo.org/946180 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fplll/Manifest1
-rw-r--r--sci-libs/fplll/fplll-5.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index a47edd02beb0..5566b85d76ba 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1 +1,2 @@
DIST fplll-5.4.5.tar.gz 2630275 BLAKE2B 43d1601f401c3a4eba60939028b26f99d32f92b9d53b763768427d05b2d709645532c4fbb14556c8d8d92cc14efe86468469ed69a77bdb03af75ec08499cc17e SHA512 3e1281f1b993ebe4a767b7fc526f49a27d58f24b1b4c6074310cc971f6f569388d6ba27102087a2eb11671d2d5b87bd60306e2597567f4ae8dd2a9efd13beb77
+DIST fplll-5.5.0.tar.gz 2633527 BLAKE2B 47a5b53fea261cb08ac04a939108414f692280806a7c12ebf851f309cfccbeb360dd1777ac595e9eacae1f23b51c6437c11c91964a04242f3a45af9f8b28de75 SHA512 c070dab206ebf692aa2afd8e6cdf412b5497488e8205332b4b726dd69283f415f86d1bcb55937a678cacd47b2068eea3f776eae8e050c4096e48d1cefd3de291
diff --git a/sci-libs/fplll/fplll-5.5.0.ebuild b/sci-libs/fplll/fplll-5.5.0.ebuild
new file mode 100644
index 000000000000..fc8117803c94
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="qd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}