summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-20 11:15:37 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-20 11:15:37 +0100
commit99c0df70d4f13359cdfbfabc1bcd978e8ac8fb90 (patch)
treeb8d2256d01ac7cfb0b91cf7f960ae7e5e37002d3 /sci-mathematics/dataplot
parentsci-mathematics/coq: Remove old (diff)
downloadgentoo-99c0df70d4f13359cdfbfabc1bcd978e8ac8fb90.tar.gz
gentoo-99c0df70d4f13359cdfbfabc1bcd978e8ac8fb90.tar.bz2
gentoo-99c0df70d4f13359cdfbfabc1bcd978e8ac8fb90.zip
sci-mathematics/dataplot: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/dataplot')
-rw-r--r--sci-mathematics/dataplot/Manifest1
-rw-r--r--sci-mathematics/dataplot/dataplot-20090821.ebuild82
-rw-r--r--sci-mathematics/dataplot/files/Makefile.am.2009082146
-rw-r--r--sci-mathematics/dataplot/files/configure.ac.2009082176
4 files changed, 0 insertions, 205 deletions
diff --git a/sci-mathematics/dataplot/Manifest b/sci-mathematics/dataplot/Manifest
index 400f30f2d684..5cce0ff1a381 100644
--- a/sci-mathematics/dataplot/Manifest
+++ b/sci-mathematics/dataplot/Manifest
@@ -1,3 +1,2 @@
DIST dplib.2009_07_15.tar.gz 7507367 BLAKE2B 5eec49feb1e90d479547955e5717e8e49eed18f78bae5942881511becf517986c8ba8e2f7513000c52fbb1686cc31fadf38ac61fb1f0822283f6b4fa9dd6431b SHA512 5e4e6c866a5690c3f67b322d53b6bf1bec33c488a99c95f360ce74785a57286541945fdcab5cbbacb04039046f5ba94aeaf8112b80aa34ed2c2cf04abc6f7d40
-DIST dpsrc_2009_08_21.tar.gz 6656048 BLAKE2B 69f5a141cc17ec6c9d8b52fc0dfd546be6cbc06b859cac0fd318f80f31829ae76596c430ec0ae61eaf7d557fca728af9ef9efd88ee2213c4908976d2c91689c4 SHA512 1e655c6832b724b9f69692f28f5497fb4064d208cde5462c4bd73c8d255605ba62b9b703f5ea32bbe7506b18ccd0ad5c4c2556381fbebdb6e05ce51625a4a339
DIST dpsrc_2013_12_20.tar.gz 6761551 BLAKE2B 029d278ebc025d0e902b2b37743f0ad53c567463d7929d69c7c1fe291b9355c29766035b9747f184ca28035eac2954ad391a7039da7151e7a5391ba123c6ac3f SHA512 a62df14f3ec59ccae4ead52b34adfc6e881ade1397e5a31b8a73c9740e7a2245317fef4f9756224c8d2fb57799c2247b15f6c4d65777de6302553fd138bb4083
diff --git a/sci-mathematics/dataplot/dataplot-20090821.ebuild b/sci-mathematics/dataplot/dataplot-20090821.ebuild
deleted file mode 100644
index bf52682525e4..000000000000
--- a/sci-mathematics/dataplot/dataplot-20090821.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils fortran-2 toolchain-funcs autotools
-
-# YEAR MONTH DAY
-MY_PV=${PV:0:4}_${PV:4:2}_${PV:6:2}
-MY_P=dpsrc_${MY_PV}
-# MY_PV_AUX usually ${MY_PV}
-MY_PV_AUX=2009_07_15
-MY_P_AUX=dplib.${MY_PV_AUX}
-
-DESCRIPTION="Program for scientific visualization and statistical analyis"
-HOMEPAGE="https://www.itl.nist.gov/div898/software/dataplot/"
-SRC_URI="
- ftp://ftp.nist.gov/pub/dataplot/unix/${MY_P}.tar.gz
- ftp://ftp.nist.gov/pub/dataplot/unix/${MY_P_AUX}.tar.gz"
-
-SLOT="0"
-LICENSE="public-domain"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples gd opengl X"
-
-REQUIRED_USE="opengl? ( X )"
-
-COMMON_DEPEND="
- media-libs/plotutils
- opengl? ( virtual/opengl )
- gd? ( media-libs/gd[png,jpeg] )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- X? ( x11-misc/xdg-utils )"
-
-S="${WORKDIR}/${MY_P}"
-S_AUX="${WORKDIR}/${MY_P_AUX}"
-
-src_unpack() {
- # unpacking and renaming because
- # upstream does not use directories
- mkdir "${S_AUX}" || die
- pushd "${S_AUX}" > /dev/null || die
- unpack ${MY_P_AUX}.tar.gz
- popd > /dev/null || die
- mkdir ${MY_P} || die
- cd "${S}" || die
- unpack ${MY_P}.tar.gz
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-opengl.patch
- cp "${FILESDIR}"/Makefile.am.${PV} Makefile.am || die
- cp "${FILESDIR}"/configure.ac.${PV} configure.ac || die
- sed -e "s:IHOST1='SUN':IHOST1='@HOST@:" \
- -e "s:/usr/local/lib:@datadir@:g" \
- dp1_linux.f > dp1_linux.f.in || die
- sed -e "s/(MAXOBV=.*)/(MAXOBV=@MAXOBV@)/" \
- -e "s:/usr/local/lib:@datadir@:g" \
- DPCOPA.INC > DPCOPA.INC.in || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable gd) \
- $(use_enable opengl gl) \
- $(use_enable X)
-}
-
-src_install() {
- default
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S_AUX}"/data/*
- fi
- insinto /usr/share/dataplot
- doins "${S_AUX}"/dp{mes,sys,log}f.tex
- doenvd "${FILESDIR}"/90${PN}
-}
diff --git a/sci-mathematics/dataplot/files/Makefile.am.20090821 b/sci-mathematics/dataplot/files/Makefile.am.20090821
deleted file mode 100644
index e10cf41ebd54..000000000000
--- a/sci-mathematics/dataplot/files/Makefile.am.20090821
+++ /dev/null
@@ -1,46 +0,0 @@
-bin_PROGRAMS = dataplot
-dataplot_SOURCES = dp1_linux.f \
- dp2.f dp3.f dp4.f dp5.f dp6.f dp7.f dp8.f dp9.f dp10.f dp11.f \
- dp12.f dp13.f dp14.f dp15.f dp16.f dp17.f dp18.f dp19.f dp20.f dp21.f \
- dp22.f dp23.f dp24.f dp25.f dp26.f dp27.f dp28.f dp29.f dp30.f dp31.f \
- dp32.f dp33.f dp34.f dp35.f dp36.f dp37.f dp38.f dp39.f dp40.f dp41.f \
- dp42.f dp43.f dp44.f dp45.f dp46.f \
- dpcalc.f dpdds2.f dpdds3.f dpdds.f edinit.f edmai2.f edsear.f edsub.f \
- edwrst.f fit3b.f starpac.f tcdriv_nopc.f aqua_src.f cluster.f compgeom.f \
- optimi.f libplot_src.c rldp.c main.f
-
-if ENABLE_GD
-dataplot_SOURCES += gd_src.c
-else
-dataplot_SOURCES += gd_src.f
-endif
-
-if ENABLE_GL
-dataplot_SOURCES += gl_src.c
-else
-dataplot_SOURCES += gl_src.f
-endif
-
-if ENABLE_X11
-dataplot_SOURCES += x11_src.c
-else
-dataplot_SOURCES += x11src.f
-endif
-
-dataplot_CFLAGS = @GL_CFLAGS@
-dataplot_LDADD = @GD_LIBS@ @GL_LIBS@ @X11_LIBS@ $(FLIBS) -lreadline
-
-# this is to remove ambiguity between the similar filenames
-# of the c and f77 version (shortcoming of automake)
-# the f77 versions are forced
-# the c versions objects are called dataplot-gd_src.o etc
-gd_src.o: gd_src.f
- $(F77COMPILE) -c -o $@ $<
-gl_src.o: gl_src.f
- $(F77COMPILE) -c -o $@ $<
-aqua_src.o: aqua_src.f
- $(F77COMPILE) -c -o $@ $<
-libplot_src.o: libplot_src.f
- $(F77COMPILE) -c -o $@ $<
-rldp.o: rldp.f
- $(F77COMPILE) -c -o $@ $<
diff --git a/sci-mathematics/dataplot/files/configure.ac.20090821 b/sci-mathematics/dataplot/files/configure.ac.20090821
deleted file mode 100644
index fa9a700aa060..000000000000
--- a/sci-mathematics/dataplot/files/configure.ac.20090821
+++ /dev/null
@@ -1,76 +0,0 @@
-AC_PREREQ(2.59)
-AC_INIT([dataplot], [20090821], [n.heckert@nist.gov])
-AC_CONFIG_HEADER([config.h])
-AC_CONFIG_AUX_DIR(config)
-AM_MAINTAINER_MODE
-AM_INIT_AUTOMAKE([foreign])
-
-AC_PROG_CC
-AC_PROG_F77
-AC_F77_LIBRARY_LDFLAGS
-case $F77 in
- *gfortran*) FFLAGS="${FFLAGS} -w -fno-range-check" ;;
- *) ;;
-esac
-
-AC_CANONICAL_HOST
-case $host in
- i?86*linux*) MAXOBV=100000 ;;
- *64*linux*) MAXOBV=1000000 ;;
-esac
-AC_SUBST(MAXOBV)
-
-AC_ARG_ENABLE(gd,
- [AS_HELP_STRING([--enable-gd], [Enable the gd device driver])],
- [enable_gd=$enableval],
- [enable_gd=no])
-
-AC_CHECK_LIB(plot, pl_closepl_r, ,
- [AC_MSG_ERROR([plotutils libraries not found])])
-
-AC_ARG_ENABLE(gl,
- [AS_HELP_STRING([--enable-gl], [Enable the OpenGL device driver])],
- [enable_gl=$enableval],
- [enable_gl=no])
-
-AC_ARG_ENABLE(X,
- [AS_HELP_STRING([--enable-X], [Enable the X11 device driver])],
- [enable_x11=$enableval],
- [enable_x11=no])
-
-if test x"$enable_gd" = x"yes"; then
- AC_CHECK_PROG(enable_gd, [gdlib-config],,
- [AC_MSG_ERROR([GD driver requested but gdlib-config not found])])
- GD_LIBS="`gdlib-config --libs` -lgd"
- GD_CFLAGS="`gdlib-config --cflags`"
- AC_SUBST(GD_LIBS)
- AC_SUBST(GD_CFLAGS)
-fi
-AM_CONDITIONAL(ENABLE_GD, [test x"$enable_gd" = x"yes"] )
-
-if test x"$enable_gl" = x"yes"; then
-dnl hardcoded opengl libs (should be host/implementation dependent)
- AC_CHECK_HEADER(GL/gl.h,,
- [AC_MSG_ERROR([OpenGL driver requested but header gl.h not found])])
- AC_CHECK_HEADER(GL/glu.h,,
- [AC_MSG_ERROR([OpenGL driver requested but header glu.h not found])])
- GL_CFLAGS="-DUNIX_OS -DAPPEND_UNDERSCORE -DSUBROUTINE_CASE"
- AC_SUBST(GL_CFLAGS)
-
- AC_CHECK_LIB(GL, glXCreateContext, GL_LIBS="-lGL",
- [AC_MSG_ERROR([OpenGL driver requested but libraries not found])])
- AC_CHECK_LIB(GLU, gluPerspective, GL_LIBS="-lGL -lGLU",
- [AC_MSG_ERROR([OpenGL driver requested but libraries not found])])
- GL_LIBS="-lGL -lGLU"
- AC_SUBST(GL_LIBS)
-fi
-AM_CONDITIONAL(ENABLE_GL, [ test x"$enable_gl" = x"yes" ])
-
-if test x"$enable_x11" = x"yes"; then
- PKG_CHECK_MODULES(X11, x11,,
- [AC_MSG_ERROR([X11 driver requested but pkgconfig module not found])])
-fi
-AM_CONDITIONAL(ENABLE_X11, [ test x"$enable_x11" = x"yes" ])
-
-AC_CONFIG_FILES([Makefile DPCOPA.INC dp1_linux.f])
-AC_OUTPUT