summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-11-19 10:12:36 -0800
committerJason Zaman <perfinion@gentoo.org>2022-11-19 10:23:24 -0800
commit9e64b84c2b5bf0dfe077b6f0257374d3d8d40d40 (patch)
tree24aabf7822eb026c72b2e40d283a2a4664006f35 /sci-visualization
parentsci-libs/keras: drop 2.8.0, 2.9.0 (diff)
downloadgentoo-9e64b84c2b5bf0dfe077b6f0257374d3d8d40d40.tar.gz
gentoo-9e64b84c2b5bf0dfe077b6f0257374d3d8d40d40.tar.bz2
gentoo-9e64b84c2b5bf0dfe077b6f0257374d3d8d40d40.zip
sci-visualization/tensorboard: drop 2.8.0, 2.9.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.8.0.ebuild64
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.9.0.ebuild66
3 files changed, 0 insertions, 132 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 15c3f7786956..472537c49964 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,3 +1 @@
DIST tensorboard-2.10.0.zip 5873469 BLAKE2B b03a804682275abd83482e6dc8e62bef4301d796ef5bd2b02bed8d15ab16ff4bd19f1b9e3488e12ea6c03e1b7a85fd69a6a226f0a5378da2067c661b7f1f2f7e SHA512 04da20089d7e24e2c519da24bb8ad32f622386799e28403e036d40c29bc99011cc374480176776b0801df0e37eb2b0e93a987d2a97cd7406eabb75bfd649a311
-DIST tensorboard-2.8.0.zip 5776309 BLAKE2B b06c740fbe01c707e937018184e286fb7221391715c5ca6d843a89c9dd3a364b8693e748ccbde735d074b0abdbca65d4e2dd9a6e57b4ede61f78a661bd16e702 SHA512 3d937e41ac0abfe44cfab12f0b5269de45615c512499107a239bb348df7f3ccaabf283afcea2a7bac4a34d7b9318947c709a84154d0d2e61912138c31c86673f
-DIST tensorboard-2.9.0.zip 5797045 BLAKE2B e91988637a0e30fcd6341f02bc5e83ba92ae1f6e65a2aa5ddb1626ec4bb95a97d1306984b899279281e5d5f5ac70be76669ddc87524910861429e02259269b79 SHA512 244e117de989a56efc4120b6374d5cc6c31bb233e234cf95df9ddf7cbd0ec494b925dae238c59f3663087136bbf789284096f20b300f0b4c56c9de7faddc520b
diff --git a/sci-visualization/tensorboard/tensorboard-2.8.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.8.0.ebuild
deleted file mode 100644
index 8923ebaec0e7..000000000000
--- a/sci-visualization/tensorboard/tensorboard-2.8.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8,9} )
-inherit python-r1
-
-DESCRIPTION="TensorFlow's Visualization Toolkit"
-HOMEPAGE="https://www.tensorflow.org/"
-SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
- >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
-BDEPEND="app-arch/unzip
- ${PYTHON_DEPS}"
-PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"
-
-src_prepare() {
- eapply_user
-
- sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
- "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
- grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
-
- find "${S}/${PN}" -name '*.py' -exec sed -i \
- -e 's/^from tensorboard\._vendor import /import /' \
- -e 's/^from tensorboard\._vendor\./from /' \
- {} + || die "failed to unvendor"
-
- rm -rf "${S}/${PN}/_vendor" || die
-
- sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
- sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
-}
-
-src_install() {
- do_install() {
- python_domodule "${PN}"
- python_domodule "${P}.dist-info"
- }
- python_foreach_impl do_install
-}
diff --git a/sci-visualization/tensorboard/tensorboard-2.9.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.9.0.ebuild
deleted file mode 100644
index 33cd44742483..000000000000
--- a/sci-visualization/tensorboard/tensorboard-2.9.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-inherit python-r1
-
-DESCRIPTION="TensorFlow's Visualization Toolkit"
-HOMEPAGE="https://www.tensorflow.org/"
-SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
- >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
-BDEPEND="app-arch/unzip
- ${PYTHON_DEPS}"
-PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"
-
-src_prepare() {
- eapply_user
-
- sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
- "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
- grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
-
- find "${S}/${PN}" -name '*.py' -exec sed -i \
- -e 's/^from tensorboard\._vendor import /import /' \
- -e 's/^from tensorboard\._vendor\./from /' \
- {} + || die "failed to unvendor"
-
- rm -rf "${S}/${PN}/_vendor" || die
-
- sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
- sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
- sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
- || die "failed to relax oauth deps"
-}
-
-src_install() {
- do_install() {
- python_domodule "${PN}"
- python_domodule "${P}.dist-info"
- }
- python_foreach_impl do_install
-}