summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-04-03 14:06:26 +0200
committerZac Medico <zmedico@gentoo.org>2023-04-05 19:58:13 -0700
commit70fb119a972f04d0c8192cce7c8ff87e2509c08c (patch)
tree489d61f76e7d818d5c52f5ad2922440761875056 /sys-apps/flatpak
parentapp-admin/awscli: Bump to 1.27.107 (diff)
downloadgentoo-70fb119a972f04d0c8192cce7c8ff87e2509c08c.tar.gz
gentoo-70fb119a972f04d0c8192cce7c8ff87e2509c08c.tar.bz2
gentoo-70fb119a972f04d0c8192cce7c8ff87e2509c08c.zip
sys-apps/flatpak: add systemd flatpak-update.{service.timer}
Closes: https://github.com/gentoo/gentoo/pull/30459 Closes: https://bugs.gentoo.org/903735 Signed-off-by: Florian Schmaus <flow@gentoo.org> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-apps/flatpak')
-rw-r--r--sys-apps/flatpak/files/flatpak-update.service11
-rw-r--r--sys-apps/flatpak/files/flatpak-update.timer9
-rw-r--r--sys-apps/flatpak/flatpak-1.14.4-r1.ebuild (renamed from sys-apps/flatpak/flatpak-1.14.4.ebuild)6
3 files changed, 25 insertions, 1 deletions
diff --git a/sys-apps/flatpak/files/flatpak-update.service b/sys-apps/flatpak/files/flatpak-update.service
new file mode 100644
index 000000000000..07330552f7d6
--- /dev/null
+++ b/sys-apps/flatpak/files/flatpak-update.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Update system Flatpaks
+After=network-online.target
+Wants=network-online.target
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/flatpak --system update --assumeyes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/flatpak/files/flatpak-update.timer b/sys-apps/flatpak/files/flatpak-update.timer
new file mode 100644
index 000000000000..f34af44de847
--- /dev/null
+++ b/sys-apps/flatpak/files/flatpak-update.timer
@@ -0,0 +1,9 @@
+[Unit]
+Description=Update user Flatpaks daily
+
+[Timer]
+OnCalendar=daily
+Persistent=true
+
+[Install]
+WantedBy=timers.target
diff --git a/sys-apps/flatpak/flatpak-1.14.4.ebuild b/sys-apps/flatpak/flatpak-1.14.4-r1.ebuild
index 16d18d1775bf..859b8ef2a2a8 100644
--- a/sys-apps/flatpak/flatpak-1.14.4.ebuild
+++ b/sys-apps/flatpak/flatpak-1.14.4-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9,10,11} )
-inherit linux-info python-any-r1
+inherit linux-info python-any-r1 systemd
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
DESCRIPTION="Linux application sandboxing and distribution framework"
@@ -105,4 +105,8 @@ src_install() {
find "${ED}" -name '*.la' -delete || die
# resolve conflict with acct-user/flatpak for #856706
rm -rf "${ED}/usr/lib/sysusers.d"
+
+ if use systemd; then
+ systemd_dounit "${FILESDIR}"/flatpak-update.{service,timer}
+ fi
}